Confirmation popup problems

Hello, I come to the forum because I’ve been trying to solve this problem for a few hours and I’m not successful.

I’m trying to log into the Apps and when would I open the trezor confirmation window “TrezorConnect | Trezor”, it opens for about 2 seconds and closes by itself, even before anything appears on the page, so I can’t confirm anything and use my trezor. I was using it normally a few hours ago and this problem just started. The same problem is happening on Ronin and Metamask.

I’m using mozilla, but I’ve already tested it in chrome (here the page doesn’t even open). I’ve done every possible procedure that came to my mind and that I found by researching.

I’ve already cleared the cache, updated the trezor firmware, reinstalled the bridge and the suite, restarted the PC, changed the usb port trezor, disabled ADblock, changed the Safety check to prompt, among others.

I leave here the image of what appears on the console, if that helps.

I’m using a Trezor One, Windows 11, I tested it on Firefox and Chrome.

1 Like

Hi @druyda,

Many of us have experienced the same phenomenon of “2 sec display of Trezor Connect”. I my case it got more stable (less erroneous) when I started to use Firefox with Metamask instead of Chrome, but it’s still not completely gone and happens now and then.

To inform those who are experiencing the same problem, I tested some other things, like using trezor on another computer, the problem remained the same, so I imagined that the problem could be directly in trezor, and I downgraded the trezor version from 1.10.5 to 1.10.4, after that the problem was solved in my case.

Interesting. Thanks for reporting this. I thought the potential problem was related to the Trezor Connect webpage, especially after seeing your screenshot above with the page errors.

Like many people (MANY PEOPLE) my Trezor is essentially useless and will not allow me to interact with any dapps thru metamask as the 1st pop up allowing you to connect your trezor and export the pubkeys disappears in about 2 secs. SOMEHOW THIS ISSUE IS ALL OVER THE INTERNET AND TREZOR HAS SAID AND DONE NOTHING ABOUT IT. None of the so-called fixes work.

I cant use your product and my money is stuck in this POS until i buy a different hardware wallet and import my wallet. So so so so bad. Fix this issue !!!

  1. the issue is not reproducible all the time, our QA has tested it over and over, it needs some specific setup and mostly occurs when using Dapps and other networks.

  2. if you have anything relevant to add, then please add it here:

  3. you can restore your wallet on any other wallet of your choice at any time using your seed words.

1 Like


See this post. It can be multiple issues - memory leak, iFrame timeout, uninitialized variable, or other things. I’d advise your developers to look closely into the javascripts used in Trezor Connect.

Trezor confirmation page disappears after a couple of seconds. What to do? I’m using MM and Chrome on Mac

Did anyone find a solution to this by any chance? Cannot believe this hasn’t been fixed by Trezor yet, considering it renders the device unusable without major effort…makes me want to buy Ledger and forget I ever gave this a chance…

You still experiencing this issue till now ? @deXempo

I am indeed. I have everything up to date, mm as well as trezor firmware, using Brave browser with addblock turned off for dapps, still it just wont do more than couple of trxs before it starts acting up again. Only solution I found working is to close the browser, disconnect trezor, sometimes I reboot even to make it work.

I found the solution to it that’s why I’m asking if you still experiencing the issue so I can direct you @deXempo


If your solution can help others, please post it here.

Hahaha :joy: :joy: @Petosiris he has no solution, he’s just lurking around

Always. :wink: And I’ve suggested a few things about how to solve this issue before.

1 Like

As stated above,

I know that this is a common bug that happens to Trezor when it links with Metamask and have read through many threads here & reddit.

Tried most of the solutions but still cant seem to solve this annoying bug.

Using Trezor Model T and use chrome, both is updated to latest.

I’ve clear my cache on chrome, unplug n replug in Trezor, check my usb ports as well.

It works sometimes after 1 or 2 transactions then it will go missing again.

Thank you and hope somebody can assist on this.

1 Like

I have found a solution for the “Confirmation popup appears and closes in a few seconds”. I have had the same problem for more than one year and can´t access my coins on DEFI protocols with metamask.

The solution is easy: Download Microsoft EDGE + metamask + connect to your Trezor. It will say that Metamask is working primarily with Google Chrome and Mozilla Firefox, agree and continue with EDGE and it will be working!

In one WORD: use EDGE and it will be OK!

If you want to support me: BTC: bc1qx2utcw7zucvhc2vapyyf2y4ntk9s5t7h8kck85
LTC: ltc1q6ay5h3ck94ggcgde457scqwp4d9u5h4wysxjum
ETH: 0xE6330215e3907B382dc41417d87df604448f5889

1 Like

Interesting. Is this always the case? How long have you been using Edge in combination with Metamask and Trezor?

Hi everyone,
I solved this issue. (Don`t click on the checkboxes druing the prompt!)

Here step by step

First to clean up:

  1. Delete cach
  2. restart your PC/MAC
  3. Insure browser is on latest version and latest firmaware installed on trezor.

After this is done you should now get the prompt (once) again. DO NOT CLICK on the checkboxes!!!

  1. “Don’t ask me again”
  2. “Remeber this device”

After NOT clicking the checkboxes it has been working fine for me.


Hit i cant get throug loading…any suggestions ?