Confirmation popup appears and closes in a few seconds

Hello, I come to the forum because I’ve been trying to solve this problem for a few hours and I’m not successful.

I’m trying to log into the Apps and when would I open the trezor confirmation window “TrezorConnect | Trezor”, it opens for about 2 seconds and closes by itself, even before anything appears on the page, so I can’t confirm anything and use my trezor. I was using it normally a few hours ago and this problem just started. The same problem is happening on Ronin and Metamask.

I’m using mozilla, but I’ve already tested it in chrome (here the page doesn’t even open). I’ve done every possible procedure that came to my mind and that I found by researching.

I’ve already cleared the cache, updated the trezor firmware, reinstalled the bridge and the suite, restarted the PC, changed the usb port trezor, disabled ADblock, changed the Safety check to prompt, among others.

I leave here the image of what appears on the console, if that helps.

I’m using a Trezor One, Windows 11, I tested it on Firefox and Chrome.

1 Like

Hi @druyda,

Many of us have experienced the same phenomenon of “2 sec display of Trezor Connect”. I my case it got more stable (less erroneous) when I started to use Firefox with Metamask instead of Chrome, but it’s still not completely gone and happens now and then.

To inform those who are experiencing the same problem, I tested some other things, like using trezor on another computer, the problem remained the same, so I imagined that the problem could be directly in trezor, and I downgraded the trezor version from 1.10.5 to 1.10.4, after that the problem was solved in my case.

Interesting. Thanks for reporting this. I thought the potential problem was related to the Trezor Connect webpage, especially after seeing your screenshot above with the page errors.