[INFO] Trezor stuck in bootloader mode (1.10.0) during firmware update

Trezor Model One users are having trouble updating firmware with Trezor Suite and are stuck in bootloader mode. If this is the case, try to update the firmware via Trezor Wallet: https://wallet.trezor.io/#/

Here is a tutorial: User manual:Updating the Trezor device firmware - Trezor Wiki

Then you should be able to use Trezor Suite again.

hi - I did manage to update the firmware to the latest version after I got into bootloader mode, but I am seeing the below on Suite without my device being connected (!!!). Trezor web works but I have lost Trezor suite desktop after the update on the 15th of September.

Can you please assist ? Using Trezor 1 on a Mac. I also tried uninstalling and re installing suite and that did not work either.

1 Like

Hi, i have same problem, also mac (os Catalina) and Trezor 1. But something is different, i can “switch device” and have there one active (green) and one inactive (red) named trezor. When i click on green, i can choose from standard or passphrase. When i choose passph i can “login” and see my accounts and adresses. but when i choose “standard wallet” its shows me that picture and return me into welcome page…

I am getting the exact same thing :frowning: I am also able to switch device but its getting me nowhere.

I think there could be some issues with cache because I still see my previous name trezor with default name, but I renamed him… so when I connect my white trezor everything is fine, but when connect black there is that problem…

I tried connect it via web page and it works normal. So it’s somewhere at cache or suite perhaps :man_shrugging:t2: But I am not IT pro so don’t know what to do :thinking::face_with_raised_eyebrow:

we are both failing under the same OS so … it looks like a problem with the update. never had issues since day 1 with suite.

1 Like

Same issue. After Trezor firmware update desktop app dont work anymore: Writes that “Trezor is in bootloader mode” and I cannot go further.

Web application is working.
Reinstall of desktop app dont fix issue.
Desktop app showing same screen when trezor is disconnected.

OS:
macOS Big Sur 11.5.2
Trezor Suite version:
21.9.2

1 Like

Guys, i find temporally solution… i think that all happend because is passpharase activated after entering hidden wallet.

So i went to web application, write pin, in window with passphrase leave blank and enter, than click trezor and advanced settings, there is passphrase encryption and i turn it off.

when it is done, i turn trezor suite and switch device - it will connect me to trezor, +add wallet, write pin and its done - standard wallet is ready and balanced.

BUT, it still shows me it is hidden wallet → picture…

than, when i try to log into hidden passphrase wallet i have to turn on passphrase protection, and it shows me hidden wallet - and its allright.

BUT and there is problem, when disconect trezor and trying to connect again to “standard wallet” theres that problem - duplicate passphrase etc etc… and again :smiley:

I’m experiencing the same issue with Trezor Suite on Mac. Is there anyone from Satoshi Labs tech support aware of it?

Hi, yes we are currently monitoring the issue and our QA team is already on it.
As soon as the GitHub issue will be created I will post it here in the thread so you can stay updated.

For now, whoever will encounter this issue could you please provide Trezor Suite log (go to app settings- in right up corner and then click on three dots and Show log):

Or pls provide answers to following questions:

What firmware version did you update from/to?
What version of Trezor Suite do you have?
What version of Trezor Bridge do you use?
Do you use web interface or app ?
If you use web interface, what browser do you use?
What operation system do you use?

Thank you for the cooperation.

1 Like

Thank you MichalZ,

Here are the answers to your questions.

BTW Trezor Suite thinks there’s a Trezor attached even when there isn’t. Upon startup it says: “This Trezor is in bootloader mode” and it’s not possible to remove this warning.

What firmware version did you update from/to?
Sorry I don’t remember.

What version of Trezor Suite do you have?
Version 21.9.2 (21.9.2.13354)

What version of Trezor Bridge do you use?
2.0.27

Do you use web interface or app ?
Usually the app but having to use the web now.

If you use web interface, what browser do you use?
NA

What operation system do you use?
MacOS 11.6

1 Like

GitHub issue created:

Hi, guys, something happend, when i crossed from Catalina to mac BigSure 11.6… theres no longer issue with dubbled passphrase… :slight_smile: and welcome screen dont show attached trezor :slight_smile:

Trezor suite version is 21.9.2.

Log added Je to tam. Úspěšně uloženo | Ulož.to

I am still struggling . Trezor team - you need to make this work on Catalina from what it seems . The latest update did not dix it…

I tried everything: resetting the app, wiping off the device. Nothing worked.

@Cryptotechgr this issue is suppose to be fixed in November release.

1 Like

thx a mil @MichalZ . do you have an estimate on when in November this will be released ? Can you please also inform Jirka from your team ? He does not seem to be in line with this info.