Trezor suite incorrect find my hidden wallet empty

How can I get access to hidden wallet? Trezor suite report that it is empty, but it is not empty and it works fine using Metmask. I can access all tokens in Metamask typing in
the passphrase. But Trezor suite reports empty … That is not good because I have some
tokens that are not supported by Metamask so I can only access them from TS. What to do?

1 Like

What is wrong with the Trezor app? It reports my hidden wallet + passhrase for empty, but I can use Trezor with Metmask and passphrase to swap on Uniswap. I have tokens
that are not erc-20 that I currently cannot access because they are not supported by
Metamask … What to do? I run the newest version of Trezor app and newest firmware on device.

1 Like

My hidden wallet + passphrase works fine in Metamask but comes up empty in
Trezor suite. It used to work fine, I think the problem has started after updating
Trezoe suite. How can I get access to my non ec-20 tokens on the Trezor?

Please make sure you have your coins enabled in Suite settings. Suite will not scan coins that are not enabled.

You also need to make sure that your internet connection is working and that Suite can connect to the backends. If you are getting discovery errors, it’s possible that Suite cannot load your coins and thinks the wallet is empty.

Try enabling or disabling Tor and turning off any VPNs you may be using.

Making multiple forum posts very rarely helps resolve this kind of problem, and neither does it cause faster response times.

1 Like

I have tried all those things: coins are enabled, internet i working, no discovery errors when I open wallet without passphrase, have tried enable tor in settings, have turned off vpn and tried again. There is no doubt there is a Trezor suite bug in various versions of the software and possibly interlinked with various firmware versions of the device. It always works in metamask, confirm the passphrase on the device, can swap on uniswap, same passphrase (exactly the same) always returns empty wallet in Trezor suite.

1 Like

You are using Metamask so I’m assuming you use Ethereum.

Do you have any ETH in the first address? That is, if you compare your Ethereum address that is linked in your Metamask, and the (empty) Ethereum address that Suite gives you, are they the same?

If yes, that indeed indicates some sort of Suite bug.

If not, then (a) you’re actually using a different passphrase in Suite and in Metamask, or (b) you are using some other than the first address in Metamask. That will make your funds invisible to Suite.

Which specific currencies are you trying to load in Suite that are not supported by Metamask?

Obviously they are not the same because if they were the same I would be in the right wallet. I get a new wallet from TS with the same seed + passphrase compared to the same seed + passphrase on trezor with metamask

1 Like

How do I choose which address to load? Can I manually change the address from the new wallet to the one in metamask?

1 Like

You don’t. Suite will only see the first address. You might be able to click “add account” to add the second, third, etc., but usually this is only enabled if you have non-zero history in the first address.

But Metamask support for Ethereum ecosystem is far more complete than Trezor Suite’s. It is very unlikely that Suite sees some Ethereum-based tokens that Metamask doesn’t.

So, again,

You mentioned at start that …

…so they are presumably on a different network than Ethereum. Is that network enabled in your Suite settings?

Also, it is still possible that your “non-erc20 tokens” live under a different passphrase than the one you are using for Metamask.

1 Like

Network enabled? They are there as an account … No, it is the same seed and same passphrase. I have just now managed to recover my non-erc20 tokens by using an
old laptop that has a years old trezor suite installed, and by plugging the device into it and typing in my passphrase and eveything worked and looks normal and my coins are there. And I have sent them to secure storage on a centralised exchange. On the PC I installed the same old version of Trezor suite from github, and tried again there, but alas same result: empty wallet. So that means, the bug is not on the device, not the seed and not an incorrect passphrase. When I enter the passphrase I check it by clicking the eye icon so that is why I am 100% confident that
the passphrase is entered correctly.

1 Like

Glad you managed to access your funds, but this is still rather strange.

Your tokens are listed under Ethereum account?

And you see them in a years-old Suite, but not in up-to-date Metamask?

Have you tried adding the token by contract address? Go to the Tokens tab, then click “Add token”.

You seem to misunderstand everything I have written.

It is Trezor suite that returns empty wallet. Metamask + Trezor works fine.

i mean, I thought the whole time that we are talking about tokens that you don’t see in Metamask?

you know, from this:

or am I to understand that Metamask sees the tokens but can’t send them??

You are dodging the issue by pretending to misunderstand. I can see that other people have had this problem as well, from another post on this forum:

1 Like

You should also look at the post below where OP admitted hee was using wrong passphrase.

What coins are we talking about here, the only “non erc20” coins you can see in Suite are natively supported ones which have nothing to do with ETH or ERC20 so you cannot see them in MM, For ex. you cannot see Bitcoin in Metamask.

I am doing the opposite of “dodging the issue”. I am trying to get enough information to investigate the issue.

So far you told us that some old Suite version works for you, and the newest one doesn’t, but havent told us what exactly doesn’t work.

It shows your wallet as empty, with a passphrase that we believe is correct. Okay. What else? You haven’t answered:

  • which coins are supposed to be there that aren’t
  • are those coins enabled in Suite settings?
  • if the coins in question are Ethereum tokens, have you tried manually adding them via the “Add token” button? if yes, did that work?

Mystery solved!

The Trezor software indeed report the wallet as “empty”, and then presents a new empty wallet … But when adding the accounts for tokens, they are there! … So when the TS reports “empty wallet” it is misleading because the wallet is not empty and it gives the user the impression that the passphrase was entered incorrectly, or incorrectly calculated by the application.

No mistyped passphrase, just Trezor suite incorrectly reporting that the wallet is empty.

Erc20 and non-erc20 was enabled in my wallet, and after updating TS and logging in 14 days later, poof all coins disabled and TS incorrectly reporting “empty wallet”. How did that happen … Defintely some improvements required for the user experience.

Keep in mind that Ethereum ERC20 tokens are not shown at your total balance and that you need to go to.the Ethereum tab and there to the Tokens tab. It would be nice if Trezor also includes the value of these tokens in the total balance.