Opensea and MetaMask will not allow signing of transactions to place items for sale that are stored in my Trezor wallet

I’ve been using Opensea with my metamask wallet for some time, but last night I decided to transfer all of my high-dollar NFT’s to my Trezor wallet for secure storage. I sent all the tokens and have verified that they are on the Trezor wallet directly and not in a Metamask wallet address. When attempting to place items for sale on Opensea, it pops up to ask me to sign the transaction on my Trezor, however each time that I confirm the transaction, the Opensea page said “You have declined this action in your wallet”.

I need to figure out the solution to this issue as it is extremely important to me that I’m able to store and sell these NFT’s from my hardware wallet. If I am not able to do this with my Trezor, I am going to have to find a hard wallet that works with Opensea, and I really would prefer to stick with what I currently have and enjoy.

Also, it won’t allow me to send the tokens back to myself in the Metamask wallet for the same reason, after I sign the transaction on the Trezor, Opensea tells me that the transaction was declined in my wallet. How can I fix this?

Hi, I have just set up my Trezor and connected it to my MetaMask wallet and sent some NFTs there. However, when I try to list an nft on opensea or sign any contract, I am met with an error message saying “You declined the action in your wallet.”. I don’t actually get sent to a page to connect my Trezor and don’t get given an option to confirm my transaction on my Trezor either. The transaction is just automatically declined somehow.

Does anybody know what could be causing this issue? Any help would be greatly appreciated.

1 Like

I’m having a similar issue, except my transaction is actually sent to me to confirm on the Trezor, and after confirmation, it gives the same error on opensea of “You have declined the action in your wallet”. It’s obviously something on Trezor’s end that needs fixing, and it’s crazy that they haven’t handled it yet when Ledger has been supporting NFT’s for so long…

Trezor doesn’t support storage of NFTs, so please don’t try to send them to your Trezor. However, I know of at least one wallet which support storing NFTs in a Trezor authorized wallet. The NFTs are then stored in the website’s wallet and Trezor is only used to authorize login and transactions on the 3rd party website. Maybe Opensea is one such website too, I don’t know, I have no personal experience with Opensea.

Hi @ShortyOG

The thing is Trezor doesn’t support NFTs, hence if you sent these to Trezor generated address you wouldn’t be able to sign such transaction.

See a similar issue, if interested

So, when using MetaMask you must use its default account for these TXs, not the one generated by/paired with Trezor.

The theoretical solution here would be recovering your Trezor seed by using MetaMask. Since both Trezor and MM follow BIP-39, you should be able to do that. Once it’s done, you should be able to spend these tokens by using MM.

Beware; we do not recommend recovering Trezor seed by using other apps for security reasons. Therefore, do this only on your own responsibility. If you are about to do this anyway, consider moving your other funds to safe place to minimize the potential risk in case your seed would be compromised.

Further, the solution suggested above has not been tested. Therefore, do your own research beforehand.

3 posts were merged into an existing topic: Metamask and OpenSea no longer interact with my Trezor

@pavel and @Petosiris
Thank you for the informartion above. What I get, trezor doesn’t support NFT at the moment. What I would like to ask are :

  1. Can I transfer any nft which is owned under metamask to my trezor metamask (trezor is the signer of any activity under this metamask) ?
  2. Should I can, how the way to do it? Just transfer it to my trezor metamask account as I transfer token?
  3. I am not sure of point 2 since as I know, metamask extension doesn’t support NFT right now

Your advice please.

Thanks in advance

No, don’t do that. If your Trezor is connected to Metamask then the NFTs you transfer to that Metmask account will likely go to your Trezor and Trezor doesn’t support NFTs.

Let your NFTs reside where you bought them and wait for Trezor to support them, or transfer them to an account somewhere else which support NFTs.

1 Like

Will Trezor ever support NFTs? I have an Ember Sword Land and I can’t sell it.

ok so i’m having the same issue with my metamask/trezor but only when i try to cancel a listing on Opensea. the trezor page opens and immediately closes, and the site says i declined the action in my wallet while my metamask shows a failed transaction with zero gas fee and nothing on etherscan. i can still list items from my trezor/metamask linked account, and i have cancelled listings from this account numerous times in the past. i’m just not sure how to get around it now, resetting the account gets rid of the failed transaction but it happens again as soon as i try to cancel a listing after.

edit: and now i had the same event happen when trying to mint something. immediately opening and closing the confirmation page and said transaction declined in wallet.

Hi @chester97 ,

I had same issue this morning. Same message ‘You declined the action in your wallet’. FYI, this is my chronology.

  1. Send small amount NFT to trezor on metamask to test
  2. Send back succesfully from trezor to metamask on opensea
  3. Send big amount of NFT to trezor on metamask
  4. Can’t send back my big amount of NFT to metamask

I found 3 alternative solutions on problem no 4 above, on this forum and reddit :

  1. Connect your trezor account to MyEtherWallet and send NFT from there
  2. Import your trezor seedphrase to other NFT supported wallet such as metamask, trustwallet, or ledger
  3. Update the firmware of trezor to the latest version

No 1 and 2 solution didn’t work for me. Eventually the easiest solution which is no 3 worked for me.

Hope you can solve the issue soon.

Happy to help should you have more question.

Thank you

the issue is with MM and will be fixed once they do the update

I’m pretty sure that the underlying issue is not related to NFT’s. I use metamask with trezor for NFT’s everday. Metamask can connect directly with Trezor to do almost any web3 operation. Metamask generates the message that trezor signs and uploads to the blockchain.

The underlying issue that OP is bringing up is related to signing transactions, which @forgi mentions. I currently have issues with trezor signing for token approvals. If I create an LP on a decentralized exchange, trezor doesn’t know how to sign the approval. I think the issue is related to EIP-712 signing. If you need to access NFT’s with trezor, you should be able to connect metamask to your trezor and send them to another account or directly access opensea. I haven’t tried using opensea with trezor, but I do know that they require signing for listing. Some signing methods don’t work with trezor.

You definitely do not need to recover your account with a seed phrase to access the NFT.

2 Likes

why is this guy a ‘leader’ when he has no idea what he is talking about? ‘storing NFTs’? they are just tokens that go in any eth wallet. Trezor works great for most NFTs, just not polygon atm

you are mentioning old post from September, now it has been implemented

Opensea is good with Trezor, except for polygon

It is just an eth address. I have been using a trezor for NFTs for almost a year

it just wasn’t supported officially

For your information:

But great first post in these forums, @Crypple! I have downgraded myself so my trust level won’t bother you anymore.