Metamask and OpenSea no longer interact with my Trezor

After the big suite update, I no longer can interact with MetaMask and OpenSea. What happened to the bridge? Why break all compatibility like this? I’ve now got two transactions in limbo and another missing transaction because of this. Any ideas?

Hi @TREZORMONSTER

First; Trezor Suite launch doesn’t have any impact on MetaMask - OpenSea interaction.

Second; please, check the suggestions below.

  • Make sure, your Trezor is running the latest firmware.

  • Also, make sure you are running Trezor Bridge 2.0.27. Check it’s running properly, seek for “trezord” process in your task monitor. If there is no “trezord” process running on the background, and you are getting no results on http://127.0.0.1:21325/status/, then Trezor Bridge is either not installed or doesn’t run properly. Reinstall it from this source https://wallet.trezor.io/#/bridge. Then, try it again, please (preferably with both supported browsers; Chrome and Firefox in incognito/privacy mode).

  • Use supported browsers only. Either Chrome or Firefox (try both and try using Incognito/privacy mode as well).

  • Clear your browsers cache.

  • Not only using a VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.

  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.

me and my friends have the Same issue with my ETH address storing NFT using Trezor.

Please help! any update version of trezor can solve this problem? especially for the generated address.

Just use metamask (use trezor seed) but no such address found, just other address…

Please suggest another method or develop related nft software we needed. thanks

[email protected]

similar:
I’ve been using Opensea with my metamask wallet for some time, but last night I decided to transfer all of my high-dollar NFT’s to my Trezor wallet for secure storage. I sent all the tokens and have verified that they are on the Trezor wallet directly and not in a Metamask wallet address. When attempting to place items for sale on Opensea, it pops up to ask me to sign the transaction on my Trezor, however each time that I confirm the transaction, the Opensea page said “You have declined this action in your wallet”.

I need to figure out the solution to this issue as it is extremely important to me that I’m able to store and sell these NFT’s from my hardware wallet. If I am not able to do this with my Trezor, I am going to have to find a hard wallet that works with Opensea, and I really would prefer to stick with what I currently have and enjoy.

I have an NFT in ETH address
When I transfer my NFT to another Wallet though opensea,
i enter pin and approve. It shows me : you decline your action in wallet

try so many time, it shows you decline your action in wallet or no response

really sad, could you help me to send the NFT? I found some related topic, its about EIP 712, does Trezor T adopt it?

also, i recover the metamask acc by using another browser, it just show few address i used, no the address i mentioned before. how can i find them?

really frustrated.

hard wallet: trezor
broswer: brave

Could you please help me? my family need me and money.
thanks
[email protected]

or can i export private key for my address, and use another wallet to control the wallet? Please help

hi @littlefireson

as NFTs are officialy not supported by Trezor, this is out of scope of this forum.

However I suggest you to downgrade your MetaMask to the version 9.8.4 as your issue might be related to Metamask having issues with HW wallets related to EIP 1559.

You can use following manual:

  1. go to brave://extensions/ or chrome://extensions/

  2. switch on Developer Mode

  3. disable current MetaMask extension

  4. download the 9.8.4 zip file from: https://github.com/MetaMask/metamask-extension/releases

  5. drag and drop that zip file in your browser window

  6. MetaMask installation procedure should pop up

Use this old extension for the time being, use the average gas price as seen at https://etherscan.io/gastracker

Trezor’s business decision not to support NFTs “officially” is incomprehensible, a significant strategic error on the part of the company. Sadly, I did not know this before purchasing because it was not mentioned anywhere in the sales information for Trezor. No one likes throwing money away.

sigh.

ok… just bought the Trezor wallet specifically for NFT’s.

guess it’s return it and buy a competitor :\

any suggestions? i bought the Ledger X, had an setup issue… opened a case, and got zero support.

Are there any hardware wallet vendors that actually have a support team? suggestions?

jim

Collum: The only company that directly responded to a request for customer service assistance was SafePal. I haven’t really used the wallet yet, so I can’t speak to that, because they, too, aren’t up to date with NFTs. For that reason, I’ll just have to use for tokens, which doesn’t help you. But I can attest to their responsiveness to inquiries. This is good to keep in mind when they do fully support NFTs. I’ve gone back to Ledger, but their customer service is non-existent.

Please, always check the offical Supported coins & tokens list before you decide to buy. There’s also differences between Trezor Model One and Model T.