Cannot transfer funds out of my metamask hardware wallet ▫

I connected my hardware wallet using the metamask chrome extension and successfully transferred funds into it. Funds can be seen in the metamask wallet but not in my trezor suite. However, I have never succeeded in transferring the funds out.

The steps I took to attempt transferring out:

  1. I go into hardware wallet in metamask and click “Send”
  2. I select the account address to send it to.
  3. there is a link to bring me to log in to trezor. I logged in using both my pin and passphrase.
  4. The transaction is initiated but in the metamask activity link, i only see “Pending”.
  5. I have tried to up the gas, change wallet address, change coin type, etc., but all failed.

Can someone explain what I can do?

1 Like

When using third-party apps, beware, some of them create their own default wallet, different from a Trezor generated one. (For recovering such wallet you would need a recovery seed related to this wallet which is different from Trezor generated wallet.)

Once you initialize MetaMask wallet, there is a default account created (the red one in the picture). If you wish to use it, then you need to keep your MetaMask seed phrase to recover and access this account whenever needed. This account is not a part of Trezor wallet.

On the contrary, there are Trezor accounts (the yellow and the blue one in the picture). The same accounts are generated in MEW, Trezor Suite etc. These are Trezor generated accounts and can be recovered only by using Trezor recovery seed.

Basically, the explanation of your issue is that the particular address (account) you refer to is not part of your (current) Trezor Wallet. Even though Trezor is not connected, in MetaMask you can still see;

  1. your default MetaMask account,
  2. also your previously used Trezor generated wallet(s) with different seed(s),
  3. and also your Trezor generated wallet(s) with passphrase(s)

All three wallets mentioned (1, 2, 3) would differ from your currently used Trezor Wallet. Only the first MetaMask account (1) you can use without your Trezor because it’s independent on Trezor completely.​

However, as for other accounts (2, 3) you may see, the related Trezor wallet must be connected (either with the appropriate seed and/or with the appropriate passphrase). Otherwise, you wouldn’t be able to sign any transactions within these accounts due to missing the appropriate private key stored on Trezor. And that’s when it gets frozen.

Simply put, if you are unable to access that account by using Trezor Suite, then this account you want to access via MetaMask is not part of your Trezor wallet.

is this resolved? i have same issue. i cannot transfer/swap the token inside the MM w/ trezor wallet. BTW, it in the BSC network. BNB to be exact. “unknown address”


Are you able to access the address from which you are trying to send in MEW ?

1 Like

I am sorry what is MEW?
If this the address in metamask w/ trezor, yes i can access it. I can see my tokens there but i cannot moved it to another MM (normal). Even swaping, it cannot proceed

1 Like is different Ethereum wallet.
Please connect your Trezor, export your public keys and enter passphrase (if the address from which you are trying to spend is in hidden wallet) and check if this address is on the list of addresses you are offered to access (as shown below):

1 Like

i cannot see my address in here. i tried with passphrase and without passphrase

1 Like

if you can’t see your address in the list, then you are accessing wrong wallet = using different combination of seed and passphrase.

that’s why you are getting unknown address error in Metamask as well.
Metamask is preventing you from spending your funds because (appropriate) private key is missing. These private keys for signing transactions are derived from the combination of seed stored on Trezor device and passphrase (if enabled and used). Hence, if different seed and/or a different passphrase is used then the private key differs and cannot be used.
In such case, previously generated wallets/accounts in third-party apps would become watch only wallets without the possibility spending the funds.

Please note that you might have made a typo when “setting” the passphrase in the first place so in order to be able to access the desired address or sign the transaction from this address you will need to reproduce same typo.

Passphrase is case sensitive so lowercase and uppercase characters are distinguished and count as different and space is a valid character as well.

1 Like

hi @MichalZ, thank you for helping out. I still cannot see my address in the MEW but i finally access my MM w/ trezor. i search for my notes and i found 2 passphrase in it. Thankfully 1 works. i can now send/swap tokens. thank you so much.


No worries, you are welcome.
I’m glad that your issue has been resolved :wink:

1 Like


I have the same problem !!

I cannot transfer funds from my trezor wallet … 0xC47906De13F00dDcB16F5b1392F9A55cE1Fb0E02

I try also with the MEW but the metamask stop to work (crashes) and dont finish the transaction

please can you help me !


1 Like

anyone found an answer to this? got my tokens trapped in my metamask bsc hardware wallet :frowning: i cant withraw them

Same exact issue, please, can anyone help?
p.s not a hidden wallet

cant buy on uniswap,
cant move funds between my accounts
and can’t sand to exchange

Finally found the work around. disable paraphrase and security check in trezor app. thank me later :slight_smile:

1 Like

In this case setting safety checks to prompt won’t affect the ability of signing the transaction.
So I assume it was again just a passphrase issue. If you were trying to sign the transaction from the address created in your Standard (not passphrase protected) wallet you either disable the feature in Suite (or via Trezor ctl) or leave the passphrase blank when prompted and proceed without it…

My problem continues
is not the passphrase

Hi @magno, could you clarify whether you have troubles with making q transaction (Trezor freezes, Metamask crashes, you receive an error message etc), or whether you cannot see your funds (and your usual receiving address) in your wallet in the first place? If you are getting any errors, please post a screenshot of it here.

1 Like

all was fine but than
I try to send funds to another wallet
and the metamask crashe and if dont crashe is like a infinite loop
I can see all my funds and dont show any error

this is the wallet

Hi, my problem is similiar:
I transfered tokens (matic) to Metamask account connected with Trezor.
While trying to send them out, MM asks me to:

  1. Export public keys
  2. Enter passphrase (not relevant)
  3. Enter Pin
  4. And then it freezes. The loading gif is displayed, which also freezes - does not even turn around and around.
    I guess it’s the same error as magno.
    Tried multiple times. Eventually blockchain sends: transaction failed.
    Pls help
    Edit: Tried disabling Safety Checks, Metamask still crashes.
1 Like