Address unknown trezor metamask ▫

Did you even bother to read these posts?

oooh wait, a Trezor fanboy, fight until dead for that company of bugs

There were three cases mentioned

Which one is yours?

Please be civil and don’t use name calling in these forums!

I have replicated the bug several times to corroborate and record it.

If you have documentation of the bug you claim to’ve found, please upload this to SatoshiLabs in a ticket email so they can look at it. Or you can post it here.

2 Likes

Hi Jose,

keep the communication in friendly and respectful manner please.

If the way you communicate won’t change, appropriate steps will be taken.

Thank you for understanding.

Hi @Grampas

Indeed, be very careful and

  1. Make sure, you set up BSC correctly
    https://forum.trezor.io/t/does-trezor-support-matic-polygon-and-binance-smart-chain-under-metamask/575/2
  2. More important, make sure you are accessing an account related to seed stored on your Trezor device and that you are entering the correct passphrase. Otherwise, you won’t be able to sign any transactions within these accounts due to missing the appropriate private key stored on Trezor.
    https://forum.trezor.io/t/cannot-transfer-funds-out-of-my-metamask-hardware-wallet/1000/2
  3. And lastly; since BSC network uses BNB as Gas, make sure you have enough funds to cover fees as well.
1 Like

Having the same issue. Did you guys manage to find a solution?

Here is what happened to me -

  • Connected Metamask to Hardware wallet
  • Selected one of Trezors Metamask Hardware wallets
  • Having issues processing transactions (unknown address)
  • Decided to try using another device and when I tried to connect the Hardwallet, the number wasnt available in the Trezor list

This is the hardware wallet number Trezor gave me and now it is not on the list of Trezor hardware wallets anymore 0x9885E186f39Dfead2098e8f48Db061e30F84EAc9

Hi @pankekosdz
See below

2 Likes

@pavel @RaaazorPowerUser
So if your HW wallet is linked to MM’s seed phrase, You are saying it is Metamask’s Problem to fix correct?
With MM’s new update 10.0.3
I personally Get through the transaction as if it were good, but only once sending out of the Metamask linked seed phrase hardware wallet, I get a Metamask error at the bottom right corner of my screen saying “Transaction 0 Failed! Error: Error: Unknown address”
Even tho i am able to send coin Into the wallet, and it is confirmed on Eth scan when it is sent.
But transaction out of this account Never make it to eth scan.

When using MetaMask default account, then HW doesn’t have to be paired with MM at all because MM seed is used for signing TXs. The default MM wallet is completely independent on Trezor no matter if it’s connected or not.

But, if multiple wallets previously have been created in MM by using Trezor seed (and passphrase), the same seed and passphrase must be used to sign those TXs.

Actually, that’s where the confusion comes from. MM create multiple wallets for you but they become watch only wallets if the initial seed and (the passphrase), from which the wallets were derived, is not used.

Have you tried using another compatible app e.g. MyEtherWallet, MyCrypto, Trezor Suite etc.?

If so, how did it go?

1 Like

Yeah you didnt answer the question, These hardware wallets were created before trezor suite came out.
Once we updated Our Metamask hardware wallets were obsolete, and now we can not transfer out.

How does this have to do with our seed phrase when, we have our Separate seed phrases, Trezor suites AND our OLD HW on MM that is only accessable once the trezor wallet is unlocked via trezor suite.

Yes they are Watch only Hardware accounts, but your saying this is from a Seed phrase which Makes no sense, and the Passphrase was never set up to begin with.
Trezor suite contains the only Password protected Wallet I own and Isn’t part of the issue.

Trezor Suite works just fine, the NEW Hardware wallets it creates work JUST FINE. Our Accounts are linked to Meta mask seed phrase because trezor Suite is NEW.
Fyi Both seed phrases are correct and backed up and Verified multiple times to be correct, so is this Metamask’s fault or Trezor’s? Idk.

Metamask’s latest update 10.0.3 - I now get the error at the bottom right corner of my screen.
Metamask’s 10.0.2 update - The transactions out of this MM linked hw account would Not assign a Nounce number, nor show up on Eth scan and it would Forever Pend.
Metamask’s 10.0.1 update was the latest one to actually work, and every Update that came out Before Trezor Suite seemed to be very compatible with this MM HW wallet linked to trezor.

So as you can see we all seem to be saying the same thing. It’s either Trezor’s Suite + Upgrade.
OR Metamask’s hardware wallets are not compatible with Trezor Suite.
Ty for you time @pavel @RaaazorPowerUser

Trezor Suite is only one of many compatible app with Trezor device. Suite has nothing to do with your MM accounts whether you are able to access these or not.

Incorrect. Just leave the passphrase dialog blank, skip it, and you will enter your default passphrase non protected wallet.

Again, the magic formula from which wallet is generated is seed & passphrase (if used) no matter what app is used.

You can recover your wallet with any compatible app or any other hw wallet following bip39.

It doesn’t matter what app you use whether it’s MM, Suite, MyCrypto. By using the same seed and the same passphrase you always get the same, based on public key cryptography.

Actually, that’s one of the greatest advantage being able to recover your wallet any time, in case your physical hw wallet is lost, damaged etc.

@RaaazorPowerUser You Just Reiterated what was said already in this thread sir.
PLEASE ANSWER MY QUESTION AND STOP GIVING RUN AROUNDS LIKE META MASK AND TREZOR SEEM TO LOVE TO DO.

We All Should know how to access the Standard vs Password wallets it is VERY simple to grasp sir.
It seems you did not read what i wrote, “Trezor Suite works just fine, the NEW Hardware wallets it creates work JUST FINE. Our Accounts are linked to Meta mask seed phrase because trezor Suite is NEW.
Fyi Both seed phrases are correct and backed up and Verified multiple times to be correct, so is this Metamask’s fault or Trezor’s?” maybe @pavel has a brain and eye balls to help further, we are all praying for some decent advice here.

1 Like

Hi Shmoopy,

please be so kind to keep the conversation polite and friendly.

Thank you for understanding.

1 Like

I am :green_heart: sorry, it was very early.

Thanks for your reply.

How is that account not part of my Trezor wallet if it´s a Hardware account created using “Connect Hardware Wallet”? It was a number that I picked from the list of accounts Trezor has.

Did something make it stop being part of my wallet?

I have the EXACT same problem as others here. Every time I try to make an exchange or approve a transaction I get the “unknown address” error. I can still transfer out to my other MM wallets but cannot make purchase transactions on Uniswap. I seems there are a LOT of others with this issue and the lack of empathy from Trezor in this thread is disturbing.