Address unknown trezor metamask ▫

Same issue here and I realized that I may misspell my passphrase when I created and I lost that wallet (forever?). So I think we should have something that can recover our wallet from this situation ,but need kyc or something to verify the owner.


@opt1m1st_13 Please, see post above Address unknown trezor metamask ▫ - #19 by pavel

@Frankzeneta If you misspell passphrase, new wallet is created. The same wallet is accessed only when the same recovery seed and the same passphrase is used. Learn more about passphrase:

same error, anyone found a solution?

i found a bug, sometimes to connect trezor to metamask dont syncro with true addres of your trezor and sow you others addres, at the first time when you connect your trezor if it this happend and you transfer all your currencies to that addres you will lost all , becouse when you want to retire to other wallet at time for connect to trezor this makes an error. (unknown address).
clap clap clap trezor, super useless. you made me lose 2.5 bnb

This doesn’t sound like a bug in Trezor. However, there’s a virus out there now which changes addresses you input. This could be your problem. Always double check the address is correct before you send.

im not talking about ronin, im talking about metamask, and its a bug. I have replicated the bug several times to corroborate and record it. sometimes the addres of trezor suit does not match with the addres what metamask show you, therefore if you use one of those addresses you will lose all the coins.
and the double check is only for outgoing transactions not for incoming transactions.

Hi @Jose_Loren_Garcia


Also, read post below, very carefully. MetaMask accounts explained.

1 Like

yes yes, trezor is perfect and inhackeable, one user found a bug and- ooh no its a bug, caution with bla bla bla…

Did you even bother to read these posts?

oooh wait, a Trezor fanboy, fight until dead for that company of bugs

There were three cases mentioned

Which one is yours?

Please be civil and don’t use name calling in these forums!

I have replicated the bug several times to corroborate and record it.

If you have documentation of the bug you claim to’ve found, please upload this to SatoshiLabs in a ticket email so they can look at it. Or you can post it here.


Hi Jose,

keep the communication in friendly and respectful manner please.

If the way you communicate won’t change, appropriate steps will be taken.

Thank you for understanding.

Hi @Grampas

Indeed, be very careful and

  1. Make sure, you set up BSC correctly
  2. More important, make sure you are accessing an account related to seed stored on your Trezor device and that you are entering the correct passphrase. Otherwise, you won’t be able to sign any transactions within these accounts due to missing the appropriate private key stored on Trezor.
  3. And lastly; since BSC network uses BNB as Gas, make sure you have enough funds to cover fees as well.
1 Like

Having the same issue. Did you guys manage to find a solution?

Here is what happened to me -

  • Connected Metamask to Hardware wallet
  • Selected one of Trezors Metamask Hardware wallets
  • Having issues processing transactions (unknown address)
  • Decided to try using another device and when I tried to connect the Hardwallet, the number wasnt available in the Trezor list

This is the hardware wallet number Trezor gave me and now it is not on the list of Trezor hardware wallets anymore 0x9885E186f39Dfead2098e8f48Db061e30F84EAc9

Hi @pankekosdz
See below


@pavel @RaaazorPowerUser
So if your HW wallet is linked to MM’s seed phrase, You are saying it is Metamask’s Problem to fix correct?
With MM’s new update 10.0.3
I personally Get through the transaction as if it were good, but only once sending out of the Metamask linked seed phrase hardware wallet, I get a Metamask error at the bottom right corner of my screen saying “Transaction 0 Failed! Error: Error: Unknown address”
Even tho i am able to send coin Into the wallet, and it is confirmed on Eth scan when it is sent.
But transaction out of this account Never make it to eth scan.

When using MetaMask default account, then HW doesn’t have to be paired with MM at all because MM seed is used for signing TXs. The default MM wallet is completely independent on Trezor no matter if it’s connected or not.

But, if multiple wallets previously have been created in MM by using Trezor seed (and passphrase), the same seed and passphrase must be used to sign those TXs.

Actually, that’s where the confusion comes from. MM create multiple wallets for you but they become watch only wallets if the initial seed and (the passphrase), from which the wallets were derived, is not used.

Have you tried using another compatible app e.g. MyEtherWallet, MyCrypto, Trezor Suite etc.?

If so, how did it go?

1 Like

Yeah you didnt answer the question, These hardware wallets were created before trezor suite came out.
Once we updated Our Metamask hardware wallets were obsolete, and now we can not transfer out.

How does this have to do with our seed phrase when, we have our Separate seed phrases, Trezor suites AND our OLD HW on MM that is only accessable once the trezor wallet is unlocked via trezor suite.

Yes they are Watch only Hardware accounts, but your saying this is from a Seed phrase which Makes no sense, and the Passphrase was never set up to begin with.
Trezor suite contains the only Password protected Wallet I own and Isn’t part of the issue.