Address unknown trezor metamask ▫

Trezor Suite works just fine, the NEW Hardware wallets it creates work JUST FINE. Our Accounts are linked to Meta mask seed phrase because trezor Suite is NEW.
Fyi Both seed phrases are correct and backed up and Verified multiple times to be correct, so is this Metamask’s fault or Trezor’s? Idk.

Metamask’s latest update 10.0.3 - I now get the error at the bottom right corner of my screen.
Metamask’s 10.0.2 update - The transactions out of this MM linked hw account would Not assign a Nounce number, nor show up on Eth scan and it would Forever Pend.
Metamask’s 10.0.1 update was the latest one to actually work, and every Update that came out Before Trezor Suite seemed to be very compatible with this MM HW wallet linked to trezor.

So as you can see we all seem to be saying the same thing. It’s either Trezor’s Suite + Upgrade.
OR Metamask’s hardware wallets are not compatible with Trezor Suite.
Ty for you time @pavel @RaaazorPowerUser

Trezor Suite is only one of many compatible app with Trezor device. Suite has nothing to do with your MM accounts whether you are able to access these or not.

Incorrect. Just leave the passphrase dialog blank, skip it, and you will enter your default passphrase non protected wallet.

Again, the magic formula from which wallet is generated is seed & passphrase (if used) no matter what app is used.

You can recover your wallet with any compatible app or any other hw wallet following bip39.

It doesn’t matter what app you use whether it’s MM, Suite, MyCrypto. By using the same seed and the same passphrase you always get the same, based on public key cryptography.

Actually, that’s one of the greatest advantage being able to recover your wallet any time, in case your physical hw wallet is lost, damaged etc.

@RaaazorPowerUser You Just Reiterated what was said already in this thread sir.
PLEASE ANSWER MY QUESTION AND STOP GIVING RUN AROUNDS LIKE META MASK AND TREZOR SEEM TO LOVE TO DO.

We All Should know how to access the Standard vs Password wallets it is VERY simple to grasp sir.
It seems you did not read what i wrote, “Trezor Suite works just fine, the NEW Hardware wallets it creates work JUST FINE. Our Accounts are linked to Meta mask seed phrase because trezor Suite is NEW.
Fyi Both seed phrases are correct and backed up and Verified multiple times to be correct, so is this Metamask’s fault or Trezor’s?” maybe @pavel has a brain and eye balls to help further, we are all praying for some decent advice here.

1 Like

Hi Shmoopy,

please be so kind to keep the conversation polite and friendly.

Thank you for understanding.

1 Like

I am :green_heart: sorry, it was very early.

Thanks for your reply.

How is that account not part of my Trezor wallet if it´s a Hardware account created using “Connect Hardware Wallet”? It was a number that I picked from the list of accounts Trezor has.

Did something make it stop being part of my wallet?

I have the EXACT same problem as others here. Every time I try to make an exchange or approve a transaction I get the “unknown address” error. I can still transfer out to my other MM wallets but cannot make purchase transactions on Uniswap. I seems there are a LOT of others with this issue and the lack of empathy from Trezor in this thread is disturbing.

I also get this error in MM for the hardware wallet.

I’d love to jump into a call with @pavel or someone from the Trezor team to walk me through the process of getting my funds out this account.

I’d be willing to record the call and the whole process and then upload it here to help all others solve their issues.

@pavel and Trezor Team, would you be willing to assist me with this? I’ve filed a support ticket on the official channel and still haven’t heard anything back from the Trezor team.

Yo pude resolver este inconveniente que seguramente es lo que les pasa a muchos de por aquí, el error es que cuando conectan su metamask y despues dan click en conectar su billetera de hardware la primera vez les pide una frase de contraseña y si escriben mal algo genera claves completamente diferentes cada vez, con lo que si el error les sigue saliendo, cierren su navegador y vuelvan a abrirlo vuelvan a entrar a conectar su billetera de hardware por que les pedira otra vez esa frase contraseña, escríbanla bien esta vez y asi les saldra la wallet donde depositaron sus fondos, ami me paso que en mi contraseña cambie un 9 por un 8 y tuve que rastrear en que frase de contraseña se quedo mi wallet, pero su dinero si sigue ahí, amenos que hayan perdido su contraseña.

Saludos espero les sea de ayuda.

metamask error
Please help I have the same error. I need the funds badly to pay for my bills. It is my first time to use the metamask hardware wallet. I cannot transfer it out. The answers seem to be very confusing. I do not even use trezor suite. I just use it hardware wallet independently and confirm if a popup comes out.

image

I am having this exact same error. I don’t know what happened. It was my first time using Trezor to secure my assets but now, I can no longer withdraw them. I can attest that this issue doesn’t have anything to do with passphrase because I have never used passphrase when creating a hardware wallet synced with MetaMask.

Here’s my story:

I have connected my Metamask wallet to Trezor and selected one of the addresses from the list after the page where one has to input the passphrase. I did not input any passphrase and just hit enter. I now have 2 addresses in my Metamask, one is the default one after signing and the other one that is connected to my Trezor wallet.

I tried sending some funds to Trezor generated address in Metamask just to make sure that the new Metamask wallet connected to Trezor is working. The funds were received, however, the funds can no longer be transferred back to any other wallets. I am getting the error ‘Transaction 0 failed error: error: unknown address’. I even tried transferring funds between accounts but to no avail.

1 Like

I have sam problems and my crypto freeze too.
Why you don’t give usable solution @pavel

Same problem here, created a MM account with my Trezor T, no passphrase, and it’s impossible to make any transaction (unknown address error)

You use BSC network right?

Yes, I use BSC network

Me too , If you found solution please mention me,Thank

Are you checking “IN” transaction on BSCscan? I check already ,It do not have “IN” transaction.how about you?

Hi, I’ve recently got my trezor and have started using it.

When I set up the hardware wallet on Trezor it seemed very easy and I transferred my coins into it. I did a test run and transferred 1 token into hard wallet and then sent it back out to my other soft wallet. I then proceeded to transfer it all to trezor hard wallet.

However, upon trying to send some coins out from my wallet I get the attached failure.
unknown address

I believe it has something to do with the passphrase. I didn’t think there was a passphrase set up, but there must be because each time I use metamask it always ask for a passphrase when trying to make a transaction. So I may have just typed a random word to test it and I am now trying every single passphrase I could have used and it is not allowing me to send.

Could this happen because of the incorrect passphrase, or could it be something else?

Please help… If it is the passphrase I will create a excel sheet of thousands of words and go through one by one. If not and there is another solution I’d really like to hear.

Thank you.