Address unknown trezor metamask ▫

I have the problem that when I want to make a transaction, it gives me an error in the address to send funds between my metamask wallets, one for trezor hardware and the other normal

I also do not know how I can link my address of the trezor of metamask linked to the funds that it has to the metamask of the mobile since it tells me that the address is not valid

I would need help to be able to at least get the funds that if they entered the trezor

4 Likes

Hi @terzack

Please, see the following post explaining different accounts in MetaMask.

That does not make any sense, because then it is the same trezor when you link it with metamask that invites you to generate the wallet like this ??? You are telling me that there is no possibility of recovering my funds then because my trezor blocks being able to withdraw the funds but without being a wallet in my trezor … very logical, no?

Then according to your explanation. Not only does trezor invite me to create a non-existent wallet in the connection with metamask, but it also blocks my funds without it being trezor’s own system, because I don’t understand anything. So does it mean that I have lost my funds?

Thank you for your prompt response, I hope you can give me a solution to what I think is a problem of a bad connection between metamask and trezor even though it is sold as compatible and everything is great

And now that we get to the question quiz, is there a way to take this ‘virtual wallet’ and open it in another metamask? Because of course when doing the same process with my trezor in the metamas of the mobile or another browser, I cannot access that trezor account.

The fact is that the suite has recognized the trezor at least once … then it doesn’t end as overnight it fails after having to refresh the browser 20 times because it hangs loading the suite until it recognizes it

For being able to access the same wallets, the same accounts, and the same addresses in the same order, at the beginning there must be always the same formula.

As for Trezor, there is a recovery seed and (a passphrase) from which everything else is derived: Recovery seed Account private key Private key Public key → Address

As for MetaMask, there is a recovery seed, following the same pattern.

For any transaction to be signed, the appropriate private key must be used.

Well I will study the situation but you do not specify how I would have to proceed. And by the way if you tell me that for it to be a trezor account it has to appear as in the assumptions you indicated in the other post which were the yellow and blue ones. So if it is a trezor account since it puts hardware on the right side then I understand that it is my trezor’s problem but that the trezor suite has suddenly been blocked. Now I have to investigate to know how to solve a problem that should not have appeared and if so, it would have to have a ‘simple’ resolution

Anyway the most important of all this and that even nowhere has been answered or indicated is. How can I recover my trezor wallet linked to metamask as your supposed yellow and blue in another browser so as not to delete said account and not be able to recover it again? Because I have tried to do it but they keep appearing random addresses even using the seed of both trezor and metamsk and in no case can I recover my correct wallet address again

Obviously, you either used a different seed or a passphrase, or both.

Hw wallets don’t generate random results when the same seed and the same passphrase is used.

The only way to access your funds is to use the same seed and the same passphrase. No one can do that for you.

1 Like

You just need to read the entire thread and you may find out that this is not the problem. the problem is not that it does not access my trezor wallet, but that a transaction has been blocked because it puts an unknown address because the trezor suite has not worked well with the browser even though it had not failed until that opportune moment and it derives from the fact that I cannot access the wallet either with the seed or with anything in another browser because it is a wallet created by the trezor in metamask we go to the yellow and blue option that they have indicated in the other thread. and I cannot pass this wallet to another metamask from another browser because the seed is the metamask, despite the fact that hardware appears as indicated in the other thread regarding yellow and blue. So my question is how I can proceed to carry my wallet of the metamask linked to the trezor that has the metamask seed that has blocked any action in the trezor suite of my browser, and that no matter how much I try with the seed to move it, this address never appears from my wallet … my main account appears that yes but not the second one that is added by hardware and that is what I am asking about how I can make it appear in another browser in the metamask

If yr concern is yellow/blue acc, read carefully

In other words, anytime you use the same seed and passphrase no matter what app is used you would always get the same wallet with the same acc.

If you have any troubles with Trezor Suite, use any compatible app such as MyEtherWallet, MyCrypto etc.

Im having the same issues. Did you already found a solution on this? All my funds in metamask are gone that is linked to my trezor 1

I have the same issue… i guess the link between metamask and trezor doesnt work properly… how can we resolve it?? thanks for a quick help

Hey guys

Sorry to hear you have been experiencing difficulties. However, there is no such technical issue. As already mentioned, when the same seed (and the same passphrase) is used the same wallets, accounts, and addresses are generated no matter what app is used. It’s based on a public-key cryptography.

Double check the following:

Pair your Trezor device with any compatible app, such as MEW, MyCrypto, Trezor Suite etc. If you cannot see the address of yours, then you either used a different seed or a different passphrase.

Have you been using passphrase? If so, make sure you fully understand how passphrase works.

Beware, the only possible solution is to use the correct combination of seed (and passphrase).

just transferring funds from my trezor hardware wallet between my regular account wallet…

1 Like

Hi @onerolan
Have you tried to make this tx by using other compatible app?

@pavel You are probably not aware of the severity of this issue. It is no coincidence suddenly a lot of people come here with the same issue. I have been using Trezor since 2016, ETH on Trezor since 4 months.

Now, all of the sudden, my Trezor is not confirming Metamask transactions anymore with the “error: unknown address” error. Clearly, when I created the trezor address in metamask, Trezor was using a different privatekey than right now. I never used a passphrase, ever. So this is not the issue with me. Now this is… concerning to me. Very. I have - as you can imagine - 6 figure money on this eth address. And I am sure there are a lot more people like the people in this thread and me, who are just about to discover their funds are (hopefully) temporarily unmoveable. I hope you can find a solution to this very grave issue.

4 Likes

@pavel same issue here, after I updated the new ver. of trezor bridge, none transaction could be done on my metamask/trezor 1 wallet.

One other mate who have the similar issue pointed the reason to passphrase. I recall that after I upgrade trezor bridge, the popup window asked me to fill in passphrase and I skipped that. Actually I do have a passphrase. @pavel may I know where can I enable passphrase in metamask trezor bridge?

1 Like

and I agree with @softliner , the severity of this issue is not properly assessed.

2 Likes

Trezor is a single purpose computer for storing master private key only.

Hence, if you connect Trezor to any compatible app https://wiki.trezor.io/Apps you get always the same wallets, accounts, and addresses generated in the same order no matter what app is used (if the same seed & passphrase is entered).

Pair your Trezor device with any compatible app, such as MEW, MyCrypto, Trezor Suite etc. If you cannot see the address of yours, then you either used a different seed or a different passphrase.

Passphrase dialog shows up once public keys are exported. Navigate to Menu - Connect Hw Wallet - Trezor

Hi! I have same issue. My cryptocurrency is freeze now.

1 Like