When Opening a second Hidden wallet in Trezor, turning off a Coin deletes that coin from first wallet

Here is the Technical Problem. And it is a serious problem that MUST be corrected.

  1. I had 4753.538 Doge (over 800$ USD) in my first #1 Hidden Wallet with the DogeCoin flipped on.

  2. I opened a second hidden #2 wallet in my Trezor to use as storage for my mining rigs, which was for Ethereum only. On that Hidden wallet, I selected the ETH toggle switch for that coin and deselected DogeCoin switch, thinking that the Wallets are separate as far as listed coins showing.

Seemingly, turning the DogeCoin switch off on my #2 wallet, deleted all of my DogeCoins in my first #1 Hidden Wallet.
(There is no mention in the help screens that i could find that deselecting a coin in different wallet would delete the coins globally in all other wallets where that coin was active, even those containing coins).

This is a serious defect in the programing of the Trezor, where an individual should not be able to turn off a coin when there are coins of that specific type in another hidden wallet.
Secondly, currently when you choose a type of coin, that selection is a “global-selection” (unknown to me the Trezor owner). Where such Coin toggle-selector-switches should be able to select specific coins for each Hidden wallet “individually”. As in my case, I only wanted ETH in my second wallet (so I wouldn’t mistake one wallet for another, and transfer coins into the wrong wallet).

“As this is a defect in the Trezor programming”, and where my DogeCoins cannot be recovered in full, I fully expect to have all of my DogeCoins reimbursed by Trezor.io ASAP. With NO EXCUSES.
“Else I will go on a rampage with posts on every blog I can find to tell my story to the people.” Bad news travels faster than good news. And you need to update my Trezor with an update software, else refund my money for this one I just bought.

Additionally, you should / must fix this issue in your Trezor units. I can imagine how many people have run into this same problem, only to have unknowingly burned their coins in another wallet… like i did (I believe).
That is the only thing I can think of why my Dogecoins are not there, and my #1 hidden wallet is now totally empty as if a new wallet, with DogeCoin deselected on the #1 Wallet.

Also, I have big fingers, and your Trezor unit is way to small. It should be at least half the size of a common cell phone. Smallness is NOT always better. In addition something so small as your current Trezor is, makes it hard to handle, it also makes it hard to keep track of.
Additionally, you should have some kind of tracking mechanism in the Trezor to locate it. In the least a beeping sound that can be made by a Computer Browser screen to help locate it in a house or room.
Right now… you have made a device that is purposefully designed to loose, and burn coins.


turning your coins on/off in the settings does not delete your coins. Your coins are not in suite neither on the device, the are on the blockchain.

You didn’t loose anything, simply go back to that first wallet and turn on Doge back on.

If you don’t see it there, you are using wrong passphrase and opening new wallet. So check your spelling.

So, yes, coin selection is for entire device, not for a specific wallet, I see your point there. But your coins are not lost.

yes, our product team has this feedback and it will be considered for the future.

I don’t see any location mechanism happening anytime soon, for this, your Trezor would need to be connected by bluetooth or something else to some other device. This is a security risk, we are trying to minimize any possible attacks.

Your coins are never lost even if your device is lost or damaged, they are represented by your prive keys/seed, and you can recover it any time, please read: https://wiki.trezor.io/Seed

tried that already, and I am not using the wrong passphrase. I have the passphrase written right in front of me in my book. this is not the first time I have used this unit. I know what I am doing.
I have tried 30 times… and the wallet is empty. Both wallets are empty. But the second wallet should be empty.
I did turn on the DogeCoin toggle switch as you suggest. Still no coins. It is empty.

regarding the security risk… as I said, it could be a separate circuit that only actuates a small battery operated chirping or beeping speaker.

Can I delete this device, and use my recovery seed to try to recover my coins?

yes, you can, you will still need correct passphrase.

It is very much possible that you misstyped the passphrase the first time…and now you are opening new wallet because you are typing something different, remember every new even misstyped passphrase opens empty wallet

Ok… i deleted my trezor, and recovered the unit using my seed… and my wallet is still empty.
So if you say it can be recovered from the blockchain… what do you need from me to do that?

I have submitted a ticked already, but did not explain on the ticket what I thought had happened. Anyway, if what I thought had happened, is not the case, then someone hacked my Trezor, or some other debacle happened. My Ticket ID: 120486

Regarding my Passphrase… I wrote it down… and I have gone into my wallet many many times using that same password.

My second password was nearly the same as the first. And… I look at the password before I enter it… to make sure its the correct password. Keep in mind that the password shows on my computer screen, and on my trezor unit. There is no mistake on my part, I am sure of it.
Additionally, I have made NO WITHDRAWLS whatsoever. Only deposits.

I will answer your ticket, we will need more details.

Hey Forgi,
You know, you were correct. I did type my password incorrectly. So now I have to eat my own foot.

I made a pasphrase… this is the test
and the second wallet… this is the test2

I didn’t realize that I didn’t have a number on the first passphrase… and thought I did have a number 1 after the phrase. And thus created another wallet as you suggested. Anyway that is nice to know. Now I have to change my first passphrase and put a 1 after it.

Thank you for your time. Hope other people benefit from my fuckup.

no problem, it happens often…glad you found the coins

just keep in mind that you cannot “change the pasphrase”. You need to type in the passphrase that you want to create, this will create a new wallet and then you have to send coins there as a regular transaction.
Or you can keep using one where you already have them, up to you.

noteworthy scare. My heart skipped a beat.

For those who keep things organized, the small is easy to hide and carry. There are also many large hardware wallets on the market, some as large as mobile phones. I can tell you, that kind of experience doesn’t work at all !

Can I view the address of my previously created hidden account through the wallet client without entering a passphrase?

No, it’s not possible to view a Hidden wallet without entering a Passphrase. Even with entering the correct Passphrase and opening the Hidden wallet, it’s not possible to view its “address” (in the blockchain).

2 posts were merged into an existing topic: Trezor钱包连接metamask钱包创建的账户的问题!