Trezor : failed to execute 'transfer' on usb device: a transfer error has occured

this is my second time posting my issue with trezor third party wallet, previous post was deleted, not sure why .

ok this is the problem, I been using trezor for quite some time, its a great product never had any issue but
few days ago it started giving me headache. I tried to withdraw my asset but my metamask keep crashing. this is when I check my chrome log get the subjected error ( failed to execute ‘transfer’ on usb device: a transfer error has occured)

its been going on for couple of days so I decided to restore my wallet address to metamask with the same passphrase / seed and surprisingly my wallet address does’nt exist . whats going on? any help please. and please do not delete my post again. thanks

try to change more USB cables and make sure your Trezor bridge is running.

you are using wrong passphrase

im facing the same issue. I hope trezor will fix this. by the way this is error message I get

Error: Failed to execute ‘transferln’ on USBDevice’: A transfer error has occured.

I have try change my usb cable. but still no luck

Please do not double-post, @tarbus. Your message from the other thread was moved here. If you also have a problem with the pop-up window when confirming a transaction, then discuss it here.

I tried with many cable including brand new cable such as tetherpro and trezor bridge is also running in my system but still no luck and definitely not a wrong passphrase because I’m using this on daily basis.

at which point does this error occur? Show a screenshot or a video.

this error notification come from chrome browser. it occur after metamask freezes / hanged and eventually transaction will failed.


after seing this I decided to restore my address in metamask but that address cannot be found. that’s weird because I never change my pin/passphrase/seed and it was working fine 2 days ago. like I say use this wallet everyday for the past 13 months.


Unknown address error means you are using wrong passphrase, it is mentioned multiple times on this forum, you can search it.

Try Trezor Suite instead.

impossible. this is the same passphrase I been using everyday for the past 13 months.

are you sending ETH or tokens? Try Trezor Suite and find that address with balance in there with that passphrase.

im trying to send BSC token (bsud) . yeah I already did that but my address cannot be found. weird

it seems like trezor is having connection issue with metamask, it freezes even before any prompt to keyin pin or passphrase

on your screenshot you are trying to send a transaction without being connected, and this not possible.

MM asks for pin and passphrase when you plug in your device, troubleshoot connection issues like described here: How to troubleshoot Trezor connection issues - YouTube

Thanks for the YouTube link but still the same. This is very frustrating I have tried to restore my address in Linux (Debian 11) , macOS and windows 10 and my address cannot be found. What’s going on guys? I kept all my seedwords/passphrases in very organised manner. I’m definitely not a newbie with this stuff ,
trust me this is not about wrong passphrase. please focus on the real problem

If your address is not there then what transaction are you trying to make?

Can you conne t to Trezor Suite? With the PIN? You could have used wrong seed too.

I encounter the same issue before, bsc wallet in my trezor is gone. but didn’t send a ticket since there is not much in it.