Ronin + Trezor doesn't work - No login possible


It says you cannot install Ronin wallet in ingognito

same issue for almost 1week pls help us

we have same issue i cant even sleep thingking how to fix the problem pls help us to fix this thank you

he niyak pls help me to fix my problem i still cant open my axie account

Hi @GenZCrypto,
you can change the extension settings in a normal mode of browsing, and make it allowed to use it in the incognito mode as well.

Anyway, have you tried clearing your browser cache (and restarting the browser)?

If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet.

Trying it on another computer would be also helpful.

I have the same problem! can you resolve?

Hi!
Unfortunately, after downloading the Trezor Bridge and after confirming that my device is indeed connected, I still can’t log in to the marketplace using my ronin wallet that is connected to my Trezor. It only shows the trezor confirm button for the first try logging in, but doesn’t anymore on further tries. Still stuck in a loop of confirming on the ronin extension but nothing is happening. I also did the clearing the browsing cache but did not resolve the problem also. I will soon try the incognito mode way.

same issue here :frowning: any updates? any solution at all?

Same issue here. After my trezor update I can’t login even i put my old seed phrase for recovery. Im already do all steps even making wipe and put my old seedphrase again. Is there anyone can solve this problem? Even sending axie to other ronin address is not working because trezor got stuck after i put my pin. Please help us!

When using third-party apps, make sure to check all suggestions below:

  • Update Trezor firmware.
  • After successful installation of Trezor Bridge, you should see “trezord” process running in your activity/system/task monitor. If you cannot see the process running in the background, please try to reinstall it again, from this source Trezor Wallet
  • Then, please check your Trezor Bridge Status, available from http://127.0.0.1:21325/status/
  • Use supported browsers only. Either Chrome or Firefox (try both and try using Incognito/privacy mode as well).
  • Not only using a VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.
  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.
  • Also, consider downgrading your MetaMask app.

Sir I’m already do this things. The ronin address i use before to make hardware wallet in my trezor is not showing on the 50 list. How can i reconnect my ronin wallet to my trezor one even im already use my seed phrase on recovery. Please help us.

@Kielzo please avoid cross-posting as you have already posted in several topics and even created new topic that has already been answered, thank you.

Its been answered still not resolve how im going to stop sir? Please i need to fix this issue i need to feed my family. :sob:

1 Like

@Kielzo I think I can help you out. I have a number of PH speakers in my Discord as well as myself that can help troubleshoot the issues you are having. Drop into my discord a leave a message in the “Trezor Support” channel of my discord. Feel free to add me as a friend on discord as well.

3 Likes

Im already join in the discord sir

I’ve got a sneaky suspicion that the Ronin Wallet is the one to blame for the issues of people not being able to log into their Ronin accounts with the Trezor connected.

When Trezor updates the firmware, trezor bridge, and or trezor suite, is there a possibility those updates could cause communication issues between a third party wallet such as the Ronin Wallet? Perhaps the Ronin Wallet developers haven’t configured it to communicate with the new updates yet.

I have the same issue. I had 1 account that encountered this problem, then both my accounts couldn’t be accesed anymore through ronin login. Is there a solution now? Please, my hospital bills cannot be paid without unlocking my accounts.

Hi @mayhembeel, all the troubleshooting tips were already posted in this thread, but let me make a brief sumary:
Do you have Trezor Bridge installed and running? https://wallet.trezor.io/#/bridge
Also, use only the officially supported browsers - Chrome and Firefox (try it in both).
If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, try to disable them.

I strongly believe this is due to Trezor Bridge 2.0.31. My Trezor Bridge show that I have 2.0.31 (latest) however, on the download button, latest version is 2.0.27.

I try to install the previous version 2.0.27 and I can link the 2nd wallet from trezor to Ronin. However, after sometimes i can’t make any transaction on the same wallet, stuck at loading screen from Trezor. Upon checking out the Trezor Bridge, I see it revert to the latest version 2.0.31.

Hi @anhhuyle,

May I ask where you got version 2.0.31 from? As far as I know, the latest official release is 2.0.27.