Ronin + Trezor doesn't work - No login possible

update-
Still not able to log into Axie marketplace dashboard after constant refresh and restarting.

When I choose the Trezor hardware wallet account on Metamask and log in via Metamask, it won’t sign in but it just shows a constant loading on the screen.

I can sign in to my software account but having issues with the newly made Trezor ones on Metamask.

I have cleared my cache, cookies and browsing history.
Firmware is 2.4.1 (installed today)

Cheers

hi Im new here!
I have the same Issue … Troy .I made an account using may Trezor and I gifted 3 axies on the address but and i can only log in in Marketplace using my e-mail address…This account has 3 axies in it. play and earn and i can transfer slp to the ronin wallet. Problem is i cant Withraw my Slp or my Axies back .

Have you find the solution troy ?

can anyone help me pls. me snapchela is a hacker

Sorry to hear that, @ruby. Please contact Communtiy support and communicate with them directly through email. It’s best to keep personal details away from the public forums, I think.

A post was split to a new topic: Ronin + Trezor doesn’t work, No login possible

Have the same issue. Any solution at all?

Hi Troy,

I finally got this working today. Apparently, I set some scholarship accounts with no paraphrase and other accounts with paraphrase. So what Ronin did was it created 50 wallets/addresses for the 2 hardware wallets with and without paraphrases correspondingly. You need to know which scholarship account corresponds to the paraphrase you set.

Please note that you need to close the browser if you previously logged in to a different hardware wallet.

1 Like

@KrisBurg,

Thanks for sharing your solution, it may help others in the same situation!

1 Like

You’re able to log in with your email and password, but not your Trezor?

Hello, I have the same issue (same as shown in the video). I can sign in account 2 (Trezor #2) ando I can´t sign in in account 1 (Trezor #1) by hardware Trezor.
I can log in with email and password in Trezor #1, and watch my Axies, AXS and SLP but I can´t send SLP, AXS or gift my Axies to another account.
Is there any possible solution?

1 Like

Unfortunately I am experiencing similar issues, which is really putting all of my scholars in a very touch position. I explain the issue below in detail. Does Trezor have an official help desk? I want to figure this out ASAP so that my assets aren’t tied up/so that my scholars can start playing again. :frowning:

I just bought a Trezor and yesterday morning I created a single main Trezor Ronin address. A few mins after creating that address, I transferred all of my (scholars) axies to that single main Trezor Ronin address. Things were working perfectly for the first couple hours, I was even able to make one transfer of SLP (to one of my scholars) using my Trezor.

A few mins after I made that transfer, my Trezor stopped being able to connect to Ronin (log in). I can log in manually using my email and PW, but when I get in I can’t transfer any assets out of that main Trezor Ronin wallet. Sometimes, things will seem like they are working, and my Trezor will go through the process like I am signing in, but it just takes me back to the main log in page as if nothing happened. I am also not able to connect more hardware wallets. Again, this is all in stark contrast to my ability to do all of these things normally/without issue for the first couple hours of use yesterday morning.

I have tried all of the recommended fixes (e.g., restarting my comp, clearing my cache, etc.) listed in the above posts and nothing works.

Perhaps one difference is that when I go to check on the status of the Trezor bridge, sometimes my Trezor webpage says that I do have the most current bridge, and other times it says that I don’t have the bridge installed. I also do not see “Trezor” appear in my task manager window. When I have the desktop app open, that does appear in the task manager window as “Trezor Suite” (or something similar), but not “Trezor” as was the case in @Langly1087 video.

I do think that this might be an issue related to my computer, since I have had many other Ronin issues on this comp, but not my old comp, which unfortunately died a couple days ago.

I have thousands of dollars tied up in this and my scholars are missing out on the chance to make money to pay bills. Is there any way to get official Trezor help here? I would pay good money to sort this out ASAP.

So I have had the issue where the Trezor bridge stops working. You need to make sure that is working correctly, I think that is the main culprit at the moment. I end up having to restart my computer to reactivate the Trezor Bridge.

It might help to uninstall the bridge completely and reinstall it. Have you tried that yet?

Join my discord for faster communication. Maybe we can screen share to help you out. https://discord.gg/SgVhV7h9wu

2 Likes

The weird thing is I have been unable to replicate this issue to try and trouble shoot a fix. Occasionally the Trezor Bridge crashes on me and I have to restart my computer to reactivate it.

It is possible that the Bridge is the main issue at the moment.

Same issue here! Whenever I press login with Ronin wallet in the axie marketplace, it asks me to export in trezor for the first time and then puts me back to the “login with Ronin wallet”. This continues and I confirm and confirm on Ronin, but it always puts me back to the login site. I was planning to convert my SLP to AXS, but now it seems like I won’t be able to access my account soon at all. I hope someone finds a fix for this. Thank you!

Hi @Gabuns,
I would suggest reinstalling Trezor Bridge version from this source: Trezor Wallet (once installed, please proceed with clearing your browser’s cache). After successful installation, you should see “trezord” process running in your activity/system/task monitor. Make sure you have the version 2.0.27 installed in the end.
Also, make sure you are using Trezor only in the supported browsers (Chrome and Firefox).

I have the exact same issue, across 5 accounts… I started using the Trezor 2 days ago, day 1was fine, created 45 accounts for scholars, yesterday I started to migrate. Completed 4 with no issues. Then all of a sudden the Trezor doesnt connect or allow me to login to Ronin. As mentioned in this video you can still login via Username & Password. Would really appreciate some help here as the assets are locked…

Hi @GenZCrypto,
have you tried the suggestions I posted above? You can check if your Trezor Bridge is running by visiting this site: http://127.0.0.1:21325/status/

Does this mean its working?

@GenZCrypto Yes, you also have the latest version installed. Please try connecting to Ronin in the anonymous mode of browsing in both Chrome and Firefox browsers.