Ronin + Trezor doesn't work - No login possible

Hello, I use Trezor for the NFT Game Axie Infinity.

I have a Ronin account with several subaccounts.

I have the latest Firmware 21.71
I have the latest Trezor Bridge status Version: 2.0.31 (rev 5f53132)

Usually Trezor works fine with Ronin.

But I have one account where I can’t do anything with Trezor and Ronin (and I have other Trezor wallets I can’t use due to the same issue).

I simply can’t login. I confirm my Trezor, Trezor Passphrase, try to connect to my Ronin account… And nothing happens.

Please check this video for details:

I tried so far:

  1. Check if I can login to other Ronin Account, Trezor Suite → Yes, I can.
  2. Check for latest versions → Yes, latest versions are installed
  3. Restart PC several times
  4. Restart Chrome and https://marketplace.axieinfinity.com/ several times
  5. Clear Browser Cache several times
  6. Disable AdBlocker

Nothing worked so far.

Worst for me is, that I can’t transfer any NFT (Axies or SLP) from the account without Trezor working.

Really strange is, that for some Ronin account, Trezor works, for some not.

Any ideas what to do? PLEASE help me!

Cheers
Troy

1 Like

Noone knows an answer for my issue?

1 Like

same issue… ff up this issue.
please some one lnow about this helps up please

1 Like

So this is the first time I am seeing this issue, and you are right it is frustrating that some of them work and some of them do not.

Are all of those Ronin Trezor Hardware wallets under the same Hidden Wallet Passphrase?
There could be some kind of coding issue happening when enabling the “Don’t Ask Me Again for this session” button.

It could also be a Google Chrome issue, or even a Ronin Wallet issue. :confused:

I am going to be creating a bunch of Scholar accounts this evening with my Trezor. I am using FireFox though. I will try to replicate the issue you are having and report back my findings.

Have hope friend. This is all uncharted waters for everyone involved. Including Sky Mavis and Trezor. We’re all learning all at the same time. This issue will get resolved soon!

Yes, they are all on the same hidden Wallet Passphrase

I tried now:

  1. Check if I can login to other Ronin Account, Trezor Suite → Yes, I can.
  2. Check for latest versions → Yes, latest versions are installed
  3. Restart PC several times
  4. Restart Chrome and https://marketplace.axieinfinity.com/ several times
  5. Clear Browser Cache several times
  6. Disable AdBlocker

Additional:

  1. Reinstall Ronin Account
  2. Delete All Plugins (incl. AdBlocker etc.) except for Ronin (Reinstall), Metamask & Freaks extension
  3. Uninstall all AntiVirus (Norton, Windows Defender)
  4. Ask Ronin Support

I figure out a few further things:

This account has 3 Axies in it + I can play on Axie Infinity to earn SLP.
But on explorer.roninchain .com - the address ronin:4253f7bd4fb36492ff64f4f282f98668a26694a1 it seems like it doesn’t exists.
There seems to be a bug.

I created the account with Trezor, but on Trezor there is no Ronin Address with 94a1 to select.

After Reinstalling the Ronin wallet, not possible anymore to find Scholarships Ronin account again. Neither on Ronin, nor on Trezor.

The consequences:

  • No transfer of Axies possible
  • No transfer of SLP or similar possible
  • No possibility to create Ronin account with this ronin address
    At the moment - all Axies + SLP earned are worthless

I made an additional video. Please check it out here Ronin Issue Account w Mary Ann

Right now it seems like there are issues with the Ronin address. Or the connection between Ronin and Trezor. That would be my best guess.

Any ideas what I could do?

Same thing happened to me today. Worst part is i gifted some axies to the trezor ronin wallet before trying to log it in the axie marketplace. I think those 3 axies are gone.

I watched your video Troy, and it sounds more like a Ronin Wallet issue than a Trezor issue. Do you have any other hidden Trezor wallets that you might have used to create the address that has those Axie Infinity assets are in? For example, a Hidden Wallet that you forgot the password for?

Is there a way to recover it? Same issue. :frowning:

good day sir. i have the same issue. have you find the solution?

1 Like

i got same issue…i gifted my axie on the eth address coming from the trezor…and i cant access the ronin wallet which i created


Hi there Kenneth,

when you made the transfer, did you copy the ronin address of the wallet correctly that you wanted to send your axies to? There is a virus out there that takes action when you do the copy and paste. It replaces the address you paste with a Ronin address of a hacker/scammers wallet.

Every time you copy and paste the address, make sure to check that it is the correct address you want to send the assets to.

1 Like

I bought Trezor one first before buying axies to secure it, as per the investment is a bit high. I plan to buy axie today on the market and i watched all @Langly1087 videos to set up a ronin wallet on the trezor, but after reading all this complain and issues im scared to buy an axie and send it to the ronin trezor hardware wallet. Im not discrediting Trezor but people from my country are buying this product because of this purpose, to secure their assets from Axie infinity. I read some info here that Trezor doesn’t support NFT assets specially the axies(something with the ERC20) im not yet familiar with all this things and still trying to learn from all of you guys. Some people claims they can use ronin trezor wallet properly and some says they cant. Hope everything can be stable soon.

Im still having my own issue with Trezor not connecting until now.

Hey there @Rochi, I appreciate you watching my videos. What was the issue you were having with connecting your Trezor?

Also, the Axies can be secured via the Ronin Trezor account. Meaning after you go through the “Connect Hardware” process on the Ronin Wallet, you can then send the axies to that account. See this video here to see me sending Axies to a Ronin Trezor account.

I’m more than happy to help walk you through the process.

@Langly1087
Thanks for the video tutorial it really makes me aware of what to do first before setting up a ronin hardware wallet with trezor. im starting to invest on Axie infinity and i wanted to secure my accounts first using trezor.

Here is what i did so far base on your tutorial:

  1. Made a cold ronin wallet (i couldn’t find a way to just directly make a hardware wallet, or is there a way?)
  2. Connect a hardware wallet using trezor
  3. Connect the trezor ronin wallet to mp, sync email and link to the trezor metamask( i think this is where most of the accounts error. i might have done it too if i didnt see this thread)
  4. Check mavis if the account is accessible to play using trezor ronin, it works.
  5. ill transfer some Eth later on this trezor ronin and buy axies on mp , hopefully nothing would go wrong.

Some few question:

  • Are you able to pull-out/gift the axie out of the trezor ronin to a cold ronin?
  • Am i still be able to play the game even if the trezor is plugged off? and if i plug it back will the trezor ronin detects all the SLP gathered in game?
  • If the cold ronin was compromised, lets say someone online was able to steal the seed phrase. How much protection can trezor do?
  • if i plug my trezor on a different PC with a different ronin account, will my trezor ronin would appear on it?

Note that im a bit new about all this stuff so i do apologize if some of my questions are a bit off.
I was really assuming that Trezor has a full interface with NFTs because ronin itself shows/ask trezor device if you press “connect hardware wallet”. Hoping there could be updates for trezor to have interface for NFTs so people like us who is not well verse on this wont have this mistakes.

1 Like

There is no way to connect the Hardware wallet directly to the Axie Infinity Market Place. You need to have the Ronin set-up in order utilize the Trezor with it.

No worries about being new. That why we are here, to help you out. :slight_smile: Feel free to ask any other questions you may have.

I remembered that upon setting up my trezor suite.
it ask me 2 times for a passphrase. the firsts one, i put pin(meaning numbers) the second one, i put password (meaning letters).

To find the missing ronin address connected to your trezor. try creating a new hardware wallet. Be sure that your main ronin account is selected (main ronin meaning the one that is not connected to your hardware wallet)

Then select connect hardware wallet. enter the pin your using to unlock your trezor. (when you plug your trezor to your computer it will ask for a pin) use that.
then there you’ll find the missing ronin address on the list.

in my case now i got 2 separate 50 list of ronin addresses i can connect

Do this if you also encountered the same while setting up your trezor suite and if you also had 2 passphrase created like me.

Guys, it seems im also experiencing something similar. I have 1 out of 8 roning harwdware wallet that cannot connect to marketplace and Unfortuntely, that one was holding my slps Which i cant send now because it says too "used too many transactions " error. Has anyone were able to trouble shoot this errors? I neeed to transfer this slps somewhere more stable

Hello, I do have same issue for several days and is happening with my Metamask, all my ETH and BNB can’t be moved or touched. Must be a Trezor issue. just happens in 1 account. No one can help me so fa.

I also bought a Trezor and installed it today.
I am having issues logging into the Axie dashboard via metamask.
It’s just loading but never logging in.
Already followed the steps above.
:frowning: