Problem with Bridge after Update to Trezor Suite v22.12.1 in Win11

I Updated to Trezor Suite v22.12.1. I see a strange behavior considering the bridge.

I check the bride with:

After the first start I get Version: 2.0.27 an everything is running fine.

If I Close Suite and stop the Task trezord in Task Manager and then Restart Suite I get Version:

Version: 2.0.32 (rev 9aa6576)

And Error:

2.0.32 (rev 9aa6576)
devcon.exe does not exist

This does not look like an official Version (rev…).

Behavior is reproducible.

If I install a new Version (Bridge and Suite) from your HP it behaves the same

Please come back to me.

Suite bundles its own version of Bridge. If there is no Bridge running when you launch Suite, the internal one is started (v2.0.32 which is otherwise not available for download).
If you keep the standalone Bridge, Suite will use that.

Is there, uh, any actual problem you’re facing here, or is this just curiosity?

Hi, thanks for the answer. Sorry I should have stated all the problem, not just part of my conclusion.

I connected my Trezor One after quite some time to my PC. I updated the Suite in the process. After the Update my PC can not connect to my Trezor device anymore. Als the device itself does not start up properly. Sometimes the Display stays dead, sometime I see the black Trezor Logo, but Suite can not connect.

I tried different USB cables and 2 PC like you propose in the FAQ. I can not connect anymore. As i tried the with 2nd PC the connection was working after several failed attempts an PC 1. So I thought the problem was the Bridge, since all the times the connection worked, the status gave me V2.0.27 for the bridge.

Might be my device is damaged?

Hi @korbot,

please open a ticket as mentioned in the first post in this thread: About the Hardware issues category