New Trezor Not Recognized after First Firmware Update

My Trezor One arrived today. I opened it, installed the trezor suite and connected it to the laptop. Everything is good and the firmware update is installing. The screen changes telling me to unplug my trezor and reconnect it. After i reconnect it, the screen doesn’t change, connection doesn’t seem to work. I try 2 more times to reconnect and connect back then i close the suite to try again. When i open it, I can’t get pass the page “Connect your trezor” because the device is not getting recognized anymore.

What i tried and didn’t work:
Used another cable even though the cable worked in the first place
Used another laptop
Installed trezor bridge and tried to connect via web wallet
Tried to search for device in device manager to update the drivers manually

Note: The device doesn’t turn on when connected to the laptop.
I opened a ticket with number:104258
What to do?

1 Like

happened same as you to me today new trezor too.

Same problem on new trezor too? That is not good. Maybe they have a solution, I am still hopeful. @stormchaox tell me if you happen to find a solution to it.

If you use win10 system , I suggest you do this

2 Likes

@stormchaox see my reply

How can I use Zadig if the trezor device doesn’t appear in the dropdown menu?

Have you tried replacing the usb cable or usb interface?

Yes I did, also the cable worked the first time i connected the trezor. I tried different cables, different laptops.

trezor doesn’t appear as usb device connected to pc on windows device manager using 2 different usb cables so zadig isn’t an option to repair this.It’s like trezor is dead.

we should ask for a RMA in this case i think,so please support answer us.

Hi @tudorioan20, thanks for the ticket ID. One of our agents will soon get back to you.

Hi @stormchaox, if your device seems dead (it doesn’t even light up when connected) and switching USB cables did not help, the hardware is faulty apparently. Please submit a ticket as well https://trezor.io/support/technical/issue/ and post your ticket ID here.

did the ticket stuff a day ago .Ticket ID: 104205

@NIYAK is there any way to check if my device and @stormchaox are from the same batch? I suspect we both got faulty devices, got it in the same day and have the same exact problem. Also, how fast can I get a refund for it in order to buy another one from a trusted reseller in my country?

1 Like

Same thing happened to me, but I ended up getting hacked on a site I thought was Trezor, the did a bridge to my laptop, connected to my Coinbase and I lost all my crypto plus extra from my bank, for a total of over $10000.Trezor was expensive ,I had to wait to get it, they have terrible help support, I never should of purchased this product. I lost all my crypto trying to fix a faulty product I received.

Also happened to me this evening. I have newly bought trezor and when i was setting up with the application, it says i need to disconnect and connect it afterwards. But when i unplug and plug the trezor to my usb cable. My trezor is dead. it cannot be opened even when i was trying to re-plug it to my pc. Also tried it with my friends pc coz we bought at the same time. He’s trezor is working fine but mine seems odd. Any ways to fix this?

No solution. Support didn’t answer me anything yet. We have broken trezors but no solution. @NIYAK what can we do???

@tudorioan20 we have responded to your ticket.

@Garago113 please open the ticket and we will respond, thx

@forgi I replied to the ticket with the video requested.

I replied to the ticket with the video requested.too