I can't to connect my trezor to my macboook

I can’t to connect my trezor to my macboook. System OS macbook SUR BIG.What can I do?

Hi,

are you using web browser to access your Trezor Wallet or are you using Trezor Suite Desktop app?

browser and suite.no results. I think I need original cable…

I suggest to try multiple cables which can transmit data (not just a charging cable). The original cable is not necessary. Also try multiple USB ports and avoid using any USB hub. If any of these don’t help, let me know.

I buy original cable from apple and my Trezor connect to my MacBook

I still suggest to try multiple cables. It does the trick in many cases.

Kolin I am having an issue as well. I havent had this issue before. I plug it in and when I enter password on my device, the device seems active but it wont connect on my laptop. I click “+ check for device” and a pop up comes up that clearly sees my device. When I click “connect” it wont. In fact it always gives me an error that says “Device disconnected” even though it’s not.

Hi @Aaron_Gage

See suggestions below, make sure to go through the whole list.

  • Re/Install Trezor Bridge again from this source: Trezor Wallet. After successful installation, you should see “trezord” process running in your activity/system/task monitor.

  • Please, don’t forget to clear browser’s cache.

  • Does the device manager recognize your Trezor?

  • Make sure that you are using a supported browser - Chrome or Firefox (try both and try using Incognito/privacy mode as well).

  • Try using a different USB cable, or USB port and make sure that you are connecting your Trezor with the cable directly to the computer; please avoid using any USB hub or adapter.

  • Also, please, try connecting your Trezor device to another computer, preferably with a different operating system where Trezor Bridge is installed as well.

  • If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet.

  • Please, try using our new wallet Trezor Suite, available from https://suite.trezor.io/.

@Aaron_Gage @shuh have you managed to find a solution to your problem? I too have many issues that I summarised in this post My Trezor is not connecting - #4 by thanpolas

I responded to your other post & am also concerned about potential problems with M1s. That thread says, earlier in the year, that you shouldn’t connect Trezor with a USB adaptor or hub. However, iMac M1s only have USB-C ports, so how would you be able to use a Trezor with it without an adaptor or hub? Was this issue solved with Trezor Suite?