Having an issue accessing my wallet and confirming transactions after adding to metamask

Hi there, hopefully someone can help me with this who has had a similar problem.

I am new to using Trezor and I had set it up earlier went on to my metamask and connected a hardware wallet. It then asked me to choose an ETH wallet so I chose one and test it out and was able to move my assets to that address. Now checking in the Trezor Suite that wallet is not listed in there. I have tried to send the assets back but it just gets rejected. I am unable to confirm any transaction on Trezor for that wallet also, nothing pops up.

Is there a way to manually add this wallet to the Trezor Suite? I can’t see an option to choose one of the wallets that I selected when adding it to Metamask.

Any help would be greatly appreciated.

I have the seed phrase for this wallet. Is it a case of resetting my trezor and restoring from backup? I just did a test back up restore and it said the seed phrase is valid but not for this trezor device.

Hi @Pirus1982

Do you use passphrase feature / did you see this screen (picture below) after exporting your public keys to Metamask?

Here is some basic info about passphrase:

If you can’t see the first ETH address (you have previously exported to Metamask) listed in Trezor Suite, then you are accessing wrong wallet.

Whenever the device is used, it derives a cryptocurrency wallet from a magical formula; mnemonic+passphrase (extremely simplified).

So whenever you need to sign the transaction from the address you’ve previously used you need to use exactly the same Recovery seed and Passphrase (if enabled).

Hi MichalZ,

Thank you for your reply.

It was a while ago I added that to metamask so I am not 100% sure if I enabled Passphrase before or after adding that wallet address to metamask.

I used the same password as I would normally do. On metamask I went to connect hardware wallet - pressed on Trezor then selected an address. I assume it wasn’t the same address that was in the Trezor Suite at the time. I have tried it with and without a passphrase and I still can’t find that wallet on the trezor.

I originally just chose any wallet from the list as I thought that these were the wallets available to me. Why when I connect a hardware wallet is it showing me totally random wallets? It is showing on my metamask so surely I can somehow connect my trezor to this to move the funds?

So it seems that I originally added a wallet with just a pin number and no passphrase. I have the wallet address that I have my funds in but no wallet is showing in trrezor suite or metamask now after restoring my computer.

My question is how do I find this wallet to add back when it doesnt display at the top of the list of wallets when adding one to metamask?

It is important to distinguish between wallet and account/address.
The wallet can be either Standard or Hidden (passphrase protected).

Each wallet contains Accounts and addresses nested into them.
If you use passphrases, each passphrase generates a separate wallet. If you use two passphrases, you have three wallets in total — the two passphrases, and the empty passphrase.

The address derivation is as follow:

Recovery seedAccount private keyPrivate keyPublic key → Address

So if you are not able to find the desired address (in the list from which you want to import to Metamask) you are using either different seed or passphrase (if enabled) or both.

For more information about the structure (and address derivation) of hierarchical deterministic wallet please see following article:

I am using the correct recovery seed as I only set it up once and never changed it again. As I added that account back in July and only got round to using it this week there are a few possibilities.

When I originally set up my Trezor it is possible that I did this with no passcode or passphrase however when I try to connect to Metamask to view the wallets this just shows my wallet that is in the suite and not the one I originally added.

When I set it up with a pin number only its the same. If I set it up with a pin number and passphrase then it shows another account and not the one I originally set up.

On Metamask it was displaying as Trezor 1, I had never created any wallets in the suite prior to this but the wallet that I created in metamask never shows on the suite. It only shows if I am using the accounts listed in the suite which do not match the one I had in metamask.

So now basically I have this account with all my funds in that I cannot see on the suite and I can no longer see on metamask because during testing something out I pressed forget this device and that removed the accounts from my metamask list.

If I connect a hardware wallet on metamask with the passphrase disabled and it asks me to enter the passphrase when connecting usually you leave this blank to connect to your default wallet, if I entered a password at this stage would it just be the same as having passphrase enabled? I am trying to find out all the ways I can try and locate this account.

Pin Disabled - Passphrase Disabled
Pin Enabled - Passphrase Disabled
Pin Enabled - Passphrase Disabled
Pin Disabled - Passphrase Disabled

Would any of these change the wallet addresses or would it just be the same for passphrase enabled / disabled?

I have spent 2 days on this now trying to recover my funds which are in excess of $250,000 so I am super stressed out right now and I can’t find any telephone support. I am so worried that my funds are lost forever.

So it looks like I have figured out what I have done.

When I first setup my Trezor I had it with no Pin and no Passphrase - I connected it to Metamask and chose a random address from the list not the address of the default no pass wallet. Later on I enabled pin and passphrase for a hidden wallet. So I ended up sending the funds to the wallet I set up on metamask through connect hardware wallet and choosing the random address that I chose when I first set up the trezor.

Now I have the issue that I cannot see this wallet, I have the address but I cannot view it on the trezor suite or on my metamask any more. I originally tried to transfer funds out of it and it was just saying address unknown because I assume the bridge would not connect any more because of the passphrase etc.

Does anyone have any advice how I can view this wallet? I have tried adding it again to Metamask but it does not show in the list.

I am having the exact same issue as you. I was going to write up a post about it but then I stumbled upon yours. Were you ever able to resolve this? I have tried to recover the assets in this wallet with both my trezor and metamask backup seeds and the assets don’t show up in either one. I am at a total loss.

I got them back in the end. What I realised I had done was when originally setting up my Trezor some time ago I did not read fully what it was asking for. When it said passphrase I mistook it for seedphrase and entered my seedphrase in which basically was a new password and created a new wallet. After much guessing on the passwords I eventually copied and pasted my seedphrase as the password and I managed to gain access to the assets and transfer them out and started again.


As for Metamask app preventing you from spending your funds, this actually might be caused when the (appropriate) private key is missing.

These private keys for signing transactions are derived from the combination of seed stored on Trezor device and passphrase (if enabled and used).
Thus, if different seed and/or a different passphrase is used then the private key differs and cannot be used. In such case, previously generated wallets/accounts in third-party apps would become watch only wallets without the possibility spending the funds.

Generally, when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order.
The public-key cryptography ensures it generates always the same result.

1 Like

So you are saying that the only way this could have happened is if the hidden wallet/passphrase option was used at set up? I am 99.9% sure that that is not what happened. I never set up the passphrase in my trezor. I thought I followed the set up instructions word for word.

Is there no way for me to recover these funds?

1 Like

I never entered a password setting it up either but when I added it to metamask and it asked me to enter a password that is basically the same as setting up a password. So If you added it to metamask and used a password when it prompted you then that is the password you created for that wallet.

And you were able to recover the wallet by just entering passwords into the Trezor Suite app until you got the right one? I have tried everything that it could possibly be and am coming up empty.

Metamask has never prompted me for a password or anything when I try to access the hardware wallet. All the transactions just time out.

please note that if you have initialized or recovered your wallet in Trezor Suite the passphrase feature is enabled by default.

regarding your issue with trying to figure out what your passphrase (that is protecting the hidden wallet you’re trying to access) is: most of the time people mistake passphrase for PIN, 3rd party app (such as Metamask) login password or even Trezor recovery seed.
Beside that I suggest you to try every possible password you usually use / have recently used.
Good luck :crossed_fingers:

ok for each password you ever enter it has loads of wallets associated for that password. If you enter a password of 1234 the wallets available are different than a password of 12345. Do you know the wallet address and did it contain ETH? What I did was go to https://findeth.io/ search for wallet, entered the wallet address, connected with trezor and I would enter the password that I thought it was and then deselect all and select just the 2 eths, default and ledger and chose 500 for the wallets to search.

Metamask will always prompt you for a password when connecting to the trezor, you can either press continue which is no password or you enter a password and confirm it. Most people enter a password here without thinking it creates a secret wallet because its not been done in the suite. I would not try searching for accounts in trezor suite, either do it in metamask or findeth.

1 Like

I want to sincerely thank you for your help.

Yes I know the wallet address and yes it does contain ETH. I am going through the steps that suggested and still not having any luck. I guess it has to be that I entered a password somewhere along the way because when I search the address and don’t put a password in nothing shows up. Going to keep trying different passwords I guess. Still zero memory of ever having set one.

I was the same, I was adamant that I never put a password in. The only thing I had done was copy and paste my seed phrase where it asked for a pass phrase as I thought it was asking for that. I also tried all my passwords with a potential typo.

1 Like

Please help

When connecting my trezor to my metamask account, I connected a different address on metamask to what is shown in my trezor suite and have since sent eth to that metamask address meaning I am now unable to sign transactions with my trezor since it is a different address. Is there any way that I am able to connect my trezor to the metamask address and access these coins?