Cant buy crypto through Trezor Suite anymore

Hi everyone.

recently ive been having this problem where i can no longer by any Bitcoin or LTC through the Trezor Suite app on desktop. The problem didnt start until about a month or so ago.

I dont know what the issue is. i tried uninstalling Trezor Suite and reinstalling. still wont work.
I tried formatting the Trezor Model One what i have and even after recovering the account, still cant buy. everything works perfectly until i get to the page where you select the receive account. The “Confirm on Trezor” button decides to no longer work.

At this point I dont know what to do. is this a hardware issue now and maybe my Trezor is internally damaged? Its driving me nuts. at least if i knew it was broken i can replace the wallet. Im scared to even use the wallet as a storage now because i dont know if ill be able to even move my BTC/LTC after.

Any help/advice would be greatly appreciated.

A post was merged into an existing topic: Issue when trying to buy crypto using Trezor suite- The confirmation page seems to be frozen