Address unknown trezor metamask ▫

@594dilettantegeek you understand difference between recovery seed phrase and passphrase, right? because it is important

There are multiple people across this forum and in this thread who solved their issue…

If you want 2nd opinion feel free to read this on MM forum:

1 Like

Of course I know the difference. Without the seed phrase, I would not have been able to transition my wallets to my new laptop. Passphrase is also needed when I am transacting because Trezor pops up asking me for it.

Now about the original comment of the question asker, which Trezor Support replied to by saying the technical issue does not exist. If it does not exist, then what do you call the error message popping up on Trezor users everywhere?

it is the error telling you there is a difference between the address you are sending from and the address you are connected to (passphrase)

No, it simply says “Error: Unknown address”

WHich is silly, because it’s a staking platform, and I’m adding funds into it. Of course the platform will only recognize the wallet that originally deposited funds into it. So why can’t the payment push through? And it’s not a network congestion problem. I tried on 2 different staking platforms (BNB and Avalanche) and it’s the same error message. So the problem is on my end, not the platforms

you asked what the error means, I explained it.

that is correct, the wrong address you are connected to

Which I’m telling you repeatedly, is NOT the case. If I were connected to the wrong address, how can the staking platform show the correct balance? It matches my own paper records, which I update 2x a week. If I were connected to the wrong address, definitely the staking platform would show zero balances because they don’t have that address on record

yes, you are connecting to the platform with Metamask, but you don’t even need Trezor for that…it conects via extension…but problem is after when you are trying to sign transaction, which has to be done on Trezor and it is not connected to the same address…

just like here for example, different address in MM, different one connected to on Pancake swap

Screenshot from 2022-02-12 18-16-55

How can that happen that there are suddenly different addresses? Just days ago I used this exact same setup to pay into the staking platform, make swaps, etc? You must take me for a fool, that I am not even aware that I’m connected to a different wallet while I am on the staking platform.

Let me tell you how I organize my wallets: each wallet has only 2 cryptos on it. So for staking platforms related to Fantom and Avalanche, for example, I use one wallet. For ETH, BTC, another wallet. It’s not only for security, but helps me quickly differentiate which wallet I should be on when on certain platforms.

1 Like


1 Like

Those things the poster said, I’ve tried. But then, seeing for all these months how inutile and ineffective Trezor customer service/Community support has been, I now realize, what’s the use? I will still have to work at finding the correct solution in my instance. Copy-pasting a solution from another guy’s problem isn’t going to help me. And it is neither going to improve your image in my eyes. I hope another better company comes along to crush Trezor.

no problem, I have explained the issue in previous posts and you can find solutions from other people too, right in this post.

Also, if you believe it is the issue of Trezor you can use your seed to recover your wallet on any other wallet.

1 Like

Hello Forgi, I understood what my problem could be, but nowhere does it let me put a seed key of more than 24 words and it is assumed that my mistake was that I added a word to it when using it (from what I read). But when I try to put the seed key in my metamask with the word included, it doesn’t allow me because it only lets me put up to 24. Where should I put the 25 words of the seed key, I appreciate the help!

@JoacoNogueira you don’t put in a seed key anywhere, you need to put in the passphrase: Passphrase - Trezor Wiki

@pavel I get Invalid address message prompt when trying to get my USTC to Trezor.

Expected Result
Seeing a valid address confirmation.

**Steps to reproduce issue
I have tried to sending to 2 different exchange addresses and received the same message. I can transfer LUNC & USTC.

Does anyone know why this is happening? And if there are any work arounds through Trezor or something :sneezing_face:.


these coins are not supported in Trezor, you cannot transfer them

1 Like

How do i go about that?

Hello! Do you still have this records?

Hi! Can you please answer, what kind of password was work for you in the end? Is it some of your usual passwords?

Because now I tried each of my passwords and pins and nothing…

A post was merged into an existing topic: Troubles with Trezor and Brave