Address disappeared from Trezor

I’m using Trezor form years always no problems and nothing too complicated but recently I have seen disappeareing my wallet address. And I see using MyEtherWallet that this hex wallet is not more in the list.

Can I recover that wallet address? Having also access?

There’s any possibility that maybe resetting Trezor we loose access to “old” hex address walet?

Hi @Voci

The only possible explanation is that a different combination of seed and passphrase has been used.

Please, make sure, you are fully familiar with the passphrase feature

Hi i just want to ask if you dont make a pass phrase? What should we do?

Hi ,
I have the exact same problem with Trezor T and MEW.

I bought a Trezor T a few years ago in 2018 to store my ETH on it.
at the time, there was no native ETH support on Trezor so i used MEW with Trezor to store my ETH.
for first few months everything was ok and whenever i wanted to access my wallet i just connected my Trezor to my laptop and go to MEW and select connect to hardware wallet and it use to bring up a list of wallets and i chose the one i wanted and everything was fine.
but recently, when i connect my Trezor to my laptop and go on to MEW and connect it to my Trezor, my particular wallet that i have my ETH in does not come up anymore.
i get a screen asking me to chose the wallet i want to interact with but my wallet does not come up at all.
i keep clicking next page and i get a list of another 5 wallets but no matter how many times i click next i can not get to my wallet.
I have gone through 5000 wallets to find the one with my balance in it but i can not get to it.

hi @Gholimoli was the address you are trying to access created in Standard or Hidden (passphrase protected) wallet ?

so this is exactly step by step what i am doing :

1.Connect my Trezor to my laptop.
2. Go to myetherwallet.com
3. connect to my wallet
4. select hardware wallet and select Trezor
5.I get a message to export my public key from my Trezor for this session.
6.I allow the export of the keys and it will ask me for my password.
7.I enter my password on MYetherwallet and it will then ask me to confirm the password on my Trezor device which i do.
8.Screen comes up asking me to select the wallet i want to open and i get a choice of wallets to open but non are the wallet which i hold my coins in.
previously


i use to scroll a few pages and see my wallet and open it up and everything was fine but i have gone through pages and pages (5000) of wallets but my public wallet address is just not there.

@MichalZ,

Also see another thread Gholimoli has created: Can't access my ETH wallet on Trezor T with MEW
I’m closing that now.

1 Like

I am still having the same problem…i tried using Mycrypto.com and Metamask and i still can’t see the wallet.

what i want to know is that why has my public wallet address disappeared from the list of wallets?
does Trezor generate the list of wallets or is the wallets generated by MEW?

also this is not an isolated issue…other people have been experiencing the same problem in the past.
if you look at through this Redit thread you will see that this user was having the exact same issue with not being able to locate his wallet address.
i have gone through littterly 1000 of pages and still unable to locate my actual wallet.
I have my wallet address and i can see that all my coins are still there.

Please help.

Because you are entering passphrase now I assume that you have generated the address you are trying to access in hidden (passphrase protected wallet).

To access this hidden wallet repeatedly, you will have to use the exact same passphrase in combination with the recovery seed on the device

Since you are mistyping the passphrase (entering different input than you use for creating the hidden wallet in the first place) you are accessing wallet that you haven’t used before.

Why are you assuming that i am mistyping anything or using a different passphrase at all?
where in my post does it say that i have lost or don’t remember my passphrase?
this is not the issue.
I have only ever used 12 seed word and one passphrase.
i still know the passphrase and everything is working as it should.
i even wiped clean my Trezor T and used the recovery seed to restore it.after doing that i can even see the $5 balance in my BTC wallet .
i am not mistyping anything i just can not locate my wallet address and this has to be 100% a Trezor issue since all the address are actually generated by the device.
i think the issue may have something to do with DPATH or something like that.
I have tried to email Trezor support and have not heard anything back.
are you guys official Trezor support?

Do you think that there is a solution to this or is my coins lost for ever?

Because when the same recovery seed is used and the same passphrase is entered (if enabled and used), the same wallet is accessed. There is no exception. It always generates the same wallet including the same accounts having the same addresses in the same order. The public-key cryptography ensures it generates always the same result.

Yes users with “community support” tag are official support agents.
Could you please provide your ticket ID so we can continue troubleshooting the issue via helpdesk ?

However if it is the passphrase issue (and I am positive it is) there is unfortunately nothing we can do on our end…

ok so here is an update.
the issue was not with the passphrase as i was sure of it.
when i use MEW i go through thousands of wallets without getting the one with the balance but when i use Mycryptowallet because it scans all the wallets then i can access my wallet.

but there is now another issue with mycryptowallet that i would like your help on.
so when i access my wallet and i want to send withdraw some coins, then i get an error message saying that i declined the transaction signature or else it timed out.
so it says please confirm the transaction on your device but i get to prompt at all on my Trezor and then i immediately get an error message on mycryptowallet(screenshot attached).

i really appreciate any help at all.

@Gholimoli

try to use different browser in incognito mode and clear cache, you also have many extensions including Metamask that might be clashing wit Mycrypto, make sure to disable them

@forgi @MichalZ @Petosiris

So i did everything you told me and used a different browser in incognito mode and deleted my cache and disabled all the extensions and i still get the same error message and still unable to send my coins.
i also tried another laptop entirely and still got the same error message.

Guys please ,i really need your help. i have a medical operation and i the money in this wallet is all i have to pay for it.
i need to know if there is a way to access it os is it lost for ever?
to me it looks like it should be accessible since i can get to open my wallet via Mycrypto.com right?

also i want to know that how come i can not get to the wallet via MEW?
i think we have stablished that it’s not a passphrase issue since i can get the wallet open via mycrypto right?
any help at all will be greatly appreciated guys and many thanks in advance.

@MichalZ @Petosiris @forgi

I have logged a ticket with Trezor with ref Ticket ID: 101624.

I would really appreciate any help folks as i am in a disparate situation right now.
.

@Gholimoli we have responded to your ticket.