(User Mistake) Suite falsely claims 'this hidden wallet is empty'!

4 days ago I logged in to my Model T and my Model One just to see that both my wallets were empty with 0 transaction history! it claims: Your wallet is ready to use! (as if it’s a new wallet) I used the same old PIN & passphrase, I have them written down to avoid confusion. I entered them very carefully, checking keyboard settings, I also clicked on the eye icon to see exactly what I’m typing. It’s all correct.

I’d like to start with saying that I’ve never handed out my seed or passphrase online OR offline to anybody! I’ve been extremely careful about this.

Last time I signed in was in June this year, then it all seemed fine, all funds were there.

I’d like to reiterate, that I’m using EXACTLY THE SAME PASSPHRASE with the correct wallet, that I always used in the past (I’ve checked upper and lower case options etc) so this is not an error from my side.

Team Trezor, we’re not talking about 1 or 2 months of savings here, it’s life savings! I will need urgent assistance here, the last 4 days have been a sleepless living hell! Me and my family don’t know whether our savings are gone or if this is a bug we’re dealing with? We’ve been left in a limbo over the weekend as there’s been no further response from customer support.
Ticket ID: 188398

Some of the coins that aren’t supported by Trezor are stored in conjunction with the Metamask wallet. I’ve logged in to my Metamask and my funds are still there, according to Metamask… but not visible at all, in Suite.

Is there any way to know if the funds are still sitting in the hidden wallet? My exchange has emailed me all my transaction history so I have addresses at hand.

I have realised that this issue many times occurs when there’s been a firmware or software update… I’m now thinking of trying and older firmware but I’m not very tech savvy and can’t seem to find the older downloads on the github. Could anyone point me to the right page please?

Here are the options that I’ve already tried but didn’t work:

I’ve swapped the 2 different passphrases just in case I accidentally swapped the 2 phrases for the 2 wallets.

I’ve updated both the firmware and the software on both.

I’ve also deleted and reinstalled older versions of Suite, tried versions from 2022 and a couple more older ones from 2023. github

I’ve restored my wallets using my seed phrase.

I’ve enabled all coins in Suite.

(Tor is switched off as it always has, I’ve never used it)

(Also, I run the latest version of Windows.)

Many have had the same problem, @TwoLamps for instance has had the almost exactly same issue.
Jacob did you find a solution or did you loose your funds?


Has any of you solved this issue? ?

Very, very, very much looking forward to hear from you!

Thanks in advance,

ps: this is what happens when I try to sign in:

  • enter passphrase

  • this hidden wallet is empty

  • confirm hidden empty wallet

This leads to 2 different solutions:

  • Discovery error, accounts were not loaded properly OR Your wallet is ready to use! (no transactions… yet)

@CryptoSOS most probably you are not inputing the Passphrase for the intended wallet.

If everything you are inputing is correct and you accessed the wallet but the funds were stolen you would be able to see your address and the transactions associated.

Because you are accessing with different credentials you see an empty new wallet with no funds.

But you have opened a ticket so just wait for there answer


Thanks for your reply. As mentioned I’ve very carefully looked into this and the problem is that I am putting in the correct passphrase.

Indeed, let’s wait til the customer support replies.


1 Like

note that a passphrase can also have spaces and symbols which can be easy to overlook.

depending on what coins you use you can try hooking up your trezor to a different companion like electrum for bitcoin, or MEW for ETH (be sure you actually use the hw wallet option and dont randomly enter anything).

also if you have had multiple seeds, try those too, the hidden wallet only comes from the combination of seed and passphrase.


did you have any history on the “normal” non-hidden wallets originally, and if so, does that appear now too? if not, and especially if you uses 12 word seeds try recovering again. on 12 word seeds there’s a 1/16 chance to accidentally restore a wallet you didnt intend to as the checksum is only 4 bits.

1 Like

if you know an address you used from those wallets you could (if you feel confident digging with an offline setup) also manually dig around with your seeds and passphrases in a setup that is both fast to use while still secure.

(also mods, please consider raising the time to edit, it feels awkward triple posting because I cannot extend the post like a normal forum user.)


Yes, I didn’t use any spaces in the passphrase and no I didn’t have multiple seed’s.

1 Like

I’ve always had hidden wallet’s. Good point I will try to enter the 12 word seed again but I’ve tried a couple of times already and I was extremely careful to put the correct seed in.

1 Like

Thanks for your input. I’ll have to continue until I can finally access my crypto!

1 Like

I’ve just had a reply from the Trezor team but still not been given any way forward on how to solve the issue. Only explanations on what a seed phrase is, which I already know. I’ve explained several times that I’ve always had the seed phrase, the PIN and the passphrase written down so I’m not putting anything wrong in. I’ve enabled the eye icon so that I can see what I’m typing! I’ve tried every single combination, mixing the 2 wallets seed phrases etc.

I’ve actually happen to know Guy from the Coin Bureau, I told him about this scenario and he’s very surprised about it all, especially as he’s one of your affiliates. He also reassured me that this is certainly something Trezor customer support will be able to help and fix.

The next step I think I should try is to downgrade the firmware! Can anyone give me advice on this?

The firmware version on my Trezor One is: 1.12.1
I looked into this version and it claims on your website that it’s not possible to downgrade this version!? so what am I to do?

The firmware on Model T is 2.6.0 Here I don’t know if I can downgrade or not as it’s not been updated on your website. I really hope that I can!

Looking forward to hear from you all

1 Like

Hi @CryptoSOS , this is what you said in the ticket:

Something bizarre just happened by the way. The crypto on both my wallets are in hidden wallets. a couple of months ago I just saw that I sent some BTC to one of them. It was an address I generated within my Trezor’s hidden wallet. Now, I just logged in to this wallet using the standard wallet without a passphrase, and this crypto I sent showed up there!.. How can it be that it shows up in a standard wallet when I created it in and sent it to a hidden wallet!?

So, does your crypto show up or not? Becasue you said it did.

You have also mentioned multiple times that you have two seeds and two passphrase, so that is your issue.

1 Like

Hi @forgi,

Yes, I did put some crypto into my wallet but this time it was into a standard wallet, I thought it was a hidden wallet, but if it was it wouldn’t have shown up in the standard wallet!

I’ve opened up both wallets in standard mode but it’s empty.

I have 2 passphrase’s because I have 2 hardware wallets. I’ve switched the passphrase’s already, so that’s not the problem!

As mentioned before, I’ve written down the seed, the passphrase and the PIN and have typed them in correctly! So what shall I do?

I believe it might have to do with the firmware update… and would like to downgrade. What do you think?

1 Like

Everything points out to the fact that you are mixing seeds/passphrases.

1 Like

I’m afraid it’s not. I’ve tried all possible combinations already. I have written down which hardware wallet has which seed. So that’s out of question. I’ve switched and tried both passphrase’s with both wallets too.
This is a very serious situation, so believe me, I’ve tried everything I could think of!
There must be something else you can suggest?

1 Like

For instance, is there any way I can check if my funds are still in the hidden wallets?

1 Like

Well, you seem to have done all the right things.

First off, it’s almost certain that your funds have not been stolen. If they were, you would see an outgoing transaction. Instead, you are seeing empty accounts, which would typically indicate a wrong seed phrase / passphrase. What kind of stands out to me is “discovery error”.

Please try the following:

  1. open the hidden wallet in Suite with the right passphrase
  2. go to your Ethereum account, Receive tab, and write down the receive address
  3. check its balance on Etherscan
  4. check whether it matches the address that you have in Metamask

If all of this succeeds, then you’re experiencing some sort of weirdness on Trezor Suite side, but your coins are OK.

If you don’t see any balance on Etherscan, or if it doesn’t match the Metamask address, then you have the wrong address, which means wrong keys.

And that can mean one of two things: (a) wrong seed or (b) wrong passphrase.

(While it’s not Literally Impossible to be caused by a bug, we have never ever seen a bug cause this kind of problem. It’s the kind of thing that bugs don’t really do.)


Hi @matejcik ,

Thanks for your input, this is very helpful.

I very much hope that you’re right and it gives me some peace of mind.

I’ll check the ETH addresses but as far as I can remember, I generated several… (or was that in my exchange)

I thought I should add, that about a year ago, I tried to log in to Suite and nothing showed up in my wallet, same thing. But then after logging in (the same way) about 4 times it suddenly showed up again! It was like it refreshed and there it was. Very strange! Unfortunately this time it doesn’t show up…

I will try what you suggested and will get back to you with the results.

1 Like

So if you did use the standard wallets in the past but don’t see any history, there’s a decent chance you messed up the seed phrase.

There are several words on the bip39 list that are similar enough (especially if your backup only has the first 4 letters of each word)

So maybe take a hard look at the wordlist of bip39 and maybe some words might have been slightly different.

The quickest way to test variations of the seed would be an offline pc tool, but that’s not something that’s too simple to set up.

As mentioned the chances of a wrong seed phrase being valid on accident is a mere 1/16 and the derivations for standard coins like btc/etc have existed for years and pretty surely wouldn’t have been touched in the last year.


Hello @My1 ,

Thanks for your input. Unfortunately this problem started before I had reset my wallet and put in my seed for the first time. But surely, if I put the wrong seed in, wouldn’t it say something along the line of ‘wrong seed phrase, please start again?’
Since then, I have erased/reset my wallets and I have opened them both up with the relevant seed and there was no indication of an error along the way…

1 Like

The wrong seed phrase is the 1/16 I’ve been mentioning. A fresh trezor cannot know what our correct seed is, same as with passphrase, however the seed has a checksum embedded in it, however with 12 words that checksum is fairly weak, only 4 bits so a 1/16 chance that a random assortment of 12 words from the bip39 list yields a valid seed, for each set of 11 words you enter there are 128 valid choices for the last word.

For a passphrase the trezor just warns you that if the wallet has no history you may be on the wrong phrase, as that is more likely to happen due to the missing checksum.

If it happened before you reset your trezor, and you did use the standard wallet of that seed before you should see a history of transactions in the relevant coins. If not your seed is generally wrong. This is the first hurdle to clear, (would be useful if you have used it as it makes finding that much easier)