Trezor T unable to connect to Windows 10 ▫

Hi, I’m using a brand new Trezor directly purchased -untampered with seal. Tried multiple USB A-> C cables on 3 different laptops. Already attempted webapp, then bridge, then desktop app, then disabled USB connection and reinstalled drivers, and tried zadig solution. I was able to get it connected once for a firmware update and initial setup, but after that I have been unable to reconnect.

It seems on reddit that this is a common issue so I’m not sure how Trezor can say it is supported on Windows 10.

Trezor bridge shows a status but Windows is still unable to connect to Trezor. After the initial connection - windows says that the previous USB malfunctioned and can no longer be recognized despite reinstalling drivers.

Hi @nftea

  • Make sure that you are using a supported browser - Chrome or Firefox (try both and try using Incognito/privacy mode as well).
  • Make sure that you are connecting your Trezor with the cable directly to the computer; please avoid using any USB hub or adapter.
  • If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet.
  • Also, have you tried connecting to Trezor Suite web app https://suite.trezor.io/web/ as well?
  • Lastly, are you able to access bootloader mode?

Yes I tried incognito, on Chrome, and firefox, and use it directly through the cable, no VPN, disabled my browser extensions and as I already mentioned, used the webapp.

I will try bootloader mode, can you tell me what the purpose of it is? Do I have to use it every single time? Again, I’m not really sure how this is considered being compatible with Windows.

So to be clear, google chrome has no problems detecting when the device is in bootloader mode, I have verified that I’m on the latest version of the firmware and have made sure that my other chrome extensions are disabled. “Trezor Wallet” the chrome extension app is most likely to detect but even then it’s only a 1/15 times that it detected the Trezor when not in bootloader mode.

I’ve tried different cables and everything, I also requested a refund for this device but haven’t heard back from the team. Am willing to try other trouble shooting options but it doesn’t seem that Trezor supports Windows 10.

The problem I have is exactly described here: https://www.reddit.com/r/TREZOR/comments/e0gum5/problem_with_trezor_one_on_windows_10/

It works on my sister’s macbook, but not my windows 10.

Windows 10 is not the issue. Many people use Windows 10 with Trezor without problems, including myself.

However, it may be a driver issue on your PC, for instance a USB driver that needs updating or something. It may also be that another program running in your PC is competing with the port used by Trezor deamon “trezord”. You can check that trezord is running in the background by looking in Task Manager (Ctrl+Alt+Delete). Please also check the Trezor Bridge status at http://127.0.0.1:21325/status/ .

If your issue continues after this, I’d advice you to try and run your PC with no other user programs running at the same time. You can disable them one by one to see if any program is blocking your Trezor operation.

I’ve tried uninstalling all the USB drivers and reinstalling them, as well as check the Bridge status, as well as check on another Windows 10 computer. I also have done a clean boot and made sure no other programs are running. I’m not sure why there are so many workarounds for this other than inconsistent support for this. But it is comforting to know you are able to use Windows 10 - but I’ve tried the zadig updates as well and no it is still not working.