Trezor stopped working on my desktop PC, but works on my laptop

As the topic says, my Trezor model one no longer works on my PC. I’ve updated suite, and the firmware and restarted my computer. I’ve also changed USB-cable and port. The trezor becomes extremely slow and sometimes unresponsive and I can’t send transactions because it times out with an error message. Any idea why this is happening? Thank you.

Hi @rasmus,

You mentioned that your Trezor device works on your laptop. May I ask if you use the same USB cable? Is it possible that you use a USB hub or adapter with your desktop PC? If so, try to connect your Trezor directly to your desktop without any adapter/hub. Do both your computers have the same OS?

Yes, I’ve tried different usb cables and ports. The desktop computer is using win 11, the laptop is using win 10.

Thank you for providing further information.

Can you check if the Trezor is recognized in the Device Manager on your computer? Also, make sure to try both desktop and web version of Trezor Suite (note that for the web version, you need Trezor Bridge installed on your computer. You can download it at Also, make sure to use supported browsers if you are using the web Trezor Suite - Chrome or Firefox)

And thank you for answering!

Yes, it’s recognized as Trezor interface in the device manager. The problem did not persist when I tried the web version. I want to use the desktop version, but if there are no downsides to using the web version I guess I could continue doing that.

It looks like the issue is in the installation of the desktop version on your desktop computer.

First, I would like to ask you to try resetting the Trezor Suite. You can reset Trezor Suite in “Settings” (the gearwheel symbol in the top right part of Trezor Suite). Navigate to the “Application” tab and select “Reset app”.

If it doesn’t help, please try to uninstall your Trezor Suite desktop application, download the latest installation file from this source Trezor Suite App (Official) | Desktop & Web Crypto Management and install it again.

Let us know the results.

I’ve uninstalled and reinstalled the software. The problem persists.

I would like to add that when I use the installed software, the trezor is often not recognized by the software until I restart the computer.

When I have your attention I would also like to know if it’s possible to send funds between accounts “in” the trezor without paying a fee(?)

your funds are not “in Trezor”, but on the blockchain…

…so if you want to move funds from one address / account to another, you need to tell the blockchain, otherwise the funds haven’t really moved…

…and in order to execute the transfer, the blockchain wants you to pay a fee.

I was hoping there was some kind of artificial fix by trezor to make the accounts separated. Thank you, matejcik

Please, try to update your Windows drivers on your desktop computer. Information on how to do it can be found at in the section “Update your Windows drivers”.

Let us know the results.

This sounds like it somehow comes with the possibility of security failure (even though I understand it’s not likely). Are there downsides to just using the browser version of suite?

Your private keys are always safely stored offline in your Trezor. You don’t need to worry about the security.

The web version of Trezor Suite is as secure as the desktop version. The only downside is that you cannot enable the TOR feature in the web version, which means the coinjoin cannot be used. All other features work the same in the web version.

I recommend saving the official link to the web version (Trezor Suite) into bookmarks so you can be sure you are always accessing the correct pages.

Okey! Thank you for your excellent assistance. I’m looking forward to contacting you again in case I require it. Have a good day.

1 Like