Trezor integration / Ronin Wallet / Axie Infinity

The accounts shown when connecting your Trezor, are the accounts associated with the seed of your Trezor.
I do know that in some cases, certain Ethereum addresses are considered as “legacy”. Metamask has a specific feature for this when connecting the hardware wallet.
Is this true for you?

If not, the Axie content HAS to be in those multiple Ethereum (ronin) addresses you mentioned. If it’s a legacy address, it’s further down the tree.

P.s.: No, I’m not Trezor support.

Ok maybe I’ll wait for @MichalZ to reply.

Sure, that’s a valid option. Good luck. :wink:

Hello guys i resolved my problem hehe. I recover my Ronin Account.

I resolved my problem. Thank you Trezor!!

Hi @Chavez_Patrick
sorry I was not able to reply earlier.
I am glad that your issue has been resolved. Could you possibly share how you resolved it so others who might have a same problem will know as well?
Was it the passphrase feature ?
Cheers

I would like to know how you resolved your issue as well. Did you try what I recommended and that fixed it?

@MichalZ, I have made it a priority to help Axie players off these forums, as well as on these forums, with any support questions they may have regarding using the Trezor with Axie Infinity. Hopefully I can help mitigate some of the questions coming in with my videos and conversations on discord.

3 Likes

Thank you very much @Langly1087 your help is greatly appreciated. :pray:

Guys on Ronin wallet i can connect only 50 Trezor accounts. If i want to create more the “Next button” is not working and it doesnt show more adresses. Metamask in this matter works normaly and show unlimited adresses. Is it Ronin limitation or somehow i need to unlock in Trezor?

It’s a Ronin limit, I believe.

Hi, Anyone, would like to ask if I can use 2 trezor wallet on a single ronin account? Purpose is to have 2 access for 2 diff person managing the account. Thank you!

If i transfer my ronin account to trezor. Do I still need to go back on level 1 on my axie. And for ruin in adventure do we go back to ruin 1?

@Chavez_Patrick, I have almost similar issue. Can you please share how did you manage to resolve it?

I tried to re-setup my ronin wallet to a laptop (Currenly using desktop - Trezor hardware wallet)

I can’t find the 1st 10 ronin address that I created everytime I tried to use “Connect hardware wallet”
I can only see the #11-15 that I use last night I’m able to export it without issue.

@MichalZ any suggestion or idea that you can share to me? Thanks in Advance.

Thanks.

Yes because you will create new account from Trezor inside Ronin. Trezor will give you 50 Ronin address.

Yes because you will create new account from Trezor inside Ronin. Trezor will give you 50 Ronin address.

@Eric if ur using Trezor model T try to remember your Passphrase. Passphrase is the key.

Thanks mate, I still have access on my Ronin wallet #1-10 from my desktop.

I’m planning to set it up to a laptop so in case I need to go out I can still have access on all of my ronin wallets. Do you know how can I export it to another device (laptop) the first #1-10 ronin hardware wallet I created? Unfortunately it’s not on the 50 ronin address. :frowning:

Thanks.

@Langly1087

This is the solution for Model T if you loss the seed phrase of Ronin account.

The solution is in ur mind. Passphrase.

If u can’t see the recent account it means you put wrong Passphrase.

Watch this

@Chavez_Patrick , I’m using Trezor One I forgot to mention.
I knwo my passphrase and I can still access my 10 ronin hardware wallet from my desktop but I can’t find how to export or re-set it up to another computer, all 10 hardware wallet saying the same passphrase.

Thanks @Chavez_Patrick and @Langly1087. I managed to fix my issue.

So basically you need to enter your passphrase when you are connecting your hardware wallet.
I usually skip that part because I can go though even I’m not typing my passphrase.

Thanks for your help! Cheers! :slight_smile:

1 Like