Trezor Hardware account linked to Metamask not sending funds to other address/wallet

So I have two accounts within Metamask (Main and the Hardware connected with Trezor)

I decided to move my funds and transactions to my Metamask Trezor Account.

Main account funds (ETH) moved to my Trezor account= transferred smoothly.

However, I had an issue trying to purchase an NFT via Opensea using my Trezor account and it kept failing. Trezor hardware did not even verify this transaction. The transaction just doesn’t go through.

So, I decided to transfer the funds from the Trezor account back to my Main account.
It also keeps failing and there is no record of any Etherscan data. The funds still remain in the Trezor account.
Tried sending it to my Binance address= still failed.

My Trezor software is up-to-date. (Trezor T model)

Somehow the Trezor account can receive funds but not send it out so my ETH is stuck in it and I can’t even use it to Buy or Send.

I just want to send my funds back or find a solution to why it isn’t working at all which is very frustrating.
I hope I don’t lose my Ethereum if this is a bug or a glitch.

Cheers

Hi,

What error message or situation do you get when trying to transfer from Trezor and it fails?

Also, know that Trezor doesn’t support NFTs so please don’t try to transfer NFTs to your Trezor device.

@Petosiris After I click confirm on the screen where it shows the gas fee and total amount being received, a loading icon appears but nothing happens.
It goes back to my main account screen with the funds still intact.

1)(I am not prompted by the Trezor Device during this process)

  1. Back to the trezor acc screen with the funds still intact

@deadxnurse,

I can see in your second picture (up left, under the fox’s head) that Trezor isn’t connected, so I guess you’re sending/receiving from a standard, non-hardware connected Metamask account. Is this correct?

If so, your Send/Receive address should be derived from that standard Metamask account too.

If not, you need to connect your Trezor Model T to the hardware-connected account on Metamask.

Edit: Also see MichalZ’s tips here and try if that can help you.

@Petosiris


So I have already previously linked this to Trezor as shown on the side that it’s a hardware wallet.
I feel so bummed that the funds are stuck there :frowning:

So I connected it so the button on the right is now green. But after clicking send and confirm, the funds are still there.

Can you try using Trezor Suite to send from Trezor to your main account on Metamask? It shouldn’t be necessary to use the Metamask browser plugin at all for this operation. You just generate a Receive address in your Metamask main account (the non-hardware connected account) and then use this address in Trezor Suite as the receiver’s address to send Ethereum (ETH).

Please be sure to send enough gas with the ETH transaction. You specify the gas amount and max. limit in Trezor Suite. To find out how much gas you should specify, you can use https://ethgasstation.info/ or https://www.gasnow.org/. Check that the RBF feature is turned ON before you send, so that if the gas amount needs to be bumped up later then it’s possible to use RBF.

@Petosiris

My Trezor Suite Wallet has no funds in it.
It says it’s a standard wallet but the funds on my MM Trezor hardware account doesn’t show up on my Trezor Suite wallet.

I tried sending it over to my Standard Wallet on Trezor Suite but the transaction still failed.
Cheers

Ok, so you can see your funds in your hardware-connected Trezor account on Metamask, but not in Trezor Suite. Can you see if you use the Remember function in Trezor Suite and turn it OFF if it’s on, so that the Discovery procedure will search the blockchains for the funds? Also check that you have the latest version of Trezor Suite (21.10.2).

@Petosiris

Yup did all of that and my version is the latest.
Have other people been having this problem as well?
Cheers

I think there are two possibilities -

Either you transferred the funds to a normal Metamask account, that wasn’t connected to your Trezor and which is why you don’t see the funds in Trezor Suite,

Or you used a Passphrase when you derived your Receive address to Trezor, so you transferred the funds to a different wallet.

Also, it doesn’t make sense to do what you said - to transfer funds out of your Trezor when there are no funds in there. I don’t understand how you can make a transaction from an empty wallet. In this case it sounds like you’re experiencing the first possibility - that you transferred the funds to a normal Metamask wallet that was not connected to Trezor, and that therefore your funds are still there. They never went to a Trezor wallet.

But this account says ‘Hardware’ so it should have been linked to Trezor?
But what I don’t understand is why can’t I send funds out of it.

Well, when you use Metamask with a hardware-connected wallet like Trezor, everything you buy or exchange with that account is sent directly to your Trezor. That is, if the Receive address is correct and you use the correct network for the transfer.

So if the funds aren’t in your Trezor, then they never arrived there. Or they arrived in a different wallet in your Trezor, probably because of Passphease and a Hidden wallet.

You may open a support ticket and post your ticket ID here, if you want help from Community support.

I will file a ticket thanks

I still can’t transfer my funds to my main MM.

Did you file the ticket? If so, have you communicated with Community Support through email?
Please post your Ticket ID here if you have submitted a support request.

I know you’ve struggled with this problem since September 7, so it’s been nearly two months and it’s time someone helped you with this. Maybe @Langly1087 have some tips for you too.

Hello,
I did but have not received any reply yet. So I will submit again.
It did not show any ticket number after I submitted my request.

Please post your original ticket ID here then, instead of submitting a new ticket.

Here is my ticket
Ticket ID: 104663

1 Like

The same exact thing is happening to me!!! I can send crypto to my trezor MM account but it wont let me send it anywhere! I’ve been trying and it tells me it is an invalid PIN, then keeps adding seconds on every time I try!!! Last time it was 8000 seconds!!! 2 f-ing hours​:man_shrugging::man_facepalming:

Here is my ticket
ID: 106498