Trezor Can't Connect/Firmware Issue ▫

Hello I haven’t used my Trezor in a while and have been unable to get it to connect ( I have bridge installed). The display lights up correctly but none of the computers I’ve tried have been able to recognize the device. After doing some trouble shooting I realized I have firmware version 1.3.2(I have a Trezor One). Am I right in suspecting that this may be the issue? If so how can I go about updating the firmware so I can access my wallet.

Thanks for your help!

Did you try what I suggested in this thread?

Hi @FcIm

If you are running an older FW version, please try using our older Trezor Wallet available from https://old-wallet.trezor.io/#/

Make sure you are running Trezor Bridge 2.0.27. Check it’s running properly, seek for “trezord” process in your task monitor. Also, check Trezor Bridge Status, available from http://127.0.0.1:21325/status/

If there is no “trezord” process running on the background, and you are getting no results on http://127.0.0.1:21325/status/, then Trezor Bridge is either not installed or doesn’t run properly. Reinstall it from this source https://wallet.trezor.io/#/bridge. Then, try it again, please (preferably with both supported browsers; Chrome and Firefox in incognito/privacy mode).

Also, please:

  • Clear your browser’s cache.
  • Make sure that you are connecting your Trezor with the cable directly to the computer; please avoid using any USB hub or adapter.
  • Also, please, try connecting your Trezor device to another computer, preferably with a different operating system where Trezor Bridge is installed as well.
  • If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet.
  • If you are running Win 10, 64 bit, install software called Zadig. It is a Windows application that installs generic USB drivers, such as WinUSB, libusb-win32/libusb0.sys or libusbK, to help you access USB devices. Please follow instructions Zadig - Trezor Wiki. After installation, please restart your browser and computer as well.
1 Like

Hey, thanks for your reply. I followed the instructions you gave me and proceeded to download Zadig. When I click list all driver I don’t see anything that says unknown driver.

I get the following listed:
Intel wireless bluetooth
EgisTec
2.4G Keyboard Mouse (Interface 0)
2.4g Keyboard Mouse (Interface 1)

I’ve tried different USB ports and cables, with no change. My wallet display is lit and displayers the serial number and in the bottom write text that says Loader 1.3.2.

How should I proceed ?
Thanks for the help in advance.

Hi, thanks for your reply, unfortunately the Trezor suite is just asking me to connect my device, so it seems to be the same issue.

Please, can you confirm your Trezor Bridge (“trezord” process) is running?

If so, then please, try accessing bootloader mode by following instructions below;

  1. Before you plug in Trezor to your computer, hold both buttons pressed

  2. While still holding both buttons pressed, connect Trezor to your computer

  3. Once, you successfully enter bootloader mode, you will see Trezor displaying something like this https://wiki.trezor.io/images/Bootloader.jpg

If you won’t succeed for the first time, don’t give it up and keep trying.

After you enter bootloader mode, continue to Trezor Wallet from https://wallet.trezor.io/#/ and you will see a screen like shown below with an option to update firmware. Before you proceed with updating, please make sure you have you recovery seed.

Please, let me know whether you succeeded in entering bootloader mode and updating firmware.

Hello I opened the device manager and I see trezord. I tried the bootloader mode by pressing both buttons and I’m getting the bootloader screen on the trezor device itself, but the wallet.trezor.io does not react at all. I tried it a few times to be sure. It’s just asking me to connect my device.

Could you try connecting your Trezor device to a different computer (with Trezor Bridge installed)? While attempting to do so, please make sure you go through all suggestions mentioned already.

Also, try connecting to both Trezor Wallets;
https://old-wallet.trezor.io/#/
https://wallet.trezor.io/#/

On top of that, please consider updating/reinstalling both supported browsers (Chrome and Firefox). Try temporarily disable all plugins, and use incognito/privacy mode as well.

Hello, I finally got a hold of a different computer (first two didnt work for some reason) and started it in bootloader mode and it worked! I was able to update the firmware and access my wallet. Thanks so much for all your help.

I have the exact same problem as his however switching to another pc did not fix mine.

this question most accurately describes my problem unlike others online.

last used a couple months ago, tried to log in today can’t recognize.
win10, Trezor screen lights up but not shown in device manager.
when entered in bootloader mode it shows that my firmare is 1.10.0, what else do you suggest i should do?
i tried multiple cables and usb, it even makes a sound when i plug in and the screen lights up but nothing shows up in windows and suite is stuck at connect to trezor.
also trezord is in process.

i have also submitted tickets regarding this issue and would love to resolve it like op.

can you help me as well? op only fixed his after switching pc but mine didn’t?

"I have the exact same problem as his however switching to another pc did not fix mine.

this question most accurately describes my problem unlike others online.

last used a couple months ago, tried to log in today can’t recognize.
win10, Trezor screen lights up but not shown in device manager.
when entered in bootloader mode it shows that my firmare is 1.10.0, what else do you suggest i should do?
i tried multiple cables and usb, it even makes a sound when i plug in and the screen lights up but nothing shows up in windows and suite is stuck at connect to trezor.
also trezord is in process.

i have also submitted tickets regarding this issue and would love to resolve it like op."

Hi @nowyouseesky

Thanks for submitting a ticket. We will reach out soon. Thanks for your patience.

Also having this issue, where no steps work, even on different PCs. Device just powers on and trezor bridge reports nothing, in bootloader mode it says version 1.8.0. Have submitted ticket.

Hi @gpdogger

Thanks for submitting a ticket. We will come back to you soon.

Hi,

I get this always,
re-download the trezor suite latest version and get the trezor bridge seperatlely seems to sovle it for me.

found after installing the bridge it all works for me even tho i had bridge installed.

the version i installed was trezor-bridge-2.0.27-win32-install.exe
for some reason my machine said i had 2.0.30 already but still from the site it offere .27 all works now give that a try.

I had the same issue, Firmware 1.10.1

tried diff cable and pc still cant detect.

Tried Zadig. didn’t show on the device list.

Please help. Ticket no. 105471

@pavel

Hi @LyndonMoraleda, thanks for the ticket ID! One of our agents will soon reply to your inquiry.