Switching between multiple accounts on the Trezor Model T ▫


I hope your day is going well. I have a problem that hopefully you can help me solve.

Just FYI, All software and devices have the latest versions with the most up to date firmware.

That said, I haven’t used the Trezor Suite in a while but the last time I used it, I had set up another account with a passphrase. Today, I am having difficulty switching from the passphrase account to the standard account while using the Trezor Suite.

Can you provide instructions that will allow me to switch between both accounts?

Thank you in advance.

Hi @tlewisj1

In Trezor Suite, you can access multiple accounts. See below. By clicking on your Trezor device name (left upper corner), you will be given a dialog enabling you to access the account you need. As you can see, you can have listed several hidden wallets (passphrase protected wallets). Also, you can easily access your standard (default) wallet as well.

​Please, try using both; Trezor Suite desktop application and Trezor Suite website application, available from https://suite.trezor.io/web/ and let us know how it works.

Hi Pavel,

Thank you. I tried the remedy mentioned but the only account showing is the hidden account that was created months ago. This hidden account does not have any funds on it but the no passphrase account does.

I know this because I can see the balance on my Exodus desktop wallet.

Can you recommend another solution to access my standard no passphrase wallet via Trezor Suite or wallet.trezor.io?

Hi @tlewisj1

When using Trezor Suite, try to Log out/Forget your passphrase protected wallet by clicking on Eject button. Then, reconnect your Trezor device and leave the passphrase dialog blank.

Optionally, when using Trezor Wallet, see how to Log out of Trezor Wallet.

Hi Pavel,

Thanks but I tried this to and the name for my initial wallet is not showing up in the Trezor Suite.

It’s almost as if my standard wallet account is no longer accessible. If this is the case, would wiping the device clean and re-entering my seed phrase give me access to my original standard wallet?

Let’s check the following:

  1. Have you cleared browser’s cache?
  2. What happens when you enter no passphrase?
  3. Have you tried using Trezor Wallet Trezor Wallet instead of Trezor Suite?
  4. Have you tried disabling passphrase feature in the settings in Trezor Wallet and in Trezor Suite?
  5. Have you tried using any other compatible app, such as Electrum?

Please, check the suggestions, and let us know if there is any progress. Alternatively, there is always an option to disable passphrase feature by using trezorctl commands, however this is for advanced users only Using trezorctl commands with Trezor - Trezor Wiki

Resetting device might help, but try above listed suggestions first.