Super Paranoid Problem Hidden Wallet?

Hello,

Sorry I’ve been so scared cause I don’t really understand what is going on with my trezor suite and this hidden wallet thing. I understand that it is basically another layer of security and you have the option to enter a passphrase and that is essentially always needed to recover your funds.

I have several Trezor devices and the one I definitely did set up as a hidden wallet. I put in a passphrase and I keep that coveted with my seed for back up. It asks me for this passphrase very often anytime I do a transaction or login etc.

Having said that, on all my other devices I have NO hidden wallet. I didn’t enter any passphrase and to my understanding they should all be shown as “standard wallet” in the top left of my trezor suite once I login.

My issue is, I have noticed that one of my devices says “Hidden wallet” as well underneath NOT “standard wallet” like I figured it should. It’s weird because it still functions completely normal like a standard wallet from what I can tell. It’s never asking me for an additional password layer of security like the hidden wallet Trezor device I have does.

I just don’t get it, it’s never asking me for a password, I never entered any hidden wallet details, nothing. Why is it saying it’s a Hidden wallet?

It’s really freaking me out because although I tested the seed phrase and confirmed it’s valid, I don’t want to have to reload my trezor from seed phrase if it breaks or something and find out that I somehow have some password associated with this trezor because it’s a hidden wallet.

I read a little online and I read some people have created hidden wallets by accident. Makes me sick to think I did that and now my funds have some password I made by accident and need someday. Having said that, if that’s the case, it should just function like my other hidden wallet and it should be asking me for this passphrase all the time??

Thank you so much for your help. I’m so appreciative of any assistance you can give me. I sent a email to support ticket number is 101740

Sorry I can’t even sleep and so fearful for funds! thank you again

P.S - Looking through for forums I noticed this post from July 8th from someone else. It’s closest thing I have noticed from someone having same problem as me. But I don’t think there was ever resolution posted.

Hello
I have a Trezor One and in the first time I used the web wallet (trezor.io ) but now I am using Trezor Suite. So far so good. I have noticed that my wallet is called a “hidden wallet” in Trezor Suite, although I do not have enabled the passphrase feature. I do not use a 25th word.

After a quick internet search, I found that other users have noticed this too:

> https://www.reddit.com/r/TREZOR/comments/l3nc36/wallet_shows_up_as_hidden_without_passphrase_on/

After the last Trezor Suite update, my wallet suddenly appeared as “standard wallet”. I thought: “okay, seems they have fixed this little bug” but now, as I start Trezor Suite, it is called a “hidden wallet” again.
.

Hi @Dandent,

Yes, you have a good understanding of what Passphrase is used for and how important it is to remember it.

Do you have the Remember function enabled for the wallet in question in Trezor Suite? If so, try to disable it, disconnect your Trezor device, restart Trezor Suite and reconnect your Trezor device again.

Check that you have the latest Firmware version (2.4.2) from inside Trezor Suite at Settings->Device.

Trezor Bridge should run in the background. It’s the process called trezord. You can check this with Task Manager (Ctrl+Alt+Del).

Please check that you have the latest version of Trezor Suite (21.10.2) and Trezor Bridge (2.0.27). You can check your Bridge version and status at http://127.0.0.1:21325/status/.

Also see Pavel’s tips here.

That’s correct. A Hidden wallet will need a Passphrase to show its contents. It’s possible to create a new Hidden wallet by mistake, if you enter a wrong Passphrase. However, to be able to work with it later you have to remember that wrong Passphrase too, or it’ll simply be empty and if it’s no funds in there, you can’t lose them either.

So if you have access to all your funds now, and none of the above tips works, then consider to move your funds to another wallet and setup the device with the weird wallet again from scratch, after it’s emptied for funds. You can wipe the device from Trezor Suite.

You can also wait for reply from Community support on your …

Ticket ID 101740

Thank you so much for reply. Remember function is disabled for all my devices I’ve used. Everything is the latest version as well.

It would be very challenging to move all my funds since I have tons of stuff staked in ETH ecosystem. Of course I could but would lose lots of value unstake it early etc.

With respect to creating a new hidden wallet by mistake. This Trezor is basically my master funds Trezor. I have had everything on it cold stored for months and months. I started using Trezor Suite not long ago, but certainly don’t think it’s possible that I added a passphrase to this standard wallet without me knowing?

Like wouldn’t I of had to type it several times and confirm? Is it even possible to add a passphrase to a standard wallet or do you have to always create a new hidden wallet?

Not only that but it’s totally functioning like a standard wallet. It never asks me for passphrase when i log in which a hidden wallet should always do right?

Anymore thoughts are great, just I really don’t want to have to clear the Trezor for just silly little typing glitch.

Just on a side note. I think it’s very scary for Trezor to do this passphrase thing. As a sort of newb I had no idea that the passphrase was essentially in addition to your seed and if you forget it, it’s no recovery for you. I am lucky that with the one where I actually did set it up I never forgot my passphrase, but totally thought it was just an extension of my pin not my seed. It’s very confusing for newbs.

I also wanted to add one more important thing to indicate as well that is it not a hidden wallet as it is labeled possibly incorrectly.

When I go to the settings in Trezor Suite the spot where it says “passphrase” is not green and lit up. It is off like it should be if it was standard wallet.

So strange and still so scared, but boy how can it be a hidden wallet!?

Yeah, that’s very unlikely, since you’d have to confirm it on your device too.

You can only create a new Hidden wallet, not derive it from the Standard wallet. The Standard wallet and a Hidden wallet will always be separate, though both are derived from the same seed.

This leads me to believe you’re right about it being the Standard wallet that has been renamed/relabeled to “Hidden”. This would explain why it works like a Standard wallet and why you don’t need a Passphrase to open it. Try labeling it back to “Standard Wallet” or simply say NO when the device asks if you want to enable labeling, to see what it’s called without a label assigned to it.

Yes, I totally agree with this. The Passphrase feature is a great security feature to have if you know what it is and how to use it, but it’s too dangerous to use if you don’t know what it is, so I think users should be more protected from themselves.

In my opinion,

a) the Passphrase feature should not be enabled by default but the user should have to enable it specifically,

b) there should be a more clear warning when a user enabled the Passphrase feature, like “Warning! Make sure you fully understand how a Passphrase is used and that if you forget it you’ll lose access to your funds. Press Cancel if you don’t want to proceed.” or something similar, and

c) another warning when a user creates a new empty wallet - I.e. “Are you sure you want to create a new empty Hidden wallet? Select No if you meant to open another Hidden wallet and be sure to type the correct Passphrase.” - or something like that.

Thank you for providing your ticket ID, we will answer you ASAP.

Hello, I can confirm its about the labeling issue. I was in the same situation, never activated passphrase, latest suite version and software and having ”secret wallet” mentioned instead of ”standard wallet”. Disable labeling in Suite the re-enable, it will do the trick.

I also suggest to reset the app in the settings as a good first step to any troubleshooting.