Stuck on 'Signing Transaction' on Trezor screen - cannot send

Hi, hoping someone can shed some light on my issue.
I have updated to Trezor Suite and completed firmware update.
I can see my accounts for BTC.
I am trying to SEND BTC, the appropriate screen comes up, confirmations occur as they should on device, then when it gets to Signing Transaction everything freezes.
I’ve tried multiple times, without success.
HELP please.


Hi @RaeW
Is your Trezor on the latest firmware version? Also, make sure you are using the latest Trezor Suite:
You can also try the web Trezor Wallet, or connecting your Trezor to Electrum wallet.
If that does not help, please submit a ticket at and post your generated ticket ID here - we will prioritize your case.

Hello, thanks for your reply.
Yes I am using the latest firmware version and the Trezor Suite.
I have submitted a ticket and waiting on a response.

While waiting I tried the Trezor on another computer and found I could move $10K worth of BTC at a time. HOWEVER, the cache needed to be cleared EVERY time and the Trezor Suite uninstalled and reinstalled EVERY time.

I thought this might be my computer playing up, but I think it’s more than that. My problem has been solved for now, but I don’t find having to constantly clear caches, install and uninstall computer programs to be a satisfactory solution to using my Trezor effectively.

I’ll look for my generated ticket ID and post here.

Thank you


I will wait for the ticket ID and we will continue in the troubleshooting in the ticket thread.

@NIYAK - RaeW’s Ticket ID is 87912.

@RaeW please check your inbox.
Your ticket has been answered.

I’m having the same issue when attempting to sign a bitcoin transaction. The Trezor Model T freezes 1/4 of the way through the transaction signing process.

I have tried the transaction on firmware version 2.4.2 and 2.4.2 (bitcoin-only), with Trezor Suite version 21.9.2. I don’t have any custom modifications to the home screen and I’m using Pop_OS 21.04.

Any advice?

1 Like

Hi @Agab,
Have you tried the suggestions listed above? Please check my first reply in this thread.
Do you experience the same issue in multiple wallets (Trezor Suite, Trezor Wallet, Electrum,…) and on multiple computers?
Try also sending a smaller amount, if the issue is related to signing too many inputs.

Agab, I feel your pain. None of the suggested ‘fixes’ worked for me.

I could not use the Trezor T for several weeks. I’d log into other computers, tried different smaller amounts (as I was trying to move quite large sums) and no success.

I repeatedly installed and uninstalled the Trezor Suite, and eventually everything began working again. I have absolutely no idea how or why!

1 Like

Please check this blog post we’ve published
Also, make sure that your device is still on the latest firmware version: Firmware changelog - Trezor Wiki

Hi NIYAK, I did make sure Trezor Suite and Trezor Model T were both up to date. I tried sending both large and small amounts, but both transactions had the same issue. I didn’t have a second computer to try unfortunately. I did try two different wallets in Trezor Suite but both were Native Segwit, not sure if that matters. But what did help as a work-around was Sparrow wallet.

Once I downloaded and installed Sparrow wallet and found some tutorials I was able to connect my Trezor to Sparrow wallet and transactions functioned as intended. Hope this is able to help anyone experiencing the same issue. One extra note is make sure when connecting Trezor to Sparrow you specify the correct wallet type to match the format you used in Trezor Suite otherwise it will show you a balance of zero.

1 Like

hi @Agab

In this case, the reason is most probably too many UTXOs and the transaction you try to sign is too complex. Due to the low memory, the device is not able to sign such transactions.

Usually, changing the homescreen to the default one helps, since it gives a bit of space in the memory, but the issue may still persists when the number of UTXOs is too big (too many inputs in the transaction you want to sign).

A workaround is to consolidate number of UTXOs. The best way is to split the transaction in two smaller transactions (so each transaction will have half inputs then previously).

As Coin Control feature is not implemented in Trezor Suite yet, you can use Electrum wallet instead.

hi @MichalZ

If it was a memory problem involving too many UTXOs, wouldn’t I have the same issue when trying to use different wallet software? (assuming i’m using the same wallet, just different software to access it) When I made transactions from the same wallet using the Sparrow interface the transaction signed normally. Which led me to believe the number of UTXOs wasn’t causing the problem. If number of UTXOs was the issue I would think the same issue would happen on Trezor Suite, Sparrow, Specter, et cetera.

I am having the same problem. I have the latest Trezor Suite and the latest Trezor device firmware. I cannot send, everything gets totally stuck when attempting to sign the transaction. Please help. Sometimes lowering the amount helps but now I have lowered it so much it seems like all that remains is the parts that I cannot send…

It seems to be a bug in Trezor Suite. Please see this issue on the Trezor Suite Github: Stuck transaction signing (coin stuck) · Issue #4306 · trezor/trezor-suite · GitHub

That issue is supposedly fixed by this pull request: fix(suite-desktop): buffer overload of spawned process (bridge, tor) by tomasklim · Pull Request #4310 · trezor/trezor-suite · GitHub

It seems like we need to wait for the fix to make it into production. Does that sound right everybody, and if so, how long might that be?

@Agab @MichalZ FYI

Edit: Petosiris fixed a link.

Trezor Suite was updated today guys. I was able to send the remaining coin that I was previously unable to send, so it seems to be fixed for me. Encourage you all to update and try again, good luck.

Hi everyone thanks for reading!

I get the “failed to send” message when trying to send btc.
Yes my account has many small transactions (100+) and maybe the memory is full so I read someone advise to create a new account or wallet with a new passphrase and start moving the btc to it, which I did, I moved 90% of my btc to the new wallet but 10% is stuck in the old wallet.

I already tried sending small amounts with no luck. Should I recover all my funds in electrum, reset my trezor with a new seed, and then transfer back everything? Or maybe buy another trezor, transfer first the 90% of my btc that is safe and then recover the rest 10% with the electrum recovery that I mention?

I appreciate your help!!!

fixed! used trezor suite and problem solved, thank you for directing me to this thread!


I would like to speak to a real person who can help me with my technical issue. I cannot find any ‘live chat’ nor a phone number. Help please.

Here: Legal | Trezor - Official eShop

But it’s Saturday and they may not be in the office.
There are real persons who will try to help you in this forum too, if you want to tell what the problem is.