Stuck in bootloader mode on mac 10.13.16

I’m trying to install my new Trezor. I started with the firmware update and it failed. Now the only screen I see is Trezor Bootloader 1.10.0. I tried connecting and disconnecting and also on another mac with similar config.

The only technical document is for windows. No mac guide for getting out of this screen and setting up my wallet.

Any advise?

@Cryptotechgr that actually refers to different issue.

So to make this clear, there are two issues:

This is actually issue @75avi is encountering.

Workaround for this would be to connect your device and go to wallet.trezor.io
You should see following screen:

As long as you have verified recovery seed you can proceed to Factory reset which will erase everything on your device (except bootloader).
After reconnecting go to https://suite.trezor.io/ and proceed to installing firmware and recovering your wallet.

  • Trezor Suite showing two devices:

This issue is suppose to be fixed in next release.

hi @MichalZ - I am struggling to understand which of the two I am facing. I think I also see 2 devices. Can you tell from the below screenshot if I am facing the 2nd issue (that will get fixed with the update) or the first?

Resetting the app did not fix this. I am ABLE to use the Trezor WEB suite, but not the desktop one. The below screenshot is from the desktop suite.

thanks

@MichalZ can you please address the above ?

Hi @Cryptotechgr

please follow what Michal suggested above:

Workaround for this would be to connect your device and go to wallet.trezor.io
You should see following screen:

As long as you have verified recovery seed you can proceed to Factory reset which will erase everything on your device (except bootloader).
After reconnecting go to https://suite.trezor.io/ and proceed to installing firmware and recovering your wallet.

You can also try updating firmware directly via old wallet:

Hi - I have already done that and I am still unable to use the Desktop Suite ( I am ok with the web suite ) .

Are you able to tell if I am facing problem 1 or problem 2 as described by Michael ? Thats all I am asking (based on my screenshot).

I am also seeing two devices when I press " switch devices "

@Cryptotechgr yes, it looks like the two devices issue, have to tried to uninstall the Suite and install lates one? https://suite.trezor.io/

We are still working on this issue.

It’s problem 2 you have, I gather. So if Trezor Suite’s web at https://suite.trezor.io/web/ works Ok for you then you can continue to use that until a fix for this bug is released in November. Or you can use the other wallet at https://wallet.trezor.io/#/ and proceed as @forgi suggests.

Yes, tried installing and uninstalling many times. Did not work. Using Catalina by the way. Updates did not help either.

hey @Petosiris - thanks. before you roll out the update, can you please make sure that Desktop Suite works for Catalina as well ?

Yes, web suite works perfectly fine…

Sorry, I have nothing to do with the update. I don’t work for SatoshiLabs, I’m just a normal user.

oh I see. Thanks for helping out !

1 Like

Hi @Cryptotechgr

first of all sorry for the late answer, I was off the computer for couple days.
I believe that your issue is related to bug n. 2 (app showing two devices).
So you would have to wait for another release fixing this issue.

1 Like