Solana Account discovery error \ Asset not loaded correctly

Hello, has anyone seen issues where they were able to store thier SOL then suddelnly it dissapears? I moved a good amount over to Trezor T after updating Suite software and Firmware on device. I saw the transcations, I saw the balance, but then as soon as I moved some BONK into ‘Tokens’ underneath Solana it ALL dissapeared and now all I have is my address where it shows the assets exist, but the Solana account will no longer load into Suite or Web view. I have tried everything.
I have followed every single step here multiple times. (trezor io support discovery-error-issue). I am super technical - the funs are in my account and I have the transactions to prove it but Trezor refuses to load the Solana account, throwing the errors stated in the subject line. Also, Windows 10, I have tried Suite, reloaded bridge, Chrome, Firefox, etc. It feels like a backend issue. Has anyone tried to use the custom server section to choose a different backend server? I am afraid to do that without specific instruction I do not want to mess up any addressing.

Ideas anyone or is anyone else experiencing this?
Thank you, Littleblueme

2 Likes

Hello, Yes I’m having exact same issue when I moved over Pyth after SOL ,now I get “account discovery error” when clicking on Solana on dashboard.

Hi Kraymerica, I am sorry to hear that you are having this issue also. Also a relief that I am not alone, hopefully TREZOR will reach out to me this is in relation to Ticket ID: 200038

THANKS for sharing !

More details, this is concerning please support reach out to me. Ticket ID: 200038


I’m having the same problem. It sucks…because I am trying to take profit. I can’t access any of my SOL tokens.

2 Likes

Hi Milton did you open a ticket also? I have heard NOTHING from Trezor support.

I did. But about an hour ago. Kind of sad how there are no reps monitoring these forums to respond with at least SOMETHING.

1 Like

Hello everyone, our developers are looking into the issue. Thanks for your patience.

4 Likes

I did last night with no response yet as well. At least response in forum would be nice. They addressed the erc20 token values not showing, I’m assuming this will be next.

1 Like

Agreed. I keep telling myself patience patience it’s only been less than 24hrs. But really, people’s investements are important, these kinds of things should be supported prompty not sitting here waiting for others to run into the same issues and experience the holiday stress. This issue will dampen many a persons Holidays I am sure.

1 Like

Oh thank you so much I am just now seeing your post!! Please save us!!! <3

Hey Y’all - Check now. Looks like it is fixed!

Hello, still not fixed on my end… see attached screenshots


While I can see my tokens, I can’t send anything out - I keep getting this error:

Transaction signing error: failed to send transaction: Transaction simulation failed: Error processing Instruction 0: custom program error: 0x1

1 Like

I managed to transfer my tokens…but there is some very strange lag in Trezor. Very poor user experience. I bought the Trezor to get away from Ledger…Looks like I made a mistake.

2 Likes

Hi Forgi,

I did a ‘Factory Reset’ on my Trezor T and now I am getting a new error: "Discovery Error Accounts were not loaded properly Solana: Cannot read properties of undefined (Reading ‘slice’)

I will attach the screenshot here

1 Like

And then more errors as usual, Account discovery error and Asset not loaded correctly
We were unable to discover your accounts.


I am having all these same issues. Would appreciate if we could get more than just “we are working on it”

Maybe a timeline or some kind of reassurance that they will be able to fix it.

1 Like

Ticket ID: 200038 PLEASE help this is still an URGENT issue. Someone needs to address this ASAP. SOL support introduced now my assests are locked up and Not a single update?

Happy Christmas !
Littleblueme

3 Likes