Sent Litecoin to Bitcoin adress ▫

Hi there,

so I messed up. I sent my Litecoins from Coinbase to the Trezor, but I forgot to change the currency from Bitcoin to Litecoin. Now my LTC are on my BTC address and can’t access them now of course. Is there some way how can I get LTC back?

Thanks for any advice!

1 Like

Hi David,

which Trezor device are you using and what firmware version is installed? You can check your firmware version in Trezor Suite in the settings - device tab.

Hello Kolin,

Thank you for reply. Currently I use Trezor One, and firmware version is 1.6.3. - installed yesterday.

Thanks, one more question I forgot to ask. Which BTC address have you sent it to? Was it segwit starting with 3 or native segwit starting with bc1?

Hi Kolin,

I checked the address. It’s 3BHLfBK… - it is segwit address start with 3.

Here is a step by step manual how to recover your LTC.

  1. Go to Trezor Wallet and select Litecoin (LTC). Go to Receive tab and click on Show full address. Copy that address, verify it on Trezor’s device display.

  2. To import Trezor’s public account keys, connect Trezor device, start Electrum-LTC and create a new wallet.

  3. Select Standard wallet.

  4. Select Use a hardware device.

  5. Choose the derivation path of the address where LTC tokens are located. Litecoin is usually located on derivation path m/49’/2’/0’. You want to connect to the Litecoin network, but on the derivation path that you have sent your tokens. The Bitcoin segwit (p2wphd-p2sh - Bitcoin address starts with 3) account is located on derivation path m/49’/0’/0’.

  6. After all Trezor’s public keys are imported and the wallet transaction history is synced, you will be able to see the transactions history and all Trezor’s account addresses. You will see the litecoin tokens on the derivation path for Bitcoin.

  7. Send the litecoin tokens to the address from step 1 (from the address you have got from Trezor Wallet).

Hello Kolin,

So I followed the steps till the 7), but when I wanted to send LTC to my address, it is always not successful - ends with pop up: RuntimeError(‘ProcessError: Failed to compile input’). Any ideas how to solve this? I run at macOS Big Sur.

Can you double check, if your firmware version is really 1.6.3? You mentioned you installed it yesterday, did it ask you to update to the new version or you installed this version manually?

Good evening Kolin,

I checked the firmware version once more and I was wrong, it says 1.10.0. I remember that there was a window which says there is new version, so I installed it manually.

Still I tried once more with this FW version, but it is showing the same error.

Ok, this clarifies everything. New versions of firmware don’t allow to sign transactions with different derivation path, this is a security feature. To be able to proceed with the last step, you need to downgrade your firmware manually.

To downgrade firmware, please follow instructions available from Firmware downgrade - Trezor Wiki.
Firmware needed to be installed webwallet-data/trezor-1.9.0.bin at master · trezor/webwallet-data · GitHub.

Hi Kolin,

this looks like risky operation. If I downgrade my wallet FW, all my funds in wallet will be erased?

This is the only way to do it. Just make sure you have your seed available to recover your wallet if anything goes wrong. I would suggest to do a dry run recovery first to see if your seed is correct.

Hello Kolin,

So I followed the steps, and unfortunatelly it didn’t go well. Trezor is showing this:

I’ve made ticket - Ticket ID: 75651

Question is: are all coins which were stored in Trezor lost now?

Thanks for letting me know, we will reply in the ticket. As long as you have your seed, your coins are safe. They are not stored in the device. All coinse are stored on the blockchains and the device holds only the private keys. You are able to recover your seed to another Trezor device or any other BIP39 compatible wallet - most of them are.

Hello Kolin,

thank you for support, I will wait for the instruction in the ticket.

Just for the information… Can I somewhere watch the progress or discussion of that ticket, or I will be notified only via email?

Hello Kolin,

so I recieved the answer from support, as you might see in Ticket 75651. There are very limited options right now. Thing is that my Trezor One is currently unusable as you can see in the picture above, and in the ticket isn’t mentioned how to fix it.

Is there some way I can make Trezor work again, or I have to go for new one (and possibly with old firmware)?
How long can LTC stay on that wrong address? Is there some time limitation, or LTC can be stored there “forever”?

Thank you.

Hi David,

yes, these options are the only ones you have at the moment. It you are having an issue with your device, reply back to the ticket to solve it please. My colleague will for sure help you with that. The LTC can be stored on that wrong address forever if you don’t claim it. There is no limitation.

Hi Kolin,

It is while now since I created a ticket with question if it is possible to recover Trezor One, but didn’t recieve anwer yet. Can you check the status?

Ticket ID: 79412

Thank you.

Hi David,

I see that one of my colleagues replied to you on May 28 to the original ticket #75651. Did you receive it and did you check your spam folder?


Yes, in this case I received the answer, but only with possible solution to get LTC back (basically only option is to upgrade to Trezor T). However in response wasn’t included if there is possible to revive Trezor One after unsuccessful FW downgrade. So I responded back with question regarding this to Pavel, but didn’t receive the answer as well. So that’s why I created a new ticket which I mentioned in previous post.

Thank you.