Send Error “ is not a function”

I am able to log into my device via suite web. However, when I click “send” to go to that section from the homepage, it shows this error.

Surprisingly, it does not show when I click “receive”

Hi @jmclaren,

have you tried to click “Clear storage and reload”? If so and the issue persists, please try to clear the cache of your browser, and eventually reinstall the browser. Do I get it right that you use Chrome?

Can you send your funds from the desktop version of Trezor Suite? It can be downloaded at

Yes I’ve tried clearing the cache and reload both but doesn’t work…I’ve also tried the same on chrome and firefox both but no success…

I cannot use Trezor suite app as my machine is too old so i have always been using the web portal since day 1…

Ok, try to reinstall the Chrome and Firefox browser and also try to open the web version in incognito/privacy mode. The issue can be connected to the old version of the browser on your computer. May I ask you what versions of mentioned browsers you have?

  • MacOS is 10.10.5

  • Firefox 78.15.0esr (64-bit)

  • Chrome 87.0.4280.88 (x86_64)

I will try with incognito mode and let you know.

It doesn’t work in incognito either…

You are using old versions of browsers. Please, update to the latest versions or reinstall the browsers.