Saw error on Model T while updating firmware. Now can't recover wallet. Please help!

Hello. I recently updated the firmware for my Trezor Model T inside the Trezor Suite on my desktop. While doing so, a (concerning) error appeared on my Model T, indicating that the firmware update had failed. I unplugged and tried again. When I reentered the Trezor Suite, I began the process for recovering my wallet. To recover, I began entering my seed phrase. I have tried several times correctly entering my seed phrase letter by letter to no avail. The device keeps telling me the seed phrase is incorrect, which is impossible. Has anyone ever experienced this before or know what I can do to recover my wallet?

Thank you in advance for any tips you can provide.
B.R. Gilton

I posted last night after having a similar issue after updating software and trying to enter the pin on my device. I’m going to follow the instructions that says I need to reset my device and recover my wallet using my seed. Based on all of the other posts I’ve seen on this forum I’m already resigned to the fact that I might not be able to access my wallet and have lost my coin. Very very disheartened by this whole thing. Invested in an external wallet so that I could protect my coin. I wonder if it was a A rip off from the start we’ve all been conned.

  1. Let’s get this straight. You both have your old seeds. Whatever problem the Trezor supposedly has, it does not affect your seed data. So absolutely nothing is lost.
  2. A firmware update problem does not affect the Trezor hardware. You can just wipe the Trezor and start over.
  3. Finally, you complain that the Trezor won’t load an old seed. This has nothing to do with points 1 and 2.

Do you have any insights as to why the pin code which I know for certain is correct is now not working? Seems strange I’m not the only one experiencing this issue.

I’m not complaining. I’m just trying to solve the problem. You say, in #2, that I can wipe the Trezor and start over. How?

will the trezor connect with trezor suite to perform a wipe?
if not try the trezor command line.

The other thing I do is set a wipe code to like 1234 and put it on a piece paper with the trezor in the box.
write PIN next to the code.
If anyone finds the trezor and uses this PIN, it’ll be wiped.
But I can use this to wipe the trezor myself if I wanted, in a hurry or to perform a complete reset.

Thanks so much for your thoughts. Can you help me understand a bit more about what a “wipe” implies? I’m reading that it means getting rid of all the data on your device, which sounds alarming. As it stands right now, as soon as I plug the Trezor Model T into Trezor Suite on my desktop, I’m immediately invited by the Model T to enter my seed. There is no option to enter my pin or any other preemptive step; I go right to seed. And it won’t accept the seed that I 1) know 100% I’m entering correctly; and 2) have entered correctly repeatedly 12 times now to no avail.

Please help?

sounds like the trezor is already wiped of any previous seed related stuff.

I’d would do another wipe and re-try the seed afterwards. But the seed system has like a checksum built into it to try and mitigate wrong entry.
So it maybe that the seed you wrote down on the initial setup wasn’t exactly right…

did you use a passphrase as well?
You could use a hot wallet with the seed you have there (but not all support passphrases)
If you manage to get access to the correct accounts using the hot wallet, then just create a new wallet/seed on the trezor and then transfer funds back to trezor’s new account?

Just ideas for you…

Thanks, Doge! So is the thinking here that (assuming the old wallet wasn’t passcode-protected), I can use any hot wallet to enter the seed phrase and access the funds?

Also, Doge, I downloaded a hot wallet (Trust), entered the seed, and still nothing: it’s telling me it isn’t a valid seed phrase. Again: this is impossible. I have retained my seed phrase from day one, and have even used it effectively before. It’s as if the key itself has been corrupted somehow (even though as far as I know that’s impossible). Thoughts…?

Dog, if you have a particular hot wallet you’d recommend, lemme know?

so if you didn’t use a passphrase, then I believe that the trust wallet would accept the seed phrase and give you access to the funds.

However, it appears that the trust wallet agrees with the trezor that the seed is incorrect. It doesn’t pass the checksum/ doesn’t meet the seed specs.

So my guess is the seed isn’t quite right somewhere, it wasn’t correctly copied from the device on to paper during setup.
I know you seem really sure it’s correct, but you now have 2 different wallets that disagree with you.

you could try the seed in metamask I suppose, I think you’re going to get the same result.
I’m really sorry, but i just can’t see this any other way.
Perhaps someone else will suggest something better than me…

I notice there are seed guessers out there.
they try to guess a correct seed from an incorrect one. If it’s close…

However, I’m not going to recommend such things as they could well be used to steal funds.
So if you get desperate and go down this road, I’d recommend extreme caution and understand what you are doing…


Thanks so much for the thoughts, Doge. I’ll look into the metamask. Lemme know if you have any other specific thoughts about that, in terms of which to use? I’m definitely at a loss for words b/c, again, I’ve used this exact seed before and it worked, so for it now not to be working, just seems impossible. Luckily there isn’t that much on the wallet…