Restored Ledger to Trezor ETH not showing correctly / derivation path issue

I restored a ledger to a new trezor using the 24 seed words. Only one coin is showing up in the Trezor. I can’t see the other coins. How can I get them to show up?

Thanks in advance for any support!

open suite , click this
c
add the coin you need

I can add the coin, but asset is not connected to the ETH address. So it shows up empty.

your asset are tokens ?

Yes. SHIB for example. I have added it, but it shows empty with no coins in it.

is the eth receiving address right ?
if it is right , you have to add tokens to your eth wallet .do like i said in here

First, check whether the eth receiving address of your ledger wallet is the same as the eth receiving address of trezor wallet.

Yes,. I have added the SHIB contract address. The tokens do not show.

Wait a minute, I summoned management in another post.
i don’t know how this happened . i want to know too

The receving ETH address is different. How do I create the receiving address on trezor to match the receiving address from ledger?

In the suite, I really don’t know how to add extra eth accounts under the same wallet. The web version of the past can be more convenient.
If you use trezor to connect to matemask, there should be 10 eth receiving addresses to choose from.
ledger with the same 24-word seed connect to matemask, and there will be 10 alternative addresses.
I guess the order of the 10 addresses of the two wallets should be different.

I see. I’ll connect metamask and try to create the account in trezor that way.

You can connect trezor to matemask to find other addresses, you should be able to see your shib and other assets under that address

Cool. will try that. Thx so much!

Hello,
The explanation is that Ledger and Trezor use different derivation paths for ETH. While Ledger follows BIP32, Trezor, on the other hand, follows BIP44; Address path (BIP32) - Trezor Wiki & Cryptocurrency standards - Trezor Wiki

In such case, a third party app such as MetaMask, MyEtherWallet, or MyCrypto is needed to set a different derivation path.

Once Trezor device is paired with any of previously mentioned apps, continue with setting the derivation path needed.

See instructions for MetaMask https://metamask.zendesk.com/hc/en-us/articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet

See how to set a custom derivation path for MEW Using a Hardware Wallet With a Custom Derivation Path | MyEtherWallet Knowledge Base

Hi guys
I had a metamask wallet on a nano ldeger which I used the metamask 12 word seed for the ledger seed.
The ledger melted and so I bought a new Trezor. I have tried to add the metamask wallet to the new trezor but the wallet address is not on the list of available wallets to add to Trezor i cannot find it anywhere. can you help me please

Hi, Ledger uses different derivation path for ETH.

So you can connect via MyCrypto, select Ledger path and you will find your coins there, then you can send them to your Trezor ETH path address.

note that you’ll need to disable “Safety Checks” via Suite for this to work – there is an open issue to allow legacy Ledger paths, but it’s only going to be fixed in the next firmware release.

I don’t see instructions for MM in the link, am I missing something? I tried other derivation paths over mycrypto and MEW, but it was impossible to find any addresses I see on my ledger nano x.

Is there something I’m missing? My initial thought was that the passphrase was only for the trezor address I see (I see only one address with funds in my trezor), and the other addresses I see on my ledger (I see 3 addresses with funds) are attached to the same pin, so that is why I am able to access them, but after restarting my ledger, I double-checked, and the passphrase reveals three addresses while the trezor only shows one. What should I do? Due to that, I can’t use my trezor.

Are there any updates on a new firmware release that fixes that? Is there any other solution besides MEW or Mycrypto? Maybe a MM instruction (the link provided above doesn’t say anything about changing the derivation path to be similar to the ledger).

Thanks in advance!

Hi @guyco77,

unfortunately, custom derivation path can’t be set in MetaMask, which means you need to use MEW or MyCrypto.

In case you have your ETH on the 2nd and 3rd account and can’t see these accounts after setting Ledger derivation paths, you need to manually set custom derivation paths for these accounts. In MEW you can set a custom derivation path by selecting “Add Path”. In MyCrypto select “add a custom derivation path”

MEW

MyCrypto

To access 2nd account, the derivation path needs to be set to m/44’/60’/1’/0
To access 3rd account, the derivation path needs to be set to m/44’/60’/2’/0