Recover/Restore Monero / Trezor T with seedphrase ▫

I am using the Trezor T to store monero; I forgot my PIN, I do have my seedphrase. I tried re-downloading the Monero Wallet but it’s asking for a 25 word PIN and mine is only 12 words long, so my question is:

  1. How do I restore my Monero wallet? Do I need to wipe my Trezor first (I’m terrified of doing so, even though I have the 12 word PIN).

Thank you.

Hi @NotSoAnonymous

Please, follow this guideline to recover your wallet

If you used your Trezor device with Monero client before choose “Restore a wallet from device. Use this if you used your hardware wallet before.”

When I open up the desktop GUI wallet it’s asking for my passphrase and I forgot it. I have my 12 word seedphrase, can I not restore the Trezor device itself using this?

Or please tell me what I need to do from here.

Are you sure you had a passphrase in the first place?
Try entering an empty passphrase (just click OK in the Monero GUI or on Trezor) and see if you can get back.

(If you used Trezor Suite, you might have enabled “passphrase protection”, but it’s not active unless you actually set up a passphrase.
However the Monero GUI does not know this and will ask you for a passphrase.)

If you did in fact use a passphrase, but forgot what it is, you’re out of luck. The passphrase works in addition to the 12-word seed, and you need to have both.

I will check if I set up the passphrase or not, but are you sure I need the passphrase for Monero GUI (if I have one), even if I’m restoring the Trezor T?


However, I do have a passphrase on Monero wallet and I do not remember it. Now what? I have the PIN, and the seed, can I “recover” my keys/monero somehow?

Assuming he used a passphrase at all. I’m not convinced he did. And why should Monero GUI ask him for his private seed? It doesn’t make sense to me. It could be the Monero Wallet seed the program is asking for?

There are two separate “password” features for Monero GUI.

There is a wallet password, which protects your wallet file.
It looks like this:

If you don’t remember the wallet password, you can just “Create a new wallet from hardware”, and choose the “Restore” option:

For “wallet creation date”, pick a date that you know was before you received your first XMR.

The other “password” is the Trezor passphrase. It looks like this:

This is the Trezor passphrase feature.

If you ever used this with Monero, and don’t remember the passphrase, you cannot restore your wallet unless you remember the correct passphrase.


I deleted my post above with the incorrect information.
I also deleted my second reply in this thread, since @matejcik’s answer was much better and official too.
Sorry for deleting replies, which I normally never do, but in this case it was the right thing to do, to avoid confusion and misunderstandings for OP.


Thank you, what I had to do was “Create a new wallet from hardware” and then choose “Restore”. I have my Monero/private keys back :^)


Hello sir,

I have a very similar problem at the moment, although I am not prompted with a hardware wallet passphrase after i follow the step on “create new wallet” page. I click restore option > put the wallet creation as 1st jan 2020 > click model T > Create wallet.

I am then presented with a loading screen that states “Please proceed to device”
I punch in my PIN into my trezor, then the trezor asks me to confirm export watch only credentials, I click yes.

Then this screen appears:

Its attempting to create a brand new wallet even though I clicked the restore option.
Please help I have significant amount of monero at risk here :frowning:

Yes, that is what Restore does.

Please go ahead and choose a password so that the process can continue.

Done sir. I made 3 new wallets lol.
What next please? :blush:

Still waiting for a response.
Please help.
Ive been messaging your trezor support back and forth for a month, they can barely speak English. It’s quite frustrating.

Hi Petosiris, my name is Brad i need a lot of help :joy:. I have lost my coins in a secret wallet witch I didn’t know about and then I have 23 unauthorized transaction can you please help…

Hi guys I’m missing some coins I believe I may have sent them to a secret wallet which I didn’t know.Now I have 23 unauthorized transaction I put a ticket in but it takes up to 20 days going a bit Crazy :anguished:. Can anyone Please Help :sos:

Basically, if you created a Hidden wallet with a Passphrase, you have to enter the Passphrase exactly as you ctreated it, possibly with large and small characters. Also, a space is a possible character. If you cannot remember your Passphrase, it’s impossible to access that Hidden wallet.

What’s your Ticket ID, @mike04?

Sorry about the 3 different post this is My first time sorry again…My ticket#96713 I can’t access the secret wallet but it’s 23 different transactions and authorized…

@Bignoob not sure what your question is here…? did your coins not appear?

Then your problem was probably not the same as the OP’s.

Please start over :slight_smile: describe what is your problem, what was the original situation, what you tried, etc.

Thankyou for your response :slightly_smiling_face:

Okay, I lost my password and seed phrases for my monero gui wallet (I have significant holdings on there), but I created a hardware wallet with my trezor model t and my monero is stored on my trezor.

I have no idea how to use my trezor to reclaim my monero.
I have complete access to my trezor, it does not have a passphrase either.

This is my situation :pray: