Reboothloader failed for firmware update

Cannot see ETH balance in my trezor , I do update firmware but it keep showing at rebootloader page . I have tried follow the instructions by disconnect and reconnect with pressing the buttons many times and different computer . It’s still not working

It is recommended that you use the seed phrase to restore the wallet and re-operate.

Hi @joyce

Could you please clarify if you are not able to get into the bootloader mode or your device is stuck in bootloader mode ?

My device is stuck at the booth loader mode . I keep doing repeatly connect the device and press the both button while reconnect it . But it’s not responding


Since your device is in bootloader mode you should see following screen when connecting your device to

Please click on the green gear wheel to go to the device settings:

As long as you have verified recovery seed you can proceed to factory reset that will erase everything on your device including firmware.

Please tick both boxes in the next pop-up window and confirm the action also directly on your device.

After this procedure your device will be empty.

You can reconnect it and go to Trezor Suite again, install the firmware and proceed to recover your wallet.

My problem is , I stuck at the 2nd picture do hundred time also can’t work .

Do u means I need go for factory reset before doing this update ?

yes factory reset usually solves the issue however you have to connect the device in bootloader mode even when doing factory reset ( as mentioned in the manual given).

So if you still have issues to get into the bootloader mode please open the ticket on our support page and provide the video showing your issue so we could eventually proceed to RMA.
Thank you.

It did the recovery redo pin also . Now I can’t go in as keep asking setup trezor . When I go to set up it go to firmware update and repeat the connecting and press 2 botton again

Please help to solve it urgently

Hi there …. Finally access into trezor but still ETH wallet display nothing . “ account discovery error “ ui-device_firmware_old

Why so hard to get update for firmware ? Create lots of problems to users .

@joyce do you use Tor feature ?

Tech stupid here. Any help is much appreciated.
I didn’t get involved with Crypto when BTC was $400 because I knew my tech limitation. Finally I pulled the trigger. It took me 6 months to open my new Trezor to pair with my Exodus.
I can only store BTC and ETH there. I didn’t want USDT but that was my only option. ADA, DOT, SOL BNB are not supported or I didn’t know how to do coins with ERC20 behind them.
Tonight Trezor prompted me to update firmware, cautioned me to have seeds ready. I followed instructions. I didn’t need the seeds. I thought I did it correctly. It wouldn’t let me transfer coins out. After hours of struggle I realized I had an error msg on my Trezor Suite - “Device detected in wrong state”
Google told me to update firmware. But I think I messed up the update and now have to fix it. Last thing I need is to have tried too many times and lose everything inside. Can that happen? lol
I wrote Trezor support with Ticket ID: 121872
MetaMask? Bootloader? What are they please?
Can someone show me how to do coins in Trezor with ERC20 behind them please?
Thank you in advance.

1 Like

Me too , I am still awaiting for solutions

Already do all these still the firmware can’t update

Nope . It’s off and not activate

try to update via old wallet here: Trezor Wallet

follow the manual: User manual:Updating the Trezor device firmware - Trezor Wiki

1 Like

its successfully done forgi, praise Lord. Thanks so much.

your are marvelous.

Hey Technical team Trezor, your should learn from forgi .

after this wallet close forever ,how can we solve problem like this?