"Power surge on the USB port" - Laptop shut off when I plugged in Trezor T

Ticket # 119529

  1. I plugged my brand new out of the box Trezor T in my home laptop and immediately my laptop shut off?

  2. I then plugged the new Trezor T into my work laptop and then error came up stating " Power surge on the USB port… USB device needs more power then the port can supply"

How do I fix this? Do I buy USB HUB or is the Trezor I bought bad, etc?

Sorry about the ticket language, I have been waiting on this already a week and was very frustrated when wrote ticket! LOL


Where does the message appear, on Trezor or on your laptop?

This will be your laptop/USB port issue most likely. Have you tried different cables?

Different computers? If on other device Trezor functions well then it is your setup issue.

this would indicate that there’s a short connection either inside the Trezor (broken unit), or in the cable.

@Angel31605 try different cables, and if it is the same we will replace your device, your ticket has been answered.

The message appeared on my work laptop. my trezor never turned on at all on either laptop lol

when i plugged trezor t into my home laptop the entire laptop just shut off immediately?

Brand new out of the box and i used the cord that came with the trezor. i bought trezor from Trezor io website.

tried different cable. same issue.

Tried two different devices and two different cords.

I answered your ticket response and THANK YOU for your quick response and help!!

Sorry again for frustrated ticket!! LOL

Let me know how to return wallet and when can I get new one and if i can pay expedite fee to help get here earlier,-:slight_smile: