Pop up window dissappears when confirming metamask transaction

Randomly, when I submit a transaction in my trezor-metamask wallet, the trezor.io pop up window appears and goes out in 2 seconds. Sometimes it works (1 out of 10!) but most times it doesn´t. Tried booting, deleting cache, etc. but nothing happened.
And I can´t find any links to talk to the support team! All my coins are locked in my trezor-metamask wallet!!
Trezor model T. Happened after I updated the new firmware.
It doesn´t seem to be a metamask problem, the problem happens when the pop up window opens and closes

@sebastianv update your MM wallet too, also make sure your pop ups are not blocked by browser

Thanks. Pop ups not blocked (in fact, the window appears, and then dissappears). Mmask updated to 10.8.1, I think it´s the latest

@sebastianv there was this issue in MM and it is fixed, it has been tested.

Update your FW and MM and try different browsers (Chrome or Firefox)

Thanks, but still not working. As you can see in the post you shared, in the most recent posts (hours/days ago) there´s still users reporting the same problem (and they seem to have everything updated).

@sebastianv what FW version and OS do you have? Is the issue same in both browsers?

Hi, I have just imported the seed from a metamask account. Currently connected to the same account with the trezor. I was on some defi website for adding collateral, After I clicked on add collateral. metamask popped up, I confirmed it. I am supposed to get a verification window right? The window did pop up, however it closed itself before I could do anything, My transactions are all queuing up one after the other. All of them have failed now. The transactions have not appeared on the explorer though. I just got a new trezor one today, I am on Brave browser. Help me out.

I am not using a phrase, I can see the funds in there in MM. I try swap or even move between accounts and the approval screens are not appearing. I see them flash up for a second, but thenthey went away and the transaction times out waiting for approval. It worked yesterday and now it will not allow me to approve. Any suggestions?

@BLind we are looking into this issue of popups closing

Thank you for your help.

Hi Forgi,
Just checking to see if there are any updates on this issue. I can’t move anything with this issue as all my coins are in my Trezor.

Thank you,

I tried it again and it will not keep the tab open for more than a few seconds. I then went to history and opened the closed tab. It was just sitting and spinning with the loading circle.
Not sure if this helps, but it does seem to be a Trezor issue if the program won’t load.

Please advise

@here Please see the solution and test results from QA here:


Thank you. I am not a tech expert. I figured out how to disable adblock but I have no clue how to install the latest bridge (2.0.31) the firmware is up to date, is this the same thing? Also, the "do not check the chrome extension below I am not even getting this to at this time.

Please let me know on the bridge part.

Thanks again for your help.

I found the bridge site. it states I am already on 2.0.31
Says the latest update is 2.0.27.
This does now seem correct as the number is lower.
Can you confirm if this is correct and safe?
The site I’m on is Trezor Suite

yes 2.0.31 is bundled in Suite, if you have it installed then launch the Suite and proceed with the rest

not sure what you mean, process the rest. I should do the update to 2.0.27?

no, proceed with making MM transaction, the issue was closing popup

I tried and it still is not working

the checkbox you are not getting shows up when you connect Trezor and it asks for public keys