Pending transaction ETH

Hello Pavel,

Thank you! I opened my Trezor account with MEW Wallet and sent 0 value transaction with the same Nounce. And unbblocked my transaction!.

Thank you very much !!! :slight_smile:

Sure thing, you are welcome. Glad we could help.

1 Like


I have send my balance in my Trezor to my MetaMask wallet to purchase an NFT. I selected MAX balance and confirmed. For almost 12 hours now I have been waiting for the balance to go through.

I tried “bump fee” but doesn’t allow me to do anything. It says not enough funds.
I added more money from another account and tried to bump again, still says not enough funds.

I don’t know what to do but I need that transaction to go through. This has been a very frustrating and terrible experience! I have not experienced anything like this with MetaMask and other wallets.

Hi sir
I having the same issuel, i using the form you gave and have a Ticket ID: 96232
What can i do now? Thank you

I also have this problem with strezor suite unable to increase gas to push the transaction through

Ticket ID: 96234

I’m in a panic and confused. I have transferred almost all of my funds to TrezorT.
Today I wanted to send BTC. But my wallet is broken. I do not know what to do! Please help me. All my money is in this device.
I tried to transfer different amounts. I chose a different commission. But after confirming the transaction on my Trezor T - it hangs for a long time. After that, it is automatically blocked and the application ceases to function normally and starts working only after restarting. Trezor firmware version is 2.4.1

Hi @misterzayats,

This is probably because of many small BTC transactions into your Trezor and when you try to send out BTC the Trezor memory gets full and stop up on signing the outgoing transaction. Try to send smaller amounts and see if that goes better?

Also, look here for a wider explanation: Stuck on signing tx - #12 by Petosiris

For the entire time of use, I had only 13 transactions!
I have tried sending 0.05 and even a very small amount of 0.001 BTC with no success.
Moreover, this device is a WALLET! I should be able to buy, sell, give BTC.
When I bought the Wallet, I did it in order to replenish it and keep my savings for a long time. It was not written anywhere that it can be transferred only 1 time 10 or 100BTC.
Today I stop using. And I need to get my funds back.
How can I do this now? I do not have the ability to make tens of thousands of transactions for $ 1-2 to transfer all my funds to another wallet.

Please understand that it’s not possible for me to know how many transactions you had ingoing to your Trezor and how small or large they are, before I give you an answer. I can only work out an answer based on the information you provide.

My transactions were 0.0023-0.0028 BTC. 13 pieces
In addition, I had several XRP transactions

On your recommendation, I tried to do very small transactions, but it doesn’t work.

Who can help me!?

Hi @VanHuynh @pam

Thanks for submitting your tickets. Please, see your inboxes.

TL;DR Based on the status of your TXs, these TXs have been Dropped & Replaced most probably due to one of the reason:

  • The earlier transaction had a low gas price which would take a very long time to confirm, so a second transaction with a higher gas price was created to replace it
  • The Ethereum Node that the wallet/service connected to was not fully synced, and an incorrect nonce was used
  • User-initiated to replace or cancel a pending transaction

Hi @mcbeth1044

Thanks for submitting a ticket. Please, check your inbox.

TL;DR Based on the status, your tx has been Dropped. Learn more about possible reasons Transaction Dropped & Replaced

Hi @misterzayats

Basically, there might be two reasons preventing your from making a tx.

Either, it’s a dust issue.

Or, there might be a memory issue preventing you from signing a tx when a custom homescreen is set. Therefore, please if you have a custom homescreen, disable it, choose a default one, reconnect your Trezor device, and let us know if this helps. If not, please try to reconnect your device several times. Actually, the process of uploading the logo consumes some memory that might not be cleared properly.

Hi Pavel, I have the same problem with my transaction being stuck and I can’t bump fee because it says not enough funds even though I have enough ETH.

Ticket ID: 98387

Can someone please take a look and help me here?

Hi @Mxr

Please, try any other compatible third party app for replacing / cancelling pending tx. More information available from

Please, check your inbox and come back to us. We will troubleshoot your issue via email. Thanks for understanding.


I am having the exact same issue and this is to my great surprise as I have never ever had to wait so long for a crypto transaction to go through. This is very frustrating as it is a very important transaction and the trezor suite set a gas price of 33 GWEI as normal and I trusted this suggestion, also because another transaction that went through previously just shortly before took only a few minutes.

We will need to buy a house from that money and we are now loosing thousands because of that delay! Hence I ask you to please treat this issue as a matter of urgency, ticket ID is 100011. Thanks!

Hello, @djcat,

If your transaction is delayed because of too little gas, try to bump the fee up with Trezor Suite. This function is called Replace By Fee (RBF for short) and enables you to replace the fee amount you originally sent with a higher one. Note that the bump fee feature only works if it was enabled when you sent the original transaction and if there are no previous transactions (with a lower nonce number) before the one you bump. Also see this post for more info.

If that’s not the case, please see if this video can help you: FIX Stuck Transaction on Ethereum - YouTube

Otherwise, you can wait for Community support to answer your Ticket ID 100011.

Good luck, and also good luck with your new house! :slight_smile:


Thank you for your reply, I was desperate. Unfortunately I did not see that feature in the trezor suite or it did not work, the forum also does not seem to know that. In any case after many crazy hours of reading, sending transactions to myself and etc. I was able to reset the transaction using Metamask.

I apologize for the commotion, it will be a memorable house that I might call “crypto castle” :smiley:

Best regards,


1 Like

Im also having issues. I have 2 pending transactions well over 24 hours and now when i try and access my trezor it says something appears to be broken register protocol handler is not a function. I cant bump my fees i get this message every time. This message appears instantly when connecting to my phone or pc. Need help soon not in 20 days to fix my money being stuck,