Opensea and MetaMask will not allow signing of transactions to place items for sale that are stored in my Trezor wallet

yes, I’m having the exact same issue. this has cost me losing some eth due to cannot keep up to the market. Until now, no one has reach me and help.

Stop tagging me with the metamask Trezor tweet. So many commented it’s still not working under the tweet…….

The problem persists and as a new Trezor owner it’s alarming that the needle hasn’t moved in this regard one iota in over the past 6 months.

@Zeal @IRONSAM96 this is not issue of Trezor, users have reported it from other wallets so it’s Opensea mainly and MM.

Clear cache, reconnect a few times, use different browser.

I have been able to send Polygon NFTs via Trezor-less MetaMask & OpenSea.

I am able to send Polygon NFTs via Trezor-less MetaMask # OpenSea.

Threads like this exist for a reason:

But OK.

1 Like

A post was split to a new topic: Opeansea and MetaMask won’t allow signing of transactions


any update on this topic?

i have the same error, when i sign the transactions nothing happens.

need help , need some liquity plzZzz

My trezor stuck in this page, I click accept and sign in metamask, It had no response. I have a NFT in trezor and I want to sell it in opensea. help me plz

Hi @xincctnn,

If you’re from China, I guess this is not an Opensea or Metamask issue, but rather that the Chinese government block the Trezor connect API which both of these third party sites use. See more here about this issue.

1 Like

Great solution…

I’m being sarcastic. This is really not optimal.

Why can’t you provide support for NFTs in Trezor?


Note the date of the message you are replying to. Things have changed since then. :slight_smile:

Trezor can’t connect to OpenSea through Metamask. I tried in multiple browsers.

When you try to sign the transaction to connect it displays the binary data on the Trezor One device but the “confirm” option won’t work. It just refreshes the binary data and stays on that screen.

Since you cannot send NFTs inside the Trezor Suite and can’t connect through Metamask to OpenSea there is no way to move your NFTs from the Trezor One. They are stuck there.

The only other possible way to resolve this would be by sending them out from inside the Metamask browser extension but their dev team still hasn’t built out this functionality. Trezor One can’t connect to mobile to do it from Metamask mobile.

So for now thanks to both the dev teams on Trezor and Metamask, anybody who decided to safeguard their NFTs on the Trezor One is stuck with them and no ability to send. I guesss at least they are secure LOL.

But seriously this is a big fuck up from both of the developer teams.

  1. Why the hell would you not include NFT support in Trezor Suite? Planning on staying in 2017 forever?

  2. Metamask team needs to get the ability to send NFTs from the browser extension up and running. Then at least you could do a bulk transfer back over to Metamask (although it’s a big security risk and user error risk of screwing up the transfer). That way you could at least manage them through OpenSea.

Ledger is pulling ahead here. Devs do something. Thanks.


@Perogi I think this is a huge feedback for the Devs to look into. I advise you clear your browser cache to resolve the “confirm” option error.

I recently did the firmware update 2.5.2 for Model T on Mac OS. Immediately following this update, I am no longer able to sign any transactions via Metamask integration. I get the pop-up for passphrase, but no pop-up generates for signing the transaction. I had issues in the past when OpenSea changed to the Wyvern contract as well, months later it was resolved and all was good.
I’ve successfully reverted the firmware back to 2.5.1, but the problem still remains. It seems perhaps the bridge just isn’t populating the second pop-up window that allows one to actually sign transactions. Needless to say, aside from restoring my seed to a more compatible wallet such as Ledger, or a non-hardware based wallet, all funds and NFTs are locked again.
I’ve been a fan of Trezor for many years, I also understand changes can happen by 3rd parties that can affect the integrations of Trezor with them, no fault of Trezor’s, but in this particular instance, it was directly related to this latest update. It seems many people in the NFT space are continually being drawn away from Trezor, with issues like these, it makes sense. Some priority level and expedited fix would be greatly appreciated, but Trezor will probably end up being my crypto only wallet.

1 i connected my trezor one to metamask
2 i link the metamask to opensea
3 i bought a bunch of NFTs
4 when i want to sell, sell confirmation can’t proceed.

I’m having trouble connecting to opensea, I can’t list price new and list my art new opensea ETH. What do I have to do. I update new firmware but i can’t list price new and list my art new.

2022-03-01 (6)_LI

also me !!! its so complicated and confusing me

I have this issue too.
So we have an issue with metamask in combination with trezor and third-party NFT apps.
It’s not just opensea - it’s also rarible, looksrare and manifold.
Very disappointing.

A workaround is to use ‘Enkrypt’ wallet in combination with trezor as an alternative to metamask.
It’s legit, made by the people who developed myetherwallet (MEW). DYOR and be super careful with what you sign, etc.

I had the same problem then after researching for days i found out that you must download the trezor bridge it isnt included in the suite which is strange BUT not mentioning it to us ANYWHERE for instance here by answering one of us