My account is perpetually loading and I can't see Ethereum wallet


My Trezor Suite is continuously “loading” other coins besides Bitcoin (I have only Bitcoin and Ethereum enabled) but I can’t see any Ethereum wallets. I have a Trezor Model One. Please help me out - does Model One and Trezor Suite no longer support ethereum? I’ve attached what the wallet looks like. I’ve attached a picture of the coins enabled on this wallet.

My firmware is on 1.12.1 which I believe is the latest and the “Type” is “Universal”.

is internet connectivity OK?
have you tried ETH in Metamask with the trezor?

yes ETH is supported on model 1

Yeah my internet connectivity is all right. Should I be trying to use Metamask with Trezor?

Hi @june84,

There is most likely a synchronization issue with our backends. First, I would like to ask you to try resetting the Trezor Suite. You can reset Trezor Suite in “Settings” (gearwheel symbol in the top right part of Trezor Suite). Navigate to the “Application” tab and select “Reset app”.

If it doesn’t help, please try to uninstall your Trezor Suite desktop application, download the latest installation file from this source Trezor Suite App (Official) | Desktop & Web Crypto Management and install it again.

May I also ask you if you are able to load your ETH account in the web version of Trezor Suite? The web version can be found here: Trezor Suite

Please note that you need Trezor Bridge installed on your computer for the web version. You can download it from this source: Trezor Suite
(use supported browsers for the web version of Trezor Suite - Chrome and Firefox)

Let us know the results.

Hi radekP,

I have the same issue (endless loading) with desktop application, but I can load account in the web version of trezor suite. I have tried to reset the app and reinstall the app, don’t help.

Anything else I can do to fix the desktop issue? is there any difference between web version and desktop version? Can I just use the web version, including firmware upgrade and etc?


Hi @kenshinsee,

First, try to enable TOR feature in your desktop version of Trezor Suite (if it is already enabled, try to disable it). Maybe this feature is causing your connection issues (

Do you use a VPN? If so, try to disable it. Also, please keep in mind that in some countries (for example China), our servers are blocked and can be accessed only with VPN via the web version of Trezor Suite.

The TOR feature is the only difference between the web and desktop versions of Trezor Suite (which also means that there is no coinjoin feature in the web version). The security is the same for both versions. If you will use the web version, I can recommend bookmarking the URL (