Labels On Wallets Disappeared after update

Just updated suite a few days ago and noticed that the labels for my wallets are gone. Well they are all gone except for the most recently used wallet (this one still shows up as it should). I did an experiment and relabeled my wallets, then I quit suite and reopened and the labels are gone again, except for the most recent wallet that I used. All the other wallets just say “Hidden wallet #1” or “Hidden wallet #2” etc. Seems labels don’t work anymore after the latest update? Never seen this before but appears to be a bug.


I should also add that it is not only the labels for the wallets but also any labeled accounts within the wallet as well which are missing. So, the last used wallet still has its label and its accounts also still have their labels. The other wallets have neither their labels nor their accounts’ labels.

I ended up finding this page (can’t post links) trezor .io/ learn/a/labels-in-trezor-suite and decided maybe I’d try a couple more experiments. First I “disconnected” labels in settings and tried to save them in the cloud (by connecting to Drive) and when that didn’t work I tried locally and no luck there either. A couple observations:

When I try to save a label on one of my accounts in a wallet there is an infinite spinner that says “Rename” next to the account; a snackbar pop up that says “Error: Labeling action failed. Error: trying to fetch entity without metadata”. This is initially reproducible.

So the next thing I did was Eject all my wallets and restart Suite. Enter all passphrases and relabel everything. Suite says I’m saving labels locally in Settings. Also, now the snackbar error is not reproducible. Now I eject the device but Remember all my wallets. All labels still there. Restart Suite. All labels gone except for most recently used wallet. Also, labels that used to say “Hidden Wallet #3” and “Hidden Wallet #4” are now renumbered as #1 and #2, which is strange.

Anyway, I don’t know if something became corrupt locally, or if this is related to the Suite update; hope there is some way to get labels back in a new update or some kind of process I can do to get them working again but I can’t figure it out.