Keep getting NO USB CONNECTION when trying to connect to laptop.?

I haven’t used my Trezor T for a while and I can not connect to Trezor Suite. It keeps giving me NO USB CONNECTION. I’ve tried multiple cables, bought a new cable for date transfer. Still same issue. Any one know what the problem is?

2 Likes

what OS?
tried other PCs?
does the trezor power up?
very little info to go on…

1 Like

Im having the exact same issue. I have tried multiple cords to no avail. I havent used it in a couple of months. i tried to hook it back up to my laptop that I had no problem with a month or so ago only to get the red banner across the top of my trezor that says " no usb connection"

1 Like

yeah, the trezor powers up but stays on the lock screeen with a red banner across the top that says no usb connection. its on but wont recognize the connection and wont connect to my laptop trezor suite

1 Like

tried a different computer? different USB port, many usb cables seem to be charging cables only with no wires connected for data, so avoid those for sure.

1 Like

Hi @nix2nix and @LITZ ,

No USB connection message indicates an issue with the USB cable/ USB ports.

As @doge mentioned, try as many USB cables as you have. Make sure the cables are capable of transmitting data (not only power).

Trezor can be a bit picky in terms of USB cable, even the slightest defect may be causing connectivity issues, the cable can work fine with other devices as these do not require a stable connection.

Also, make sure to try a different USB port and try if the issue persists when connected to a different computer.

1 Like

Hi i am facing the same issue tried multiple methods but no luck. It was working 2 weeks back but suddenly no usb connection.
Please help if this issue has been solved.

I found out that the Mac “Trust this accessory” popup flashed for a brief moment and disappeared so doing this worked, check it out if you’re on Mac:

  • Go to System Settings > Privacy & Security
  • Set “Allow accessories to connect” to “Automatically when unlocked”
  • Connect your Trezor
  • After you’re done you can turn it back to “Ask every time” or “Ask for new accessories” if you want to keep the security benefit of the setting, but you’ll have to repeat this every time you want to connect Trezor.
1 Like

Hi anyone fix this problem

I have been using my trezor every day “staking” with no problems, now all of a sudden i have this same error

no usb connection

How do we fix?