I sent Litecoin on Bitcoin address


I made a mistake. I wanted to send my litecoin from binance account on my hardwer wallet. I sent my litecoin on bitcoin address. Is there any possibility to receive my litecoin back ? Thanks for any help.


have a look into this topic Sent Litecoin to Bitcoin adress as we discussed this with other user.

I do not know how to downgrade my wallet. My firmware is 1.10 and i have to downgrade it to 1.6.

i tried to downgrade to 1.9 firmware. But now on display shows contact your support.

So i was following that steps. In electrum-LTC wallet i see my litecoins. I can not send them to my hardware wallet it says : RuntimeError(‘ProcessError: Failed to compile input’). So i was following next steps and tried to dowgrade my firmware from 1.10 to 1.9 and 1.6. When i did on display of wallet was written youa re in the boot mode. So i reseted wallet and it has again 1.10 firmware. I have no idea how to send them on my wallet. Please help.

Have you followed these instructions how to downgrade it?

Yea i did. Tried 1.6 and 1.9

Raise a support ticket using this form please and let me know the ticket ID. Thank you.

Ticket ID: 75536 aaaaaaaaaaaaaaaaaaa

i also saw that trezor site has tool for recovery coins. But when i open the link i am transfered on homepage.

The recovery can be done with the described steps only. Thank you for the ticket ID, we will have a look into it.

Should i wait for answer here ?

We will reply directly in the ticket.

Thanks for your help. I am waitting.

Have you idea how long is it gonna last ? I am a little scared whether i will not lose my litecoins

Can’t really tell, but don’t worry it won’t take a long time. I am sure we will help you to recover it. Recovering LTC from BTC addresses is quite a common thing and it works. We just need to help you a bit more with the firmware downgrade.

i installed trezor bridge and python. What to do next ? I am afraid that i will not get my litecoin back.


please be so kind to follow the conversation in the ticket. Thank you.

Mám stejný problém.
Poslal jsem LTC na adresu BTC začínající na 3.
Muj firmware trezoru je 1.10.1
Jak mam postupovat ?