I lost my wallet (cryptos) after firmware update

Unfortunately, I am forced to turn to the community with my problem, because the service provider could not a to help me (TicketID:166860).
Without excluding and avoiding my own responsibility, my goal is that all
I can examine a possible solution.
Trezor forced a firmware update for proper display of Ethereum , in February 2023.
During the update process, the Trezor device froze and had to be reset using Seed.
After updating the firmware, Trezor Suite does not show the previous wallet (addresses:
different than before which the coins are currently on).
After the firmware update, the addresses in the wallet do not match the previous addresses, a
the balances, unlike the previous ones, show 0 balances.
Previous addresses still have cryptos, they are still visible.
Coins are allowed.
The seed works ( we are in a wallet, the balance is zero)
The hidden wallet was not created.
For previous logins and checks (before firmware update), everything was fine.
The problem started after the 02/02/2023 firmware update and has persisted ever since.
The wallet was created in 2017 with an original Trezor Model One device.
We have never had another wallet, never had another seed, never used another Trezor
This is the only place where we store crypto.
The seed was recorded in writing.
The seed was not checked until the problem occurred.
Everything worked flawlessly until the February 2023 firmware update.
The firmware update failed the first time.
Wallet failed to recover after successful firmware update.
Currently, the seed points to a live wallet, but not ours, with zero balance,
the addresses are different. Scary!!!
You can find our cryptos at the previous addresses.

The crypto was credited to the wallet in 2017.
Tresor was new, the core was fixed exactly during installation, the cryptos were
they are visible during all checks and were available in the standard account created when a
a transaction has been initiated.
After installation (flashing) the seed was not checked again until the problem occurred, but
this was not necessary considering everything worked flawlessly. By the way
the need for this was never brought to our attention, e.g. before firmware update!)

What did we do to solve the problem?
The seed was recorded in writing.
The seed has been checked. It works, it’s fine. Balances show 0.
No password was entered either before or during the firmware update. We have a normal wallet.
Coins have been authorized.
We checked the possibility of segwit and legacy accounts.
We also checked the possibility of spelling words.
As far as we know - via internet -, there was a case in the past when the new wallet was generalized with an incorrect seed upon creation. This error was later corrected by Trezor and the problem was solved. It is possible that did this happen to us too? Please help: you may know someone with a similar problem
faced, who can give advice on the solution, to whom we can turn with confidence
with our questions?!

1 Like

There is a 1 in 256 chance that if you restore a seed with mistakes in it, it still opens a valid wallet.

Here are the key moments of your problem:

  1. you use your seed normally
  2. your wallet gets wiped
  3. you recover the wallet
  4. it’s a different wallet.

Given that you already tried most of the possibilities, the “different seed” hypothesis is basically sure to be it.

You might simply have made a mistake when entering the seed. Trezor One asks you to enter words in randomized order, perhaps you, e.g., entered word 15 instead of word 16 at one point, and simply through bad luck you got a valid but empty seed that way.

Please try to “check seed” now and see if the check succeeds. If not, you will need to wipe the Trezor and recover again.

If the seed check succeeds, that could mean that your seed is written down wrong. Perhaps you wrote words across instead of down? Try restoring in the other order. Or maybe one or two words are wrong. You would have to cross-check against the BIP-39 wordlist, look at each word and see whether it is possible that there’s a similar looking option.

Thank you for your advice!

After this, did you activate all the coins you have?

After restoring with your seed phrase, you will enter a normal wallet. Therefore, you need to either reactivate the “hidden wallet” feature and/or enter its passphrase (password).

Always ensure that you have recorded the seed phrase correctly. Newer firmware and software usually include a random test, where they ask you to enter some words from your seed phrase into the device.

I’m not sure what you mean, but I can only assume that you were either targeted or your computer might have been hacked, possibly with a keylogger. However, even if your PC was compromised, the device should have protected you from this. Also, I don’t understand what you mean by “live wallet.”

If you recorded your seed phrase incorrectly, such as in the wrong order, you would indeed create a different wallet, resulting in different addresses.

It’s unlikely that someone else could access your cryptocurrency unless you shared your seed phrase. If you recorded it offline on paper or etched it into a metal sheet, your crypto should be secure.

Please let us know if you’re still encountering issues. Verify whether you entered the seed phrase incorrectly. You can recover it by double-checking and arranging it in the correct order.

1 Like

Thank you for your answer!


1 Like