I have lost a wallet

I had to do a factory reset on my wallet. This was completed successfully but, I have managed to delete a wallet in the process. The funds are still visible on my Trezor through metamask??.
This screen is showing up in Trezor suite which I don’t understand? - one shows My Trezor wallet as connected and one shows My Trezor wallet as disconnected??

When you factory reset your Trezor and used the Recovery seed to restore your wallet, did you remember to recreate your Hidden wallet with your Passphrase?

If your funds are visible through Metamask, then you’re probably looking at a native Metamask account, not an account connected to your Trezor.

Make sure you’ve enabled/activated all coins you’re holding in Trezor suite.

BTW, is this issue connected to your lost Passphrase 5 days ago?

Hi. I am sorry - I think I am getting really confused over this.
I think what has happened is while I was trying to do a factory reset I think I have deleted my wallet out of trezor suite so- it was not a hidden wallet at all.

Your funds are not in your Trezor wallet, they’re stored in the blockchain(s). Trezor is just a key to your funds in the blockchain(s). So you can do a Factory reset anytime and recover your funds, so long as you have the Recovery seed and Passphrase (if used). If you have these, there’s not such thing as a lost wallet.

I see from your screenshot above that you use a Hidden wallet. From our earlier conversation, in the other thread, I think you’ve had that since before you did a Factory reset. Then you should be able to access it with your Passphrase – if you remember it. Did you write down your Passphrase on a piece of paper?

The problem here is that you use an advanced function – Hidden wallet – without knowing how it works. You should educate yourself before using any function in Trezor or risk losing your funds. Please read these forums, read blog articles released by SatoshiLabs, read the Trezor Wiki, and so on, before you use any Trezor function.

Yes, I totally agree with you.
This is what is confusing. I never set up a hidden wallet therefor, I never set a paraphrase.

I’m not sure I understand … are you saying that you created a new Hidden wallet but haven’t used it? You never used a Hidden wallet to store your funds in?

You may’ve simply created it by accident then, when trying out the feature. If you “login” to a Hidden wallet and the Passphrase you specify doesn’t exist along with your Recovery seed (Recovery seed + Passphrase = key to Hidden wallet), then a new blank Hidden wallet will be created for you. That’s standard operation.

I’d like to go back to what you said earlier, that you see your funds through MetaMask. Can you please show us an image of that? Take a screenshot of your MetaMask connection to Trezor that shows your funds, please. Blur out any sensitive data before posting here.

Hi. This is the view in Metamask. I notice it is saying the Trezor is not connected.

Thank you for your help

I think MetaMask just remembers your last balance. Try and connect your Trezor then and tell us what it shows in MetaMask.

BTW, are you sure you used the correct Recovery seed when you recovered your Trezor wallet after the Factory reset?

Note that the Recovery seed for your Trezor and the Recovery seed for MetaMask are two very different things, although they look alike but shouldn’t (mustn’t) have the same words, so if you used the one for MetaMask to recover your Trezor wallet it won’t work.

A Recovery seed looks like this (example) and must be kept written down, private and not shared with anyone:

Yeah, I definitely used the Trezor seed for the recovery.
I put what I think is the paraphrase in metamask and it was giving me a list of 30 addresses.
I have an address that was used but it was none of the ones metamask was suggesting?

Good. So since you never used a Hidden wallet with a Passphrase, that means you’re only recovering a Standard wallet in your Trezor.

Those are generated Receive addresses, maybe from your Trezor.

You said above that you never used a Passphrase, so which Passphrase did you enter and why?

Note that both Trezor and MetaMask (MM) have their own wallet, receive addresses, recovery seed, and passphrase (password in MM, I think). It’s important to keep these apart. Don’t use MM’s Password as Passphrase in Trezor or vice versa.

See here for an explanation:

I never used a native MM wallet myself, only the Trezor connected ones (“Trezor 1” and “Trezor 2” in the linked post), because I only store coins with my Trezor. It simplifies things a lot. For instance I don’t have to be afraid to lose the MM recovery seed because I never had any funds stored in MM. But if you use native MM accounts, you must know what you do and keep all accounts and keys separate.

It could be an address linked to a native MM account, I don’t know. It’s difficult to know without seeing the address and what you see in your setup. The key to solving this is that you provide more information.

Below you see my accounts in MM. I only use the Trezor connected one, not the native MM account so that is zero:

If you click on that multicolored icon on the top right in MM, you can see your own accounts. Please post a screenshot here (and blur out any info you don’t want to publish).

then leave the passphrase empty, just connect exactly same way as before, just because you recovered wallet nothing has changed. Do the same thing as before.

Also, check if your seed is correct (Settings, Device, Check Backup)

You are just looking for ETH so it will be visible in Suite too, if you do not see it you are in the wrong wallet (and make sure ETH is turned on in the settings).

You said above that you never used a Passphrase, so which Passphrase did you enter and why?

I used ********** general password code i use.

The below screenshot shows the Trezor is now connected. It still is not showing in trezor suite!

Petosris - thank you again for the help

Please don’t post passwords or other sensitive data here. I edited your message and changed it with asterisks.

You’re not supposed to use a password when you login to Trezor suite. Since you didn’t create and use a Hidden wallet, select the Standard wallet. No Passphrase needed.

As @forgi says above, when you connect your Trezor to Metamask, leave the Passphrase fields blank and just press enter. Then you will connect to your Standard wallet.

Also, as he says, check your Recovery seed in Settings → Device → Check Backup, and that ETH is activated in Trezor suite (Settings → Crypto) so the Discovery process will start looking for your funds in the blockchain.

Okay I have checked the see again and Trezor says its ok.
when I try and reset my Trezor to matamask it comes up with the following on login
with persmissions not granted at top of screen?

1 Like

can you use the same one in Trezor Suite? Then you will see the same address as in MM

Sorry, I am not sure what you mean?

I deleted my wallet.
I have my seed and this verifies once I do a factory reset.
My issue is my wallet does not rebuild
Trezor stated that I must have set a paraphrase for a hidden wallet
Although I do not think I had set a paraphrase I tried a myriad of options if I had set a paraphrase non of which worked
Then Trezor informed me that when I have connected using Metamask it is setup to enable a passphrase as a default! This is very concerning for me.
Can I restore my wallet using my seed and my public key?
I’ve read that you can use BTC recover to do this?
Please help me?..